Switch to branch 14

hello everyone. anyone managed to switch to 14 . because I cant do it saying “Specified branch of app erpnext is not in upstream”. I tried version-14 , version14 , v14.0.0-beta.1, none of them works.

1 Like

use

bench switch-to-branch version-14-beta frappe erpnext --upgrade

2 Likes

@mohitchechani is it working for you ? I just got a list of errors after updating , the ui is not even working

Even I am getting issue while upgrading from develop branch or stable branch.

But working on fresh installation.

I have a working (so far)

ERPNext: v14.0.0-beta.1 (version-14-beta-pre-release)
Frappe Framework: v14.x.x-develop () (develop)

Fresh install on a Ubuntu 20 , used run-tests to populate with data. Seems usable for testing.

hi do you have a guide how u install the beta
can you share

In my case I had a frappe/bench v13 on Ubuntu 18 that stopped working after upgrading the OS to 20. I had a second vm as a backup and used that for operations. After alot of trial and error I decided I would get a working bench, then install ERPNext on a new site with v14 and run tests to try it out.

OS: Ubuntu 20.04.4 LTS
Python: 3.8.10
node: v14.19.0
yarn: v1.22.17
Mariadb: Ver 15.1 Distrib 10.3.34-MariaDB
Redis: 5.0.7
Nginx: 1.18.0
Pip3: pip 21.3.1

I suggest following the steps for installing frappe-bench for whatever OS on this page , then once you have a working bench:

bench new-site <sitename>
bench get-app --branch version-14-beta-pre-release erpnext
bench --site <sitename> install-app erpnext

As some of our wiser contributors would say: YMMV

1 Like

Can version-14-beta-pre-release erpnext install on frappe13 ?

IMHO Major versions should be aligned …

Hi,

May we know the operating environment and version of ERPNext that is currently in use? The error message suggests that the node package is not compatable, what does: node -v return?