Supplier bank account displayed in the sales invoice

while making invoices we created the field bank account but while selection it shows supplier bank account as well as we need to show only company account how to achieve or how we can create filter for the field to display only company account

another scenario when we make payment entry and select the party type as customer then also supplier bank account fetches in the party account

dose anyone have observed the slimier issue

Hi Abhijit,

Are you talking about the document? Or the print format?

If it is the document, I think if you clear the field while making the invoice, you should be able to solve this.

If it is in the print format, you have to change the print format and remove this from the fields and values that are getting printed.

Hope this helps.

Thanks

Jay

Hi,
Thanks for the immediate reply
i am talking about the document, refer below snap


here it is expected to display only company bank account but the field is showing
supplier bank account, although we declared in the bank account party type as supplier

Regards
Abhijit Undre

Ahh! You mean there are no filters there restricting the Bank Accounts to the Party Type.

Make a GitHub issue and maybe it will get addressed soon, Here’s where you can make a GitHub issue: https://github.com/frappe/erpnext/issues

Thanks

Jay

You can set a default value for the bank field via customize form:

https://docs.erpnext.com/docs/user/manual/en/customize-erpnext/custom-field#11-additional-details

You can possibly look at custom script option to add filter option.