Sudo not working on vm 190614

Hi,

I downloaded the image from https://erpnext.com/downloads/ERPNext190614.ova and got it working perfectly first time. Thank you for the great work!

However, since I'm in Belgium, I'd like to change the keyboard configuration. On debian you should run the command 'sudo dpkg-reconfigure keyboard-configuration'. You have to enter the password for user erpnext so I type erpnext as the password. I get greeted with an error:

'Sorry, user erpnext is not allowed to execute ... as root on ...'

For any other command such as 'sudo ls' I get the same.

Any ideas?

Regards,

Midnight.



Note:

 

If you are posting an issue,

 

  1. ERPNext is a free and open source software and support is given on this forum by a team (https://frappe.io/webnotes). So please consider donating if you find this forum useful (https://frappe.io/buy). Even a small amount would be helpful.
  2. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  3. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  4. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/2a5b5386-643a-4aa7-a80b-33d57ed9cc43%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.
I did manage to do 'su' and then 'dpkg-reconfigure' so the keyboard problems are solved. However, I do find it strange that sudo does not work?

Op woensdag 30 juli 2014 15:28:54 UTC+2 schreef MidnightBolt:
Hi,

I downloaded the image from https://erpnext.com/downloads/ERPNext190614.ova and got it working perfectly first time. Thank you for the great work!

However, since I'm in Belgium, I'd like to change the keyboard configuration. On debian you should run the command 'sudo dpkg-reconfigure keyboard-configuration'. You have to enter the password for user erpnext so I type erpnext as the password. I get greeted with an error:

'Sorry, user erpnext is not allowed to execute ... as root on ...'

For any other command such as 'sudo ls' I get the same.

Any ideas?

Regards,

Midnight.



Note:

 

If you are posting an issue,

 

  1. ERPNext is a free and open source software and support is given on this forum by a team (https://frappe.io/webnotes). So please consider donating if you find this forum useful (https://frappe.io/buy). Even a small amount would be helpful.
  2. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  3. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  4. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/3405e428-6a9e-46a2-bc6b-f4dbb5c45217%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

On Wed, Jul 30, 2014 at 7:15 PM, MidnightBolt de...@gmail.com wrote:

I did manage to do ‘su’ and then ‘dpkg-reconfigure’ so the keyboard problems
are solved. However, I do find it strange that sudo does not work?

The password for root and erpnext are same, ‘erpnext’.

When you use su, you have to enter root password which you entered correctly :slight_smile:

Thanks,

Pratik
erpnext

I get “user erpnext is not allowed to execute…”

run this command as root