Try ERPNext Buy Support Partners Foundation Foundation Members

Strange behaviour on Stock Entry after finishing Work Order (blue indicators)

I have a strange behaviour when finishing a Work Order, with Stock Entry for Manufacture.

Here is the BOM of produced Item:

After clicking Finish on the Work Order, a Stock Entry is generated with strange Items with Blue Indicator:

Why are the Rows have duplicate numbers? Why are there duplicate positions (f.e. BL-#75-S355 is indicated two times; once for 40kg with blue indicator [no idea what is it], and second time for 126,9kg [proper value from BOM])

Also, when trying to save the Stock Entry I get a message/error:
image

Thank you kindly for any advice!

The blue indicators depict that this is the manufactured Item out of the raw materials. Please check your Bill of Materials to see the finished goods/sub assemblies and confirm.

2 Likes

@Jai_Chavan the only manufactured item is Ripper-18-CW20-9W2451 - row 16

All other three Items with blue indicator is actually steel. They are duplicated (please compare row 1 - BL-#30-S355 and row 6 - BL-#30-S355 - why the duplicate?)

When I manually delete the three wrong Items with blue indicator:

  • I can submit the Stock Entry without error
  • The rows get numbered properly

Any ideas where these blue Items come from?
In my understanding only the last row should be blue.
BOM for Ripper-18-CW20-9W2451 contains exactly the Items with green indicator. I can’t understand where and why did the blue indicator items and qtys came from.

Pls help! :slight_smile:

Need to check the BOM to comment to debug this. Please share a screenshot of the BOM so that we can help you better!

1 Like

It’s in the first Screenshot. Do you need it different?

@Jai_Chavan

@Jai_Chavan and here’s BOM for Adapter-CW20-z PŁYTĄ-RIPPER

@Jai_Chavan and here is the BOM Explorer:

@Jai_Chavan hey Jai, maybe you had time to check this strange behaviour out?

Hello Dear Community,

Could anyone reproduce the error/strange behaviour on their instance?

Can I give any more information? Maybe I should add a support ticket?

Thank you kindly for any help :slight_smile:

Maybe your BOM produces the subcomponents that also have BOM

@Joseph_Marie_Alba thank you for taking your time.
I think the BOM Explorer actually shows all the BOM levels.
In other words, all the bottom level BOM items are basic items without a BOM. They are purchased.

Any ideas? :slight_smile: