Try ERPNext Buy Support Partners Foundation

Stop ._ file creation on virtual machine when accessing samba share from MAC OS X Host

Had been getting a lot of errors on bench migrate when compiling some .py files due to the fact that the MAC OS X host, when accessing the Virtual Machine linux vía Samba share, creates a meta file pre-pended by ._.

To stop this when using regardless of the editor you use, add this to your samba share configuration for all the folders you share from your virtual machine for development.

As root or sudo enabled user
sudo nano /etc/samba/smb.conf

Then in the share definition, add these lines:

veto files = /._*/.DS_Store/
delete veto files = yes

CTRL +X, Y, ENTER

Restart your samba service or reboot for changes to take effect.

sudo service smbd restart

Now I run bench migrate with confidence, regardless of which dev text editor I use.