ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

SSL certificate causing malfunction?

Hi

I stumbled accross something that is happening on my one server. And I started investigating.
What is happening , is that I enter Purchase Invoices of stock that I purchased but when I
try and access the 'Stock Balance" , the “Generate New Report” button top right, is malfunctioning. You can click it once but then it freezes. You can still click “Refresh” and
that somtimes works. Same in “Stock Ledger” report.

Here are the 3 servers I tested it on…

Server 1: (with SSL certificate)
ERPNext: v12.24.0 (version-12)
Frappe Framework: v12.21.0 (version-12)
2 CPu 4 G RAM, Ubunto 18.04

Server 2: (with SSL certificate)
ERPNext: v12.26.0 (version-12)
Frappe Framework: v12.23.0 (version-12
2 CPu 4 G RAM, Ubunto 18.04

Server 3 : (NO SSl certificate)
ERPNext: v12.26.0 (version-12)
Frappe Framework: v12.23.0 (version-12
2 CPu 4 G RAM, Ubunto 18.04

Servers 1 & 2 exibits the strange behaviour and server 3 works normally.

I had a look at a posting about setting up SSL on ERPnext

It refers to a video that follows a very manual process of setting up SSL.

The procedure that I followed is according to this link …
https://frappeframework.com/docs/user/en/bench/guides/configuring-https
which relies on the bench command to do the hard work.

I am still looking to see if I can see a difference.

Is it possible that my SSL certificate setup could be “half-broken”, that it actually works,
but messes up the interface in the “Stock” reports.

BTW … if I access the Mariadb database via the backend, then the tabStock Ledger table
contains all the ledger transactions ( I checked this only on server 1 ). So the info is there but
it doesn’t display it in the Stock Ledger report. ( And Stock Balance)

Does anyone perhaps have some advise , a comment or anything, please.

Depends on how much data you’re servers have.
Check status if the report in prepared report.