Split of revenue for each month (In deferred revenue)

Hi
Can anyone help me please. Actually i have created a sales invoice with a deferred revenue account .See below snap shots:
But i could not find the spit of revenue for each month

Regards
Trishty

Use the “Sales Analytics” Report.

Even the sales analytic report does not show the split of revenue for each month.

Oh yes it does.

I also experiences this to the deferred expense. The system does not create an automatic journal entry. @trishty_thakoor have you solve this? my Erpnext version is below. I am not sure if the version can affect the auto journal.

ERPNext: v12.4.2 (version-12)
Frappe Framework: v12.2.1 (version-12)

I also so this feature on odoo which is good. Do erpnext has this? to see all list of deffered revenue and expense so you can monitor it?
https://www.odoo.com/documentation/user/13.0/accounting/payables/supplier_bills/deferred_expenses.html#:~:text=A%20Deferred%20Expense%20entry%20automatically,and%20fill%20out%20the%20form.

Same problem for me with v13.7.0 not seeing errors, tested with different options (automatic or not, journal entry or not, draft or submitted, expense or income…)
@Deepesh_Garg i see your worked a lot on this subject, maybe you can help ?
Same problem here i think Deferred revenue in sales invoice

Thanks in advance for your answers,
Sincerely yours,
Martin

PS : using frappe_docker swarm mode

did you find solution for this??

did you find solution for this ???

Hey,
Working for me (frappe v13.14.0, ERPNext v13.14.1), i think it was a problem of misunderstanding how Deferred Accounting worked, i invite your to read the documentation about Deferred Accounting again, and try it manually before trying to do it automatically. It is important that the service start date and end date corresponds with data in your sales invoice.
Hope it could help,
Sincerely yours,
Martin

Hey did you ever find the problem? I’m having the same issue. When processing deferred expenses, some transactions aren’t being booked automatically.

I’m still facing same issue
sometime, it didn’t post automatically
I don’t know how to post manually as well

In accounts settings, try changing “Book Deferred Entries Based On” to days instead of months. See if that solves the problems you are having.

I don’t know how to post manually as well

Hi, to do it manually, go under accounting settings and uncheck Automatically Process Deferred Accounting Entries.
Create a new Sales / Purchase Invoice with Deferred accounting. Process Deferred Accounting Manuallly, be sure the period matches with the period of Deferred Accounting in your Sales Invoice.
When using it in automatic mode, it is created a the beginning of the period i think.