ERPNext.com Frappe Cloud Documentation Partners Frappe School Public Chat

[Solved] What changed in install.py today?!? Worked this morning, Fails now. (v13.1.1 & v13.2.x)

First, nginx and supervisor does not have anything to do when you use bench start (you are in develop mode). Nginx and supervisor are only used on production mode.

Second, When you are in develop mode, your system will not restart automatically (when you use bench start).

If you want ERPNext to start-up automatically when VPS reboots, you must be in production mode. You use bench restart in production mode.

There are some discussions here on what is the difference between develop and production mode.

1 Like

Failed with the same error.

       "    main()",
        "  File \"/home/adliyaph/frappe-bench/apps/frappe/frappe/utils/bench_helper.py\", line 18, in main",
        "    click.Group(commands=commands)(prog_name='bench')",
        "  File \"/home/adliyaph/frappe-bench/env/lib/python3.8/site-packages/click/core.py\", line 764, in __call__",
        "    return self.main(*args, **kwargs)",
        "  File \"/home/adliyaph/frappe-bench/env/lib/python3.8/site-packages/click/core.py\", line 717, in main",
        "    rv = self.invoke(ctx)",
        "  File \"/home/adliyaph/frappe-bench/env/lib/python3.8/site-packages/click/core.py\", line 1137, in invoke",
        "    return _process_result(sub_ctx.command.invoke(sub_ctx))",
        "  File \"/home/adliyaph/frappe-bench/env/lib/python3.8/site-packages/click/core.py\", line 1137, in invoke",
        "    return _process_result(sub_ctx.command.invoke(sub_ctx))",
        "  File \"/home/adliyaph/frappe-bench/env/lib/python3.8/site-packages/click/core.py\", line 956, in invoke",
        "    return ctx.invoke(self.callback, **ctx.params)",
        "  File \"/home/adliyaph/frappe-bench/env/lib/python3.8/site-packages/click/core.py\", line 555, in invoke",
        "    return callback(*args, **kwargs)",
        "  File \"/home/adliyaph/frappe-bench/apps/frappe/frappe/commands/site.py\", line 41, in new_site",
        "    frappe.init(site=site, new_site=True)",
        "  File \"/home/adliyaph/frappe-bench/apps/frappe/frappe/__init__.py\", line 175, in init",
        "    setup_module_map()",
        "  File \"/home/adliyaph/frappe-bench/apps/frappe/frappe/__init__.py\", line 1019, in setup_module_map",
        "    for module in get_module_list(app):",
        "  File \"/home/adliyaph/frappe-bench/apps/frappe/frappe/__init__.py\", line 882, in get_module_list",
        "    return get_file_items(os.path.join(os.path.dirname(get_module(app_name).__file__), \"modules.txt\"))",
        "  File \"/home/adliyaph/frappe-bench/apps/frappe/frappe/__init__.py\", line 840, in get_module",
        "    return importlib.import_module(modulename)",
        "  File \"/usr/lib/python3.8/importlib/__init__.py\", line 127, in import_module",
        "    return _bootstrap._gcd_import(name[level:], package, level)",
        "  File \"<frozen importlib._bootstrap>\", line 1014, in _gcd_import",
        "  File \"<frozen importlib._bootstrap>\", line 991, in _find_and_load",
        "  File \"<frozen importlib._bootstrap>\", line 973, in _find_and_load_unlocked",
        "ModuleNotFoundError: No module named 'erpnext'"
    ],
    "stdout": "",
    "stdout_lines": []
}

PLAY RECAP *********************************************************************
localhost                  : ok=80   changed=46   unreachable=0    failed=1    skipped=61   rescued=0    ignored=0   

Update:
I installed python3.6 and switch bench env to it and then installed all requirements for erpnext.
even did
pip install cython as it was missing still getting the same error
Error Log

It looks like you don’t have erpnext / frappe installed.

Not yet. The only thing I have working is the 24 steps posted in this thread. The Easy Install is still broken.

BKM

I have never tried Ubuntu 20.10. That is not the LTS release so I tend to stay away from the non-LTS releases because they tend to change to often.

BKM

1 Like

In the file below:

/etc/redis/redis.conf

Change bind 127.0.0.1 ::1 as bind 127.0.0.1
and run install.py again

Thanks for the clarifications, I didn’t know I was in dev mode since bkm’s tutorial was setting up for production. I can’t seem to find the documentation I want about the ERPNext app itself, inside Bench’s site. Also, the fact that I just now started a Linux course probably has something to do with my problems. That’s why I say, thanks for the help. I’ll search more about that.

Documentation began to make more sense much later. But it helped that I read it. Meantime, if you feel in a dead end anytime, just post in this forum.

1 Like

i have a permision error but the solution is add

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock
sudo -s

Great guide!! :slight_smile:
trying to install frappe without ERPNext.
got all the way to

created a blank app using bench new-app [appname] as described here and installed using bench --site site.local install-app [app-name]
all went well including an addition of

the only problem is: I rebooted and I can’t load the site (“The connection was reset” on port 8000)
:-\

:man_facepalming:
my bad…
port 80 works fine.
:slight_smile:

Welcome to the community @alonbr

Happy to hear that you were able to use this to get a success story in your ERPNext adventure.

Thanks for posting your results.

BKM

Following these steps, I could install v13 on ubuntu 20.04lts in Virtualbox, but after step 24 reboot the server, I access the site using the host browser its load without styling and js, console shows the error

GET http://127.0.0.1:9090/assets/js/erpnext-web.min.js?ver=NJhpQxSv net::ERR_ABORTED 404 (Not Found)

Couldn’t figure out the solution.

You could try building the CSS and JS assets manually. Make your current, working directory frappe_bench. Then execute this command:

bench build

This command creates all the minified files that the browser is expecting to see.

I used this command and tried clearing the browser cache and also check with different browsers but couldn’t get successful results. :neutral_face:

used this command too
bench update --build

Hmm. When you ran the bench build, did it list the file js/erpnext-web.min.js ?

I ran this a moment ago, and took a screenshot for you:

image

The other possibility is the file exists, but the permissions are incorrect. This would prevent the web server from accessing the file, and providing it to your browser.

If you can find the file, perhaps check the permissions, and make sure it’s readable?

I got the output as your screenshot. (successful build)
Since this was not successful, I moved to docker installation and currently struggling with it.
let me check the file permission. will update the thread with the result asap.

I used this method on two digitalocean ubuntu 20.04 droplets and everything went ok but I have the same issue on both installations:
I am unable to email new POS Invoice Receipt after I Complete Order in the POS System;
When I click on “Email Receipt” it offers me the option to provide the email address.
After I input the email address and I click Send it shows a notification “Email Sent Successfully.” But the email is not sent. When I look at the error logs two new errors are generated as shown below:
one error says “frappe.core.doctype.communication.email.sendmail”
and the other is show in the screenshot below


my installations are as follows:
erpnext 13.9.2
frappe 13.9.1
and
erpnext 13.10.0
frappe 13.10.0

I can send other types of emails from within erpnext meaning my Email Domain (gmail) and Email Accounts are working.

For the sake of the community please reply to the following main thread if you got a solution I can try out.

Please help, thank you in advance.

This looks like a problem in the POS module. If email works everywhere else then something changed in the POS section.

While I concur this is a problem, it is NOT the topic of this thread. If you really want help with this you should start a fresh thread dedicated to this new bug in v13.9 and 13.10. Hiding your issue here in this thread will not get the recognition you might need by the community to find a resolution.

BKM

I already created a main thread a day ago but no replies yet but there is a alot of traffic here so I might get help; or at least get another person getting same error and thus I might rule out my installation being the issue. So please understand.