[SOLVED] Error while accessing Production Environment (404)

Guys, was able to install with out any errors during my latest iteration, if i’m able to pin the issue or find any errors will post the details.

Meanwhile, after completing the setup, i tried the following command to test the system and getting following error …

[frappe@localhost frappe-bench]$ curl -I http://localhost:8000
HTTP/1.1 404 NOT FOUND
Server: gunicorn/19.6.0
Date: Thu, 04 Aug 2016 12:12:54 GMT
Connection: close
Content-Type: text/html
Content-Length: 155

And i’m not able to access the ERPNext from my host browser with the IP 8000 …
I’m using NAT and my URL is “http://192.168.146.135:8000” and i’m getting the 404 error

Can you guys direct me to the solution ? i have checked all the services and logs only error i found in the log is …

IncorrectSitePath: 404: Not Found
[2016-08-04 17:35:20 +0000] [3059] [INFO] Starting gunicorn 19.6.0
[2016-08-04 17:35:20 +0000] [3059] [INFO] Listening at: http://127.0.0.1:8000 (3059)
[2016-08-04 17:35:20 +0000] [3059] [INFO] Using worker: sync
[2016-08-04 17:35:20 +0000] [3120] [INFO] Booting worker with pid: 3120
[2016-08-04 17:35:55 +0000] [3149] [INFO] Starting gunicorn 19.6.0
[2016-08-04 17:35:55 +0000] [3149] [INFO] Listening at: http://127.0.0.1:8000 (3149)
[2016-08-04 17:35:55 +0000] [3149] [INFO] Using worker: sync
[2016-08-04 17:35:55 +0000] [3210] [INFO] Booting worker with pid: 3210
[2016-08-04 17:40:52 +0000] [3149] [INFO] Handling signal: term
[2016-08-04 17:40:52 +0000] [3210] [INFO] Worker exiting (pid: 3210)
[2016-08-04 17:40:52 +0000] [3149] [INFO] Shutting down: Master
[2016-08-04 17:41:05 +0000] [3564] [INFO] Starting gunicorn 19.6.0
[2016-08-04 17:41:05 +0000] [3564] [INFO] Listening at: http://127.0.0.1:8000 (3564)
[2016-08-04 17:41:05 +0000] [3564] [INFO] Using worker: sync
[2016-08-04 17:41:05 +0000] [3598] [INFO] Booting worker with pid: 3598
2016-08-04 17:42:54,666 - /home/frappe/frappe-bench/apps/frappe/frappe/app.py [ERROR]:
Site: localhost
Request Error
Traceback (most recent call last):
File "/home/frappe/frappe-bench/apps/frappe/frappe/app.py", line 52, in application
init_request(request)
File "/home/frappe/frappe-bench/apps/frappe/frappe/app.py", line 102, in init_request
frappe.init(site=site, sites_path=sites_path)
File "/home/frappe/frappe-bench/apps/frappe/frappe/__init_.py", line 121, in init
local.conf = dict(get_site_config())
File "/home/frappe/frappe-bench/apps/frappe/frappe/__init_.py", line 175, in get_site_config
raise IncorrectSitePath, "{0} does not exist".format(site_config)
IncorrectSitePath: 404: Not Found

Thanks,
Prashanth

5 posts were merged into an existing topic: Localhost:8080 doesn’t respond after installation