[solved] Bench start problem socket.io?

New install on centos7 machine at home - development - easy install
When I use bench start get the following: at 12:58:31 text is in red

Any help appreciated - not very linux fluent

[erp@localhost frappe-bench]$ bench start
12:58:31 system | worker_long.1 started (pid=12600)
12:58:31 system | redis_socketio.1 started (pid=12598)
12:58:31 system | watch.1 started (pid=12602)
12:58:31 system | schedule.1 started (pid=12611)
12:58:31 system | web.1 started (pid=12606)
12:58:31 system | redis_queue.1 started (pid=12604)
12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.440 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.440 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.440 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
12:58:31 system | worker_default.1 started (pid=12614)
12:58:31 redis_socketio.1 | .
12:58:31 redis_socketio.1 | .-__ ''-._ 12:58:31 redis_socketio.1 | _.- . . ‘’-._ Redis 3.2.12 (00000000/0) 64 bit
12:58:31 redis_socketio.1 | .- .-```. ```\/ _.,_ ''-._ 12:58:31 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 12:58:31 redis_socketio.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 12000 12:58:31 redis_socketio.1 | | -. ._ / _.-' | PID: 12598 12:58:31 redis_socketio.1 | -._ -._ -./ .-’ .-’
12:58:31 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 12:58:31 redis_socketio.1 | | -.
-._ _.-'_.-' | http://redis.io 12:58:31 redis_socketio.1 | -._ -._-..-’.-’ .-’
12:58:31 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 12:58:31 redis_socketio.1 | | -.
-._ _.-'_.-' | 12:58:31 redis_socketio.1 | -._ -._-.
.-’.-’ .-’
12:58:31 redis_socketio.1 | -._ -.__.-’ .-’
12:58:31 redis_socketio.1 | -._ _.-' 12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.441 # You requested maxclients of 10000 requiring at least 10032 max file descriptors. 12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.441 # Server can't set maximum open files to 10032 because of OS error: Operation not permitted. 12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.441 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase 'ulimit -n'. 12:58:31 redis_queue.1 | _._ 12:58:31 redis_queue.1 | _.-``__ ''-._ 12:58:31 redis_queue.1 | _.-`` . _. ''-._ Redis 3.2.12 (00000000/0) 64 bit 12:58:31 redis_queue.1 | .-`` .-```. ```\/ _.,_ ''-._ 12:58:31 redis_queue.1 | ( ' , .- | , ) Running in standalone mode 12:58:31 redis_queue.1 | |-.
-...- …-.-._|'` _.-'| Port: 11000 12:58:31 redis_queue.1 | | `-._ `._ / _.-' | PID: 12604 12:58:31 redis_queue.1 | `-._ `-._ `-./ _.-' _.-' 12:58:31 redis_queue.1 | |`-._`-._ `-.__.-' _.-'_.-'| 12:58:31 redis_queue.1 | | `-._`-._ _.-'_.-' | http://redis.io 12:58:31 redis_queue.1 | `-._ `-._`-.__.-'_.-' _.-' 12:58:31 redis_queue.1 | |`-._`-._ `-.__.-' _.-'_.-'| 12:58:31 redis_queue.1 | | `-._`-._ _.-'_.-' | 12:58:31 redis_queue.1 | `-._ `-._`-.__.-'_.-' _.-' 12:58:31 redis_queue.1 | `-._ `-.__.-' _.-' 12:58:31 redis_queue.1 | `-._ _.-' 12:58:31 redis_queue.1 | `-.__.-' 12:58:31 redis_queue.1 | 12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.442 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128. 12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.442 # Server started, Redis version 3.2.12 12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.442 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect. 12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.442 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled. 12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.442 * The server is now ready to accept connections on port 11000 12:58:31 redis_socketio.1 | `-.__.-' 12:58:31 redis_socketio.1 | 12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.441 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128. 12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.441 # Server started, Redis version 3.2.12 12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.441 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect. 12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.441 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled. 12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.441 * The server is now ready to accept connections on port 12000 12:58:31 system | redis_cache.1 started (pid=12617) 12:58:31 system | socketio.1 started (pid=12619) 12:58:31 system | worker_short.1 started (pid=12620) 12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.447 # You requested maxclients of 10000 requiring at least 10032 max file descriptors. 12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.447 # Server can't set maximum open files to 10032 because of OS error: Operation not permitted. 12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.447 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase 'ulimit -n'. 12:58:31 redis_cache.1 | _._ 12:58:31 redis_cache.1 | _.- ‘’-.

12:58:31 redis_cache.1 | .- `. `_. ''-._ Redis 3.2.12 (00000000/0) 64 bit 12:58:31 redis_cache.1 | .- .-. / ., ‘’-.
12:58:31 redis_cache.1 | ( ’ , .- |, ) Running in standalone mode
12:58:31 redis_cache.1 | |-._-…- __...-.``-._|' .-’| Port: 13000
12:58:31 redis_cache.1 | | -._ .
/ .-’ | PID: 12617
12:58:31 redis_cache.1 | -._ -.
-./ _.-' _.-' 12:58:31 redis_cache.1 | |-.
-._ -..-’ .-’.-’|
12:58:31 redis_cache.1 | | -._-._ .-’.-’ | http://redis.io
12:58:31 redis_cache.1 | -._ -.-.__.-'_.-' _.-' 12:58:31 redis_cache.1 | |-.-._ -.
.-’ .-’.-’|
12:58:31 redis_cache.1 | | -._-._ .-’.-’ |
12:58:31 redis_cache.1 | -._ -.-.__.-'_.-' _.-' 12:58:31 redis_cache.1 | -. -.__.-' _.-' 12:58:31 redis_cache.1 | -._ _.-’
12:58:31 redis_cache.1 | `-.__.-’
12:58:31 redis_cache.1 |
12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.447 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.447 # Server started, Redis version 3.2.12
12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.447 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.448 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.448 * The server is now ready to accept connections on port 13000
12:58:31 socketio.1 | /home/erp/frappe-bench/node_modules/ws/lib/websocket.js:348
12:58:31 socketio.1 | …options
12:58:31 socketio.1 | ^^^
12:58:31 socketio.1 |
12:58:31 socketio.1 | SyntaxError: Unexpected token …
12:58:31 socketio.1 | at createScript (vm.js:56:10)
12:58:31 socketio.1 | at Object.runInThisContext (vm.js:97:10)
12:58:31 socketio.1 | at Module._compile (module.js:549:28)
12:58:31 socketio.1 | at Object.Module._extensions…js (module.js:586:10)
12:58:31 socketio.1 | at Module.load (module.js:494:32)
12:58:31 socketio.1 | at tryModuleLoad (module.js:453:12)
12:58:31 socketio.1 | at Function.Module._load (module.js:445:3)
12:58:31 socketio.1 | at Module.require (module.js:504:17)
12:58:31 socketio.1 | at require (internal/module.js:20:19)
12:58:31 socketio.1 | at Object. (/home/erp/frappe-bench/node_modules/ws/index.js:3:19)
12:58:31 system | socketio.1 stopped (rc=1)
12:58:31 system | sending SIGTERM to redis_socketio.1 (pid 12598)
12:58:31 system | sending SIGTERM to worker_long.1 (pid 12600)
12:58:31 system | sending SIGTERM to watch.1 (pid 12602)
12:58:31 system | sending SIGTERM to redis_queue.1 (pid 12604)
12:58:31 system | sending SIGTERM to web.1 (pid 12606)
12:58:31 system | sending SIGTERM to schedule.1 (pid 12611)
12:58:31 system | sending SIGTERM to worker_default.1 (pid 12614)
12:58:31 system | sending SIGTERM to redis_cache.1 (pid 12617)
12:58:31 system | sending SIGTERM to worker_short.1 (pid 12620)
12:58:31 redis_socketio.1 | 12598:signal-handler (1586019511) Received SIGTERM scheduling shutdown…
12:58:31 redis_queue.1 | 12604:signal-handler (1586019511) Received SIGTERM scheduling shutdown…
12:58:31 redis_cache.1 | 12617:signal-handler (1586019511) Received SIGTERM scheduling shutdown…
12:58:31 system | schedule.1 stopped (rc=-15)
12:58:31 system | worker_long.1 stopped (rc=-15)
12:58:31 system | worker_default.1 stopped (rc=-15)
12:58:31 system | worker_short.1 stopped (rc=-15)
12:58:31 system | watch.1 stopped (rc=-15)
12:58:31 system | web.1 stopped (rc=-15)
12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.942 # User requested shutdown…
12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.942 * Removing the pid file.
12:58:31 redis_socketio.1 | 12598:M 04 Apr 12:58:31.942 # Redis is now ready to exit, bye bye…
12:58:31 system | redis_socketio.1 stopped (rc=0)
12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.943 # User requested shutdown…
12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.943 * Removing the pid file.
12:58:31 redis_queue.1 | 12604:M 04 Apr 12:58:31.943 # Redis is now ready to exit, bye bye…
12:58:31 system | redis_queue.1 stopped (rc=0)
12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.948 # User requested shutdown…
12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.949 * Removing the pid file.
12:58:31 redis_cache.1 | 12617:M 04 Apr 12:58:31.949 # Redis is now ready to exit, bye bye…
12:58:31 system | redis_cache.1 stopped (rc=0)
[erp@localhost frappe-bench]$ bench --help

12:58:31 socketio.1 is in red

Welcome to ERPNext!

Try recompiling the client side code with this:

bench build

For reference:

frappe@ubuntu:~/frappe-bench$ bench --help | grep build
remove-app Completely remove app from bench and re-build…
build Minify + concatenate JS and CSS files, build…
build-message-files Build message files for translation
migrate Run patches, sync schema and rebuild…
rebuild-global-search Setup help table in the current site (called…

Bench build

[erp@localhost frappe-bench]$ bench build
yarn run v1.22.4
$ FRAPPE_ENV=production node rollup/build.js
module.js:478
throw err;
^

Error: Cannot find module ‘rollup’
at Function.Module._resolveFilename (module.js:476:15)
at Function.Module._load (module.js:424:25)
at Module.require (module.js:504:17)
at require (internal/module.js:20:19)
at Object. (/home/erp/frappe-bench/apps/frappe/rollup/build.js:4:16)
at Module._compile (module.js:577:32)
at Object.Module._extensions…js (module.js:586:10)
at Module.load (module.js:494:32)
at tryModuleLoad (module.js:453:12)
at Function.Module._load (module.js:445:3)
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

There is no “rollup” in frappe-bench/node_modules.
but there is a rollup directory under
frappe-bench/apps/frappe

What should I look for next?

[erp@localhost frappe-bench]$ bench setup requirements --node
Updating node packages…
$ yarn install
yarn install v1.22.4
[1/4] Resolving packages…
[2/4] Fetching packages…
error cypress-file-upload@3.1.0: The engine “node” is incompatible with this module. Expected version “>=8.2.1”. Got “6.17.1”
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
$ yarn install
yarn install v1.22.4
[1/4] Resolving packages…
success Already up-to-date.
Done in 0.14s.
[erp@localhost frappe-bench]$

Looks like nodejs is looking for a later version (8.2.1) - I am unsure as to whether this is possible? My latest yum update on centos 7 is NOT showing an update for nodejs and is running 6.17.1. I am running latest kernel with all updates…

Here are notes to install v8 Notes to install yarn and upgrade unsupported Node version to V8

After installing nvm 8.2.1 and then the following:

cd ~/frappe-bench
sudo npm install -g yarn
bench setup requirements --node
bench update --requirements
bench setup socketio
bench build
bench update
bench --site site-name set-maintenance-mode off

Everything worked as it should - Thank you @clarkej

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.