SMS Setting - how to set up a SMS gateway that requires JSON payload?

Hi fellows,

I’m trying to use Message Media as the SMS gateway, I can use postman to send text successfully via the API but just have no idea how to configure it in the SMS Setting as the API requires a JSON payload.

API works by sending a request via postman:

Tried this setting but not working:
{"messages":[{"content":"<MESSAGE>","destination_number":"<MOBILENUMBER>"}]}

Message Media API docs: https://messagemedia.github.io/documentation/#operation/SendMessages

Any help would be appreciated.

I struggled this week to get it up and running. My first try with MessageBird didn’t work, as they require an authentication and I gave it up. I have then signed up with smsapi.com and it worked at the first try, as they allow for a simple one line URL entry to send SMS.

Note that you have to register the “from” name for it to work.

Thanks, I’ll try it out if ErpNext really doesn’t support a JSON payload.

Just feel like this is not something too complicated to support, especially there is already a ‘Use POST’ checkbox on the screen so I assume there is must be a way to work with APIs that need JSON payload.