ERPNext.com Frappe Cloud Support Partners Foundation Frappe School

SMS not getting sent from SMS Center

Hello everyone,

What does the error
/api/method/runserverobj 500 (INTERNAL SERVER ERROR)” in bench console mean while sending SMS from SMS Center?

The SMS settings are correct and i am able to send sms using POST APIs from the same server.

Can you share a redacted screenshot of your settings?

I have SMS working for a few instances.

Hi @Shinzuco,

i have sms working with the same settings on my v13-beta server.

But on v13 server it doesnt work. I get the above error msg. Is there any prerequisite anywhere else, like system settings, website settings etc. to fill up before getting sms to work?

i think it has something to do with the format of sms gateway URL.

my gateway url is
https://messaging.ooredoo.qa/bms/soap/Messenger.asmx/HTTP_SendSms
i am able to send sms with this gateway url from v13-beta

But on v13, if i give the same url, i get the above error. If i change the url to
https://messaging.ooredoo.qa/bms/soap/Messenger.asmx
i am not getting any error and it shows me ‘SMS sent…’ But i am not getting the sms since the HTTP_SendSms function is missing.

This is the api userguide from my sms gateway

Messenger Web Service

i was able to solve it taking hint from an old post in this forum. i changed the field type of gateway url from Data to Small Text and typed the URL along with the required parameters. The static parameter table was kept empty. This way i was able to get the SMS sent succesfully.

1 Like

Was about to suggest that

1 Like

Thanks @Shinzuco

I solved the problem as you mentioned in the past but its not working , researching what issue. any hint to take care , i kept msg and number parameter and no static para and converted field data to smalltext.

What sms gateway are you using? there might be provider specific parameters which might be need in the URL field

Thanks , It worked , Use Post enable and disable , but it works and we already changed field type from data to small text and relevant PR has been merged for field type issue . Thanks again

1 Like