Sms integration,problem with configuration

I want to configure the sms service.I filled all the details but error is showing like bellow

401 Client Error: Unauthorized for url: https://rest.messagebird.com/messages?body=welcome+to+vedarth&access_key=********&recipient=855&originator=SECURI

config are as in pictures please suggest the proper changes


Hi @surajkumar ,
You should replace Message Parameter with message & Receiver Parameter with mobiles

Hope this helps.

made all changes still not working.
generates same error

@nabinhait @System19
pleaase suggest any solution

@surajkumar

It shows 401 Error means problem with Key or in rare case problem with HTTP Method. Try Post method and Make sure your secret key should be valid.

The last time I tried to use a SMS gateway with Frappe that required HTTPS It wouldn’t work. That was about 18months ago. I had to use a service that provided a plain HTTP service and it worked no problem. This was due to Frappe implementation. It looks as though message bird provides plain HTTP services. https://developers.messagebird.com/docs/alternatives
Try this method.

@bhavikpatel7023
not working i did all changes

Did you try http method?

@System19
I’m quite new here.
I’ve used whatever is available through forum.
please elaborate the solution,
If you have any better gateway URL which I should prefer then also suggest me with all necessary parameters and other configurations


while doing with messagebird with above parameters I am getting this error

HTTPError: 422 Client Error: Unprocessable Entity for url: https://rest.messagebird.com/messages?_method=POST&msisdn=31612345678&…&originator=SECURI&mobile=NUMBER&message=welcome&AccessKey=KEY

Seems some parameters are mandatory or problem with parameters.

which parameters

Tried

originator is mandatory field.

I am not sure how message bird deals with http. Below is the company I used. I am not promoting them at all but most http SMS gateways use the same or very similar settings. This may help.

SMS Gateway URL
http://api.smsbroadcast.com.au/api-adv.php

Message Parameter
message

Receiver Parameter
to

On the right side of the page create the following:
Parameter
username
Value
your-sms-gateway-username

Parameter
password
Value
your-sms-gateway-password

Optional Setting

Parameter
from
Value
Your Company Name

Just read that @bhavikpatel7023 solved your issue.

@System19
hey it’s national domain.
do not have service for out of Aus

@bhavikpatel7023

I guess URL is same and as you told earlier there must be problem with it.
which static parameters I have to provide?

Yes you have to add textbox for origin in sms center and try it again.

Enter your SMS gateway URL instead.
SMS Gateway URL
http://yoursmsgateway.com/whatever

for messagebird?

@bhavikpatel7023
i did as in screenshots which text box?