Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

SMS alert configuration

Hi everyone,

I have performed following steps.

1 - Configured SMS settings.
2 - Configured SMS center.

When I send sms through SMS center, it is shown in SMS log but message is not sent. Screen shots are attached for reference.

What values should be entered in static values window, I mean “parameter” & “value”.

SMS center

Thanks

1 Like

Sender, username, password should be added as a static parameter. Check the api of sendpk.com for more details.

Thanks for your time.
I have entered username and password as per API of sendpk.com but msg not receiving to receiver.
ERPNext says message sent and it is also shown in sms log.

Note:- When I send sms through same API used in my own code, it is received at the receiver end.

Please look at screen shot and guide me what should be given in message parameter. I have written just a string. Secondly check receiver parameter is ok?

Regards,

Try:
SMS Gateway URL
For single SMS: http://sendpk.com/api/sms.php
For bulk SMS: http://sendpk.com/api/bulksms.php

Message Parameter: message
Receiver Parameter: mobile
SMS Sender Name: Leave Empty

Enter Static Parameters:
Parameter: username Value: Your sendpk username
Parameter: password Value: Your sendpk password
Parameter: sender Value: Your Company Name

1 Like

Thanks for your input.
I have followed instructions & tested both sms.php and bulksms.php but still same status.
Secondly in static parameters screen, I have option for only two inputs i.e. parameter (user name) and value (password).

Any further help please.

Regards,

Add one row with Parameter: username Value: Your sendpk username
then add another row with: Parameter: password Value: Your sendpk password
Then add another row with: Parameter: sender Value: Your Company Name
Then click done.

Sorry, I followed all steps but unfortunately not successful.

Regards,

Remove Sender parameter
And make sure you enter international dialing code on mobile no you’re sending to.
Your receiver parameter is wrong. It should be just ’ message ’
And receiver parameter should be just ’ mobile’

Can you please post a latest screenshot showing what have you entered in SMS Settings?

Please see the latest screenshot. I have removed password.

Regards,

SMS Settings

SMS Center

SMS Settings should be:

Message Parameter: message
Receiver Parameter: mobile

And from static parameters table, remove 3rd row which is for sender. If you want you can mention sender name in the left side “SMS Sender Name” field. But it must be a short name, generally less than 8 characters (verify with your service providers).

Now below is the latest settings but still no success.

I did try using http://smsblastr.com its working greate :slight_smile: see my post SMSBlastr another way to send SMS alert using your own phone

1 Like

Thanks for help. I have created account as per instructions and tried to send message but its is not received at receiver end, when erpnext shows message is sent to the number.

Please look at the screen shots of sms settings, sms center and smsblastr, & guide me.

Note:- I have not loaded any credit balance, assuming free sms initially.

Regards,

1 Like

Can you screenshot the menu Phone Workers? I think your phone it not online or not activated

When using sendpk.com your last screen grab is nearly correct.
SMS gateway URL is correct - message
Message Parameter is correct - mobile
You should leave SMS Sender Name empty.
Static URL Parameters:
Your sendpk.com username is probably your email address. It is what ever you log into sendpk.com with. Probably Not your phone number.
Your sendpk.com password is whatever you log into sendpk.com with.

Now re-read my post carefully and see if it works.

SMS Gateway URL
For single SMS: http://sendpk.com/api/sms.php
For bulk SMS: http://sendpk.com/api/bulksms.php

Message Parameter: message
Receiver Parameter: mobile
SMS Sender Name: Leave Empty - Leave Blank - Don’t Put Anything Here

Enter Static Parameters:
Parameter: username Value: Your sendpk username/email address
Parameter: password Value: Your sendpk password
Parameter: sender Value: Your Company Name

2 Likes

Please find the screenshot attached.

Looks OK. Can you screen shoot the smsblastr app in your phone.

When I click on SMSBlastr icon, it shows following info.

Msg Daily (sent/quota):0/500
Msg Monthly (sent/quota):0/6000
Message Queued:4

Status/SIM:Online/Single

[Stop service]

[Log out]

Can you try to tap the stop then start the service button.