Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

Site cant be reached - Stuck at Rebuilding data_import_tool.min.js

Created a new bench instance on a bare metal ubuntu 18 server. Resources are 8vcpu, 16 gigs of ram, 500 gb ssd. When i create a new site and access it, it says site cant be reached or the site takes too long to load and gives the same error. I have checked out all similar topics on the forum and so far nothing seems to work. Im running on production mode

Check that all your services are running , ie bench etc

bench is running, how do i check the services?

11:06:50 system           | redis_cache.1 started (pid=1844)
11:06:50 redis_cache.1    | 1848:C 03 Jun 11:06:50.942 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
11:06:50 redis_cache.1    | 1848:C 03 Jun 11:06:50.942 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=1848, just started
11:06:50 redis_cache.1    | 1848:C 03 Jun 11:06:50.942 # Configuration loaded
11:06:50 system           | redis_queue.1 started (pid=1851)
11:06:50 redis_cache.1    | 1848:M 03 Jun 11:06:50.944 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:06:50 redis_cache.1    | 1848:M 03 Jun 11:06:50.946 * Running mode=standalone, port=13001.
11:06:50 redis_cache.1    | 1848:M 03 Jun 11:06:50.946 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:06:50 redis_cache.1    | 1848:M 03 Jun 11:06:50.946 # Server initialized
11:06:50 redis_cache.1    | 1848:M 03 Jun 11:06:50.946 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
11:06:50 redis_cache.1    | 1848:M 03 Jun 11:06:50.946 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:06:50 redis_cache.1    | 1848:M 03 Jun 11:06:50.946 * Ready to accept connections
11:06:50 system           | worker_default.1 started (pid=1861)
11:06:50 redis_queue.1    | 1858:C 03 Jun 11:06:50.948 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
11:06:50 redis_queue.1    | 1858:C 03 Jun 11:06:50.949 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=1858, just started
11:06:50 redis_queue.1    | 1858:C 03 Jun 11:06:50.949 # Configuration loaded
11:06:50 system           | redis_socketio.1 started (pid=1846)
11:06:50 redis_socketio.1 | 1855:C 03 Jun 11:06:50.946 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
11:06:50 redis_socketio.1 | 1855:C 03 Jun 11:06:50.946 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=1855, just started
11:06:50 redis_socketio.1 | 1855:C 03 Jun 11:06:50.946 # Configuration loaded
11:06:50 redis_socketio.1 | 1855:M 03 Jun 11:06:50.949 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:06:50 redis_queue.1    | 1858:M 03 Jun 11:06:50.953 * Increased maximum number of open files to 10032 (it was originally set to 1024).
11:06:50 redis_socketio.1 | 1855:M 03 Jun 11:06:50.952 * Running mode=standalone, port=12001.
11:06:50 redis_socketio.1 | 1855:M 03 Jun 11:06:50.952 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:06:50 redis_socketio.1 | 1855:M 03 Jun 11:06:50.952 # Server initialized
11:06:50 redis_socketio.1 | 1855:M 03 Jun 11:06:50.952 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
11:06:50 redis_socketio.1 | 1855:M 03 Jun 11:06:50.952 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:06:50 redis_socketio.1 | 1855:M 03 Jun 11:06:50.952 * Ready to accept connections
11:06:50 system           | web.1 started (pid=1853)
11:06:50 system           | socketio.1 started (pid=1852)
11:06:50 redis_queue.1    | 1858:M 03 Jun 11:06:50.956 * Running mode=standalone, port=11001.
11:06:50 redis_queue.1    | 1858:M 03 Jun 11:06:50.956 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
11:06:50 redis_queue.1    | 1858:M 03 Jun 11:06:50.956 # Server initialized
11:06:50 redis_queue.1    | 1858:M 03 Jun 11:06:50.956 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
11:06:50 redis_queue.1    | 1858:M 03 Jun 11:06:50.956 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
11:06:50 redis_queue.1    | 1858:M 03 Jun 11:06:50.956 * Ready to accept connections
11:06:50 system           | worker_short.1 started (pid=1867)
11:06:50 system           | watch.1 started (pid=1859)
11:06:50 system           | schedule.1 started (pid=1874)
11:06:50 system           | worker_long.1 started (pid=1875)
11:06:51 socketio.1       | listening on *: 9001
11:06:51 web.1            |  * Running on http://0.0.0.0:8001/ (Press CTRL+C to quit)
11:06:52 web.1            |  * Restarting with inotify reloader
11:06:52 watch.1          | yarn run v1.22.10
11:06:52 watch.1          | $ node rollup/watch.js
11:06:52 web.1            |  * Debugger is active!
11:06:52 web.1            |  * Debugger PIN: 493-550-334
11:06:53 watch.1          | 
11:06:53 watch.1          | Rollup Watcher Started
11:06:53 watch.1          | 
11:06:53 watch.1          | Watching...
11:06:53 watch.1          | Browserslist: caniuse-lite is outdated. Please run:
11:06:53 watch.1          | npx browserslist@latest --update-db
11:06:55 watch.1          | Rebuilding frappe-web-b4.css
11:06:55 watch.1          | Rebuilding frappe-chat-web.css
11:06:55 watch.1          | Rebuilding chat.js
11:06:57 watch.1          | Rebuilding frappe-recorder.min.js
11:06:59 watch.1          | Rebuilding checkout.min.js
11:06:59 watch.1          | Rebuilding frappe-web.min.js
11:07:01 watch.1          | Rebuilding bootstrap-4-web.min.js
11:07:02 watch.1          | Rebuilding control.min.js
11:07:06 watch.1          | Rebuilding dialog.min.js
11:07:09 watch.1          | Rebuilding desk.min.css
11:07:09 watch.1          | Rebuilding frappe-rtl.css
11:07:09 watch.1          | Rebuilding printview.css
11:07:09 watch.1          | Rebuilding desk.min.js
11:07:15 watch.1          | Rebuilding form.min.css
11:07:15 watch.1          | Rebuilding form.min.js
11:07:20 watch.1          | Rebuilding list.min.css
11:07:20 watch.1          | Rebuilding list.min.js
11:07:21 watch.1          | Rebuilding report.min.css
11:07:21 watch.1          | Rebuilding report.min.js
11:07:22 watch.1          | Rebuilding web_form.min.js
11:07:23 watch.1          | Rebuilding web_form.css
11:07:23 watch.1          | Rebuilding email.css
11:07:23 watch.1          | Rebuilding social.min.js
11:07:24 watch.1          | Rebuilding barcode_scanner.min.js
11:07:25 watch.1          | Rebuilding data_import_tools.min.js

I don’t know if this showcases something but this is all i get when i run bench start

Try bench setup --build

Do I stop bench or run this in another terminal with bench running?

It says:

Usage: bench setup [OPTIONS] COMMAND [ARGS]...

Try "bench setup --help" for help.

Error: no such option: --build

Okay so, I am running with a multitenant setup, when i ran sudo service nginx reload it said: nginx.service is not active, cannot reload. So i ran sudo service nginx start, so it says :

Job for nginx.service failed because the control process exited with error code.

See "systemctl status nginx.service" and "journalctl -xe" for details.

When i ran systemctl status nginx.service it said:

nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2021-06-04 01:04:25 BST; 1min 14s ago
     Docs: man:nginx(8)
  Process: 1360 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)

Apologies.

Try bench setup requirements , bench setup nginx , and bench update --build.

It may also help to say the version of frappe and ERPNext, and what method was used to install it.