Try ERPNext Buy Support Partners Foundation

Setup Wizard fails with "Request Timed Out ( Could not start up: Error in setup )"

Yeah pretty sure. Would be nice if a dev could clarify.

Could this bug possibly be due to having a mixture of python 2 and python 3 in our systems?

Update 2020/02/13 11:00

So, I am still trying to solve this.

I have noticed an important fact. The indicated failure is never the same. What is the same every time is :

[CRITICAL] WORKER TIMEOUT (pid:29296)

Does that have an issue history with anyone here?

Update 2020/02/13 12:30

I ran the installer with the settings --without-site and --without-erpnext

    sudo -AH python3 install.py --production \
      --user ${PRD_ERPHOST_USR} \
      --without-site \
      --without-erpnext \
      --mysql-root-password ${PRD_ERPHOST_PWD} \
      --admin-password ${PRD_ERPHOST_PWD} \
      --verbose;

I then ran :

sudo bench setup production erpnext --yes;
sudo bench setup sudoers erpnext;
sudo bench restart;

I was able to complete the Setup Wizard but it was only a short form wizard that asked nothing about our company and no modules like Human Resources or Manufacturing appear when it completed?

Also it sported the Frappe icon, rather than the blue “E” for ErpNext.

How can I get the full ErpNext installation wizard that asks for business domains, type of Chart of Accounts etc.?

For what you are describing, it seems like your site doesn’t have erpnext installed. Try this:

bench --site SITE_NAME reinstall
bench --site SITE_NAME install-app erpnext

And then try the wizard

Thanks @Nahuel_Nso

In fact, I had to do :

bench --site SITE_NAME reinstall
bench get-app --branch version-12 erpnext
bench --site SITE_NAME install-app erpnext

That does get me the complete installer.

Running a partial install.py, using --without-site and --without-erpnext, then completing the remaining steps as you indicate, does not solve the larger problem described in my first post. The Wizard still fails at some random spot due to a dead worker:

[2020-02-13 14:24:25 -0500] [7739] [CRITICAL] WORKER TIMEOUT (pid:7759)
[2020-02-13 14:24:25 -0500] [7759] [ERROR] Error handling request /api/method/frappe.desk.page.setup_wizard.setup_wizard.setup_complete

I am now at about 20 hours working to solve this.