Try ERPNext Buy Support Partners Foundation

Setting up SMS in ERPNext with solutioninfini

Hello,

I have gone through the forum, followed the directives, unfortunately, things did not work out for me.

Below is the URL provided by my SMS provider;

http://api-global.solutionsinfini.com/v3/?method=sms&api_key=Ad9e5XXXXXXXXXXXXX&to=997XXXXXXX&sender=INFXXX&message=Welcome%20to%messaging

For my settings in ERPNext, I have provided the following;

SMS Gateway URL: http://api-global.solutionsinfini.com/v3/?
Message Parameter: message
Receiver Parameter: mobile
SMS Sender Name: I left this filed empty

For the static URL parameters;

api_key: my generated key
method: sms

When I try to send sms, I get no response from the system and no logs are available for review.

(Note: When I use my browser with the above settings, I send SMSs successfully and they are delivered to the recepient

Please assist

Regards,

Alexander.

Maybe try dropping the ? at the end of SMS Gateway URL.
So:
SMS Gateway URL: http://api-global.solutionsinfini.com/v3/
Message Parameter: message
Receiver Parameter: mobile
Sender Name: blank
api_key: my generated key
method: sms

SMS Gateway URL: http://alerts.sinfini.com/api/v3/index.php
Message Parameter: message
Receiver Parameter: to

You gave to get a sender ID approved from solutions infi and fill that us as sender id. leaving it blank wont work.

Thanks all. I have tried all the options above with no success. No response from the system when I click the send SMS button, and logs found for review. I have an approved sender ID from Solutioninfini which works fine when I send SMSs from their portal and through browser (using their provided URL and my generated api_key).

Regards,

Alexander.

The above settings works for me, can you try by replicating the exact same url?

1 Like

I tried replicating everything with no success. Do I have to something differently in the SMS center?

I have only one contact I am trying to send to, an employee in the management department.

Regards,

Alexander.

I have been informed that http://alerts.sinfini.com/api/v3/index.php is not for global users. The correct URL for me should be the one I mentioned in my original post. This one is for domestic users.

I have also tried for SMS settings, It gives me an message

Can anybody help me?

My SMS configurations started working after the last upgrade. I just assumed the upgrade came with a fix for my problem. I can now send SMSs.

Regards

Alexander.

change it with your provider. error messages does not have anything to do with your sender id, as this is being handled by your provider itself to comply with regulations in your country.

@Alexander, I had the same issue. What I did is to change the SMS Gateway URL field type to text as Data can only have 140 Chars as listed here: https://erpnext.com/docs/user/manual/en/customize-erpnext/articles/field-types.html

What I have understand is that when system merge all paramters with Gateway URL it exceeds 140 chars.

Also, try to merge the paramaters by yourself in the Gateway URL as done in screenshot.

hi does its work? i have same problem too