Server Error brokenfilesystem

Dears this message appears after i start the bench and i face brokenfilesystem message in terminal and finally it reports the follwoing error message in the browser while i`m tryng to access the desk

Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/app.py”, line 69, in application
response = frappe.website.render.render()
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 65, in render
data = render_page(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 117, in render_page
return build(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 124, in build
return build_page(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/render.py”, line 137, in build_page
context = get_context(path)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/context.py”, line 19, in get_context
context = build_context(context)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/context.py”, line 89, in build_context
update_controller_context(context, context.controller)
File “/home/frappe/frappe-bench/apps/frappe/frappe/website/context.py”, line 52, in update_controller_context
frappe.errprint(frappe.utils.get_traceback())
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 230, in errprint
print cstr(msg)
IOError: [Errno 32] Broken pipe

Can you please check what you get in your ‘bench start’ screen? Are any errors there?
Also try restarting your server. Broken Pipe means the connection got lost while processing the request. It’s a network issue.

Yes brokenfilesystemerror apears in bench start and also there are some
errors about encoding that the system can’t use the defult encoding (ansi)
and it use utf8 insted

Did you restart your server? And please paste the full error trace.

i`v restarted the server many times but it still

2016-11-21 16:47:22 [1430] [WARNING] Your terminal is not configured to receive UTF-8 encoded text. Please adjust your locale settings or force UTF-8 output by setting PYTHONIOENCODING=“utf-8”.
16:47:22 system | redis_socketio.1 started (pid=1443)
16:47:22 system | worker_long.1 started (pid=1445)
16:47:22 system | watch.1 started (pid=1447)
16:47:22 system | redis_queue.1 started (pid=1448)
16:47:22 system | schedule.1 started (pid=1455)
16:47:22 system | web.1 started (pid=1453)
16:47:22 system | socketio.1 started (pid=1463)
16:47:22 system | worker_default.1 started (pid=1458)
16:47:22 system | worker_short.1 started (pid=1469)
16:47:22 system | redis_cache.1 started (pid=1470)
16:47:22 redis_cache.1 | [1476] 21 Nov 16:47:22.373 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
16:47:22 redis_socketio.1 | [1451] 21 Nov 16:47:22.373 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
16:47:22 redis_queue.1 | [1468] 21 Nov 16:47:22.373 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
16:47:22 redis_queue.1 | .
16:47:22 redis_queue.1 | .-__ ''-._ 16:47:22 redis_queue.1 | _.- .. ‘’-._ Redis 2.8.4 (00000000/0) 64 bit
16:47:22 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 16:47:22 redis_queue.1 | ( ' , .-` | `, ) Running in stand alone mode 16:47:22 redis_queue.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 11000 16:47:22 redis_queue.1 | |-. ._ / _.-' | PID: 1468 16:47:22 redis_cache.1 | _._ 16:47:22 redis_cache.1 | _.-``__ ''-._ 16:47:22 redis_cache.1 | _.-``. _. ''-._ Redis 2.8.4 (00000000/0) 64 bit 16:47:22 redis_cache.1 | .-`` .-```. ```\/ _.,_ ''-._ 16:47:22 redis_cache.1 | ( ' , .- | , ) Running in stand alone mode 16:47:22 redis_cache.1 | |-.-...- …-.-._|'` _.-'| Port: 13000 16:47:22 redis_cache.1 | | `-._ `._ / _.-' | PID: 1476 16:47:22 redis_cache.1 | `-._ `-._ `-./ _.-' _.-' 16:47:22 redis_cache.1 | |`-._`-._ `-.__.-' _.-'_.-'| 16:47:22 redis_socketio.1 | _._ 16:47:22 redis_socketio.1 | _.- ‘’-.
16:47:22 redis_socketio.1 | .-`. `_. ''-._ Redis 2.8.4 (00000000/0) 64 bit 16:47:22 redis_socketio.1 | .- .-./ ., ‘’-.
16:47:22 redis_socketio.1 | ( ’ , .-|, ) Running in stand alone mode
16:47:22 redis_cache.1 | | -._-._ .-’.-’ | http://redis.io
16:47:22 redis_socketio.1 | |-._-…-__...-.``-._|' .-’| Port: 12000
16:47:22 redis_socketio.1 | | -._.
/ .-’ | PID: 1451
16:47:22 redis_socketio.1 | -._-.
-./ _.-' _.-' 16:47:22 redis_socketio.1 | |-.-._-.__.-’ .-’.-’|
16:47:22 redis_socketio.1 | | -._-.
.-’.-’ | http://redis.io
16:47:22 redis_socketio.1 | -._-.-.__.-'_.-' _.-' 16:47:22 redis_socketio.1 | |-.-._-..-’ .-’.-’|
16:47:22 redis_socketio.1 | | -._-._ .-’.-’ |
16:47:22 redis_socketio.1 | -._-.-.__.-'_.-' _.-' 16:47:22 redis_socketio.1 |-. -.__.-' _.-' 16:47:22 redis_socketio.1 |-._ .-’
16:47:22 redis_socketio.1 | -.__.-' 16:47:22 redis_socketio.1 | 16:47:22 redis_socketio.1 | [1451] 21 Nov 16:47:22.375 # Server started, Redis version 2.8.4 16:47:22 redis_socketio.1 | [1451] 21 Nov 16:47:22.375 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect. 16:47:22 redis_queue.1 |-.
-._-./ .-’ .-’
16:47:22 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 16:47:22 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 16:47:22 redis_cache.1 |-._ -._-.
.-’.-’ .-’
16:47:22 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 16:47:22 redis_cache.1 | |-.
-._ _.-'_.-' | 16:47:22 redis_cache.1 |-._ -._-..-’_.-’ _.-’
16:47:22 redis_cache.1 | -._-.
.-’ .-’
16:47:22 redis_queue.1 | -._-.
-.__.-'_.-' _.-' 16:47:22 redis_queue.1 | |-.-._-.__.-’ .-’.-’|
16:47:22 redis_queue.1 | | -._-.
.-’.-’ |
16:47:22 redis_queue.1 | -._-.-.__.-'_.-' _.-' 16:47:22 redis_queue.1 |-. -.__.-' _.-' 16:47:22 redis_queue.1 |-._ .-’
16:47:22 redis_queue.1 | -.__.-' 16:47:22 redis_queue.1 | 16:47:22 redis_cache.1 |-.
_.-’
16:47:22 redis_cache.1 | `-.__.-’
16:47:22 redis_cache.1 |
16:47:22 redis_cache.1 | [1476] 21 Nov 16:47:22.375 # Server started, Redis version 2.8.4
16:47:22 redis_cache.1 | [1476] 21 Nov 16:47:22.375 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
16:47:22 redis_queue.1 | [1468] 21 Nov 16:47:22.375 # Server started, Redis version 2.8.4
16:47:22 redis_queue.1 | [1468] 21 Nov 16:47:22.375 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
16:47:22 redis_socketio.1 | [1451] 21 Nov 16:47:22.599 * The server is now ready to accept connections on port 12000
16:47:22 redis_queue.1 | [1468] 21 Nov 16:47:22.599 * The server is now ready to accept connections on port 11000
16:47:22 redis_cache.1 | [1476] 21 Nov 16:47:22.599 * The server is now ready to accept connections on port 13000
16:47:27 worker_short.1 | 16:47:27 RQ worker u’rq:worker:vps.1478.short’ started, version 0.6.0
16:47:27 worker_short.1 | 16:47:27 Cleaning registries for queue: short
16:47:27 worker_short.1 | 16:47:27
16:47:27 worker_short.1 | 16:47:27 *** Listening on short…
16:47:27 worker_long.1 | 16:47:27 RQ worker u’rq:worker:vps.1457.long’ started, version 0.6.0
16:47:27 worker_long.1 | 16:47:27 Cleaning registries for queue: long
16:47:27 worker_long.1 | 16:47:27
16:47:27 worker_long.1 | 16:47:27 *** Listening on long…
16:47:27 worker_default.1 | 16:47:27 RQ worker u’rq:worker:vps.1473.default’ started, version 0.6.0
16:47:27 worker_default.1 | 16:47:27 Cleaning registries for queue: default
16:47:27 worker_default.1 | 16:47:27
16:47:27 worker_default.1 | 16:47:27 *** Listening on default…
16:47:28 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
16:47:29 watch.1 | Wrote ./assets/js/frappe-web.min.js - 141k
16:47:30 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
16:47:30 watch.1 | Wrote ./assets/js/form.min.js - 175k
16:47:31 web.1 | * Restarting with inotify reloader
16:47:31 watch.1 | Wrote ./assets/js/report.min.js - 250k
16:47:32 web.1 | * Debugger is active!
16:47:32 web.1 | * Debugger pin code: 194-206-880
16:47:33 watch.1 | Wrote ./assets/js/erpnext.min.js - 100k
16:47:33 watch.1 | Wrote ./assets/css/list.min.css - 8k
16:47:34 watch.1 | Wrote ./assets/js/item-dashboard.min.js - 7k
16:47:34 watch.1 | Wrote ./assets/js/d3.min.js - 380k
16:47:35 watch.1 | Wrote ./assets/css/report.min.css - 8k
16:47:35 watch.1 | Wrote ./assets/css/frappe-web.css - 54k
16:47:40 watch.1 | Wrote ./assets/js/list.min.js - 146k
16:47:40 watch.1 | Wrote ./assets/js/dialog.min.js - 85k
16:47:41 watch.1 | Wrote ./assets/js/desk.min.js - 328k
16:47:41 watch.1 | Wrote ./assets/css/form.min.css - 4k
16:47:42 watch.1 | Wrote ./assets/js/editor.min.js - 45k
16:47:42 watch.1 | Wrote ./assets/css/erpnext.css - 3k
16:47:42 watch.1 | Wrote ./assets/js/libs.min.js - 891k
16:47:42 watch.1 | Wrote ./assets/js/erpnext-web.min.js - 4k
16:47:43 watch.1 | Wrote ./assets/css/desk.min.css - 266k
16:47:43 watch.1 | Wrote ./assets/css/module.min.css - 2k
16:47:53 socketio.1 | listening on *: 9000

1 Like

another one

root@vps:~# bench start 2016-11-22 02:49:22 [1542] [WARNING] Your terminal is not configured to receive UTF-8 encoded text. Please adjust your locale settings or force UTF-8 output by setting PYTHONIOENCODING="utf-8". 02:49:23 system | web.1 started (pid=1561) 02:49:23 system | redis_queue.1 started (pid=1559) 02:49:23 system | schedule.1 started (pid=1563) 02:49:23 system | worker_default.1 started (pid=1565) 02:49:23 system | redis_socketio.1 started (pid=1569) 02:49:23 system | redis_cache.1 started (pid=1568) 02:49:23 system | worker_short.1 started (pid=1577) 02:49:23 system | socketio.1 started (pid=1567) 02:49:23 system | watch.1 started (pid=1556) 02:49:23 system | worker_long.1 started (pid=1554) 02:49:23 redis_socketio.1 | [1579] 22 Nov 02:49:23.268 # Unable to set the max n umber of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984. 02:49:23 redis_queue.1 | [1573] 22 Nov 02:49:23.269 # Unable to set the max n umber of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984. 02:49:23 redis_socketio.1 | _._ 02:49:23 redis_socketio.1 | _.-``__ ''-._ 02:49:23 redis_socketio.1 | _.-``. _. ''-._ Redis 2.8.4 (00000000/0) 64 bit 02:49:23 redis_socketio.1 | .-`` .-```. ```\/ _.,_ ''-._ 02:49:23 redis_socketio.1 | ( ' , .- | , ) Running in s tand alone mode 02:49:23 redis_socketio.1 | |-.-...- …-.-._|'` _.-'| Port: 12000 02:49:23 redis_socketio.1 | | `-._ `._ / _.-' | PID: 1579 02:49:23 redis_socketio.1 | `-._ `-._ `-./ _.-' _.-' 02:49:23 redis_socketio.1 | |`-._`-._ `-.__.-' _.-'_.-'| 02:49:23 redis_socketio.1 | | `-._`-._ _.-'_.-' | http:/ /redis.io 02:49:23 redis_socketio.1 | `-._ `-._`-.__.-'_.-' _.-' 02:49:23 redis_socketio.1 | |`-._`-._ `-.__.-' _.-'_.-'| 02:49:23 redis_socketio.1 | | `-._`-._ _.-'_.-' | 02:49:23 redis_socketio.1 | `-._ `-._`-.__.-'_.-' _.-' 02:49:23 redis_socketio.1 | `-._ `-.__.-' _.-' 02:49:23 redis_socketio.1 | `-._ _.-' 02:49:23 redis_socketio.1 | `-.__.-' 02:49:23 redis_socketio.1 | 02:49:23 redis_socketio.1 | [1579] 22 Nov 02:49:23.269 # Server started, Redis v ersion 2.8.4 02:49:23 redis_socketio.1 | [1579] 22 Nov 02:49:23.269 # WARNING overcommit_memo ry is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect. 02:49:23 redis_queue.1 | _._ 02:49:23 redis_queue.1 | _.- ‘’-.
02:49:23 redis_queue.1 | .-`. `_. ''-._ Redis 2.8.4 (00000000/0) 64 bit 02:49:23 redis_queue.1 | .- .-./ ., ‘’-.
02:49:23 redis_queue.1 | ( ’ , .-|, ) Running in s tand alone mode
02:49:23 redis_queue.1 | |-._-…-__...-.``-._|' .-’| Port: 11000
02:49:23 redis_queue.1 | | -._.
/ .-’ | PID: 1573
02:49:23 redis_queue.1 | -._-.
-./ _.-' _.-' 02:49:23 redis_queue.1 | |-.-._-.__.-’ .-’.-’|
02:49:23 redis_queue.1 | | -._-.
.-’.-’ | http:/ /redis.io
02:49:23 redis_queue.1 | -._-.-.__.-'_.-' _.-' 02:49:23 redis_queue.1 | |-.-._-..-’ .-’.-’|
02:49:23 redis_queue.1 | | -._-._ .-’.-’ |
02:49:23 redis_queue.1 | -._-.-.__.-'_.-' _.-' 02:49:23 redis_queue.1 |-. -.__.-' _.-' 02:49:23 redis_queue.1 |-._ .-’
02:49:23 redis_queue.1 | -.__.-' 02:49:23 redis_queue.1 | 02:49:23 redis_queue.1 | [1573] 22 Nov 02:49:23.271 # Server started, Redis v ersion 2.8.4 02:49:23 redis_queue.1 | [1573] 22 Nov 02:49:23.272 # WARNING overcommit_memo ry is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect. 02:49:23 redis_socketio.1 | [1579] 22 Nov 02:49:23.315 * The server is now ready to accept connections on port 12000 02:49:23 redis_queue.1 | [1573] 22 Nov 02:49:23.315 * The server is now ready to accept connections on port 11000 02:49:23 redis_cache.1 | [1586] 22 Nov 02:49:23.318 # Unable to set the max n umber of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984. 02:49:23 redis_cache.1 | _._ 02:49:23 redis_cache.1 | _.-``__ ''-._ 02:49:23 redis_cache.1 | _.-``. _. ''-._ Redis 2.8.4 (00000000/0) 64 bit 02:49:23 redis_cache.1 | .-`` .-```. ```\/ _.,_ ''-._ 02:49:23 redis_cache.1 | ( ' , .- | , ) Running in s tand alone mode 02:49:23 redis_cache.1 | |-.
-...- …-.``-.|’_.-'| Port: 13000 02:49:23 redis_cache.1 | |-. ._ / _.-' | PID: 1586 02:49:23 redis_cache.1 |-. -._-./ .-’ .-’
02:49:23 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 02:49:23 redis_cache.1 | |-.
-._ _.-'_.-' | http:/ /redis.io 02:49:23 redis_cache.1 |-.
-._-.
.-’.-’ .-’
02:49:23 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 02:49:23 redis_cache.1 | |-.
-._ _.-'_.-' | 02:49:23 redis_cache.1 |-._ -._-..-’_.-’ _.-’
02:49:23 redis_cache.1 | -._-.
.-’ _.-’
02:49:23 redis_cache.1 | -._ _.-' 02:49:23 redis_cache.1 |-.__.-’
02:49:23 redis_cache.1 |
02:49:23 redis_cache.1 | [1586] 22 Nov 02:49:23.319 # Server started, Redis v ersion 2.8.4
02:49:23 redis_cache.1 | [1586] 22 Nov 02:49:23.319 # WARNING overcommit_memo ry is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
02:49:23 redis_cache.1 | [1586] 22 Nov 02:49:23.319 * The server is now ready to accept connections on port 13000
02:49:26 worker_long.1 | 02:49:26 RQ worker u’rq:worker:vps.1589.long’ starte d, version 0.6.0
02:49:26 worker_long.1 | 02:49:26 Cleaning registries for queue: long
02:49:26 worker_long.1 | 02:49:26
02:49:26 worker_long.1 | 02:49:26 *** Listening on long…
02:49:26 worker_default.1 | 02:49:26 RQ worker u’rq:worker:vps.1580.default’ sta rted, version 0.6.0
02:49:26 worker_default.1 | 02:49:26 Cleaning registries for queue: default
02:49:26 worker_default.1 | 02:49:26
02:49:26 worker_default.1 | 02:49:26 *** Listening on default…
02:49:26 worker_short.1 | 02:49:26 RQ worker u’rq:worker:vps.1584.short’ start ed, version 0.6.0
02:49:26 worker_short.1 | 02:49:26 Cleaning registries for queue: short
02:49:26 worker_short.1 | 02:49:26
02:49:26 worker_short.1 | 02:49:26 *** Listening on short…
02:49:26 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
02:49:28 watch.1 | Wrote ./assets/js/frappe-web.min.js - 141k
02:49:29 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
02:49:30 watch.1 | Wrote ./assets/js/form.min.js - 175k
02:49:30 web.1 | * Restarting with inotify reloader
02:49:31 watch.1 | Wrote ./assets/js/report.min.js - 250k
02:49:31 web.1 | * Debugger is active!
02:49:32 web.1 | * Debugger pin code: 228-642-026
02:49:32 watch.1 | Wrote ./assets/js/erpnext.min.js - 100k
02:49:32 watch.1 | Wrote ./assets/css/list.min.css - 8k
02:49:32 watch.1 | Wrote ./assets/js/item-dashboard.min.js - 7k
02:49:33 watch.1 | Wrote ./assets/js/d3.min.js - 380k
02:49:33 watch.1 | Wrote ./assets/css/report.min.css - 8k
02:49:34 watch.1 | Wrote ./assets/css/frappe-web.css - 54k
02:49:40 watch.1 | Wrote ./assets/js/list.min.js - 146k
02:49:41 watch.1 | Wrote ./assets/js/dialog.min.js - 85k
02:49:43 watch.1 | Wrote ./assets/js/desk.min.js - 328k
02:49:43 watch.1 | Wrote ./assets/css/form.min.css - 4k
02:49:44 watch.1 | Wrote ./assets/js/editor.min.js - 45k
02:49:44 watch.1 | Wrote ./assets/css/erpnext.css - 3k
02:49:45 watch.1 | Wrote ./assets/js/libs.min.js - 891k
02:49:46 watch.1 | Wrote ./assets/js/erpnext-web.min.js - 4k
02:49:46 watch.1 | Wrote ./assets/css/desk.min.css - 266k
02:49:46 watch.1 | Wrote ./assets/css/module.min.css - 2k
02:50:09 web.1 | /home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/werkzeug/filesystem.py:63: BrokenFilesystemWarning: Detected a misconfigured UNIX filesystem: Will use UTF-8 as filesystem encoding instead of ‘ANSI_X3.4-1968’
02:50:09 web.1 | BrokenFilesystemWarning)
02:50:14 socketio.1 | listening on *: 9000
02:50:28 web.1 | Module import failed for Page (frappe.core.doctype.page.page_dashboard)
02:50:54 web.1 | 127.0.0.1 - - [22/Nov/2016 02:50:54] “GET /desk HTTP /1.0” 200 -
02:50:58 web.1 | 127.0.0.1 - - [22/Nov/2016 02:50:58] “GET /api/metho d/frappe.async.get_user_info?sid=81a14493030f0d7f7e6bd4d3c1bc6d57d3978519f1f9c5c f7d5419cb HTTP/1.0” 200 -
02:51:27 web.1 | 127.0.0.1 - - [22/Nov/2016 02:51:27] “POST / HTTP/1. 0” 200 -
02:51:28 web.1 | 127.0.0.1 - - [22/Nov/2016 02:51:28] “GET /desk HTTP /1.0” 200 -
02:51:29 web.1 | 127.0.0.1 - - [22/Nov/2016 02:51:29] “GET /api/metho d/frappe.async.get_user_info?sid=81a14493030f0d7f7e6bd4d3c1bc6d57d3978519f1f9c5c f7d5419cb HTTP/1.0” 200 -

`

@Mahmoud_Ghoneem

Can you please execute locale command on your shell and paste the output?

root@vps:~# locale
LANG=
LANGUAGE=
LC_CTYPE=“POSIX”
LC_NUMERIC=“POSIX”
LC_TIME=“POSIX”
LC_COLLATE=“POSIX”
LC_MONETARY=“POSIX”
LC_MESSAGES=“POSIX”
LC_PAPER=“POSIX”
LC_NAME=“POSIX”
LC_ADDRESS=“POSIX”
LC_TELEPHONE=“POSIX”
LC_MEASUREMENT=“POSIX”
LC_IDENTIFICATION=“POSIX”
LC_ALL=

You need to set locale to UTF-8. Please execute following to update your locale

root@vps:~# sudo locale-gen en_US.UTF-8

and then try executing the bench start.

2 Likes

ok now we have a new message

root@vps:~# bench start 04:24:39 system | redis_socketio.1 started (pid=1502) 04:24:39 system | watch.1 started (pid=1507) 04:24:39 system | web.1 started (pid=1512) 04:24:39 system | redis_queue.1 started (pid=1509) 04:24:39 system | schedule.1 started (pid=1513) 04:24:39 system | redis_cache.1 started (pid=1523) 04:24:39 system | worker_default.1 started (pid=1522) 04:24:39 system | socketio.1 started (pid=1519) 04:24:39 system | worker_long.1 started (pid=1504) 04:24:39 system | worker_short.1 started (pid=1525) 04:24:39 redis_queue.1 | [1533] 22 Nov 04:24:39.583 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984. 04:24:39 redis_socketio.1 | [1520] 22 Nov 04:24:39.583 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984. 04:24:39 redis_cache.1 | [1530] 22 Nov 04:24:39.583 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984. 04:24:39 redis_socketio.1 | _._ 04:24:39 redis_socketio.1 | _.-``__ ''-._ 04:24:39 redis_cache.1 | _._ 04:24:39 redis_cache.1 | _.-``__ ''-._ 04:24:39 redis_cache.1 | _.-``. _. ''-._ Redis 2.8.4 (00000000/0) 64 bit 04:24:39 redis_cache.1 | .-`` .-```. ```\/ _.,_ ''-._ 04:24:39 redis_queue.1 | _._ 04:24:39 redis_queue.1 | _.-``__ ''-._ 04:24:39 redis_queue.1 | _.-``. _. ''-._ Redis 2.8.4 (00000000/0) 64 bit 04:24:39 redis_queue.1 | .-`` .-```. ```\/ _.,_ ''-._ 04:24:39 redis_queue.1 | ( ' , .- | , ) Running in stand alone mode 04:24:39 redis_queue.1 | |-.-...- __…-.-._|'` _.-'| Port: 11000 04:24:39 redis_queue.1 | | `-._ `._ / _.-' | PID: 1533 04:24:39 redis_queue.1 | `-._ `-._ `-./ _.-' _.-' 04:24:39 redis_queue.1 | |`-._`-._ `-.__.-' _.-'_.-'| 04:24:39 redis_queue.1 | | `-._`-._ _.-'_.-' | http://redis.io 04:24:39 redis_queue.1 | `-._ `-._`-.__.-'_.-' _.-' 04:24:39 redis_queue.1 | |`-._`-._ `-.__.-' _.-'_.-'| 04:24:39 redis_queue.1 | | `-._`-._ _.-'_.-' | 04:24:39 redis_queue.1 | `-._ `-._`-.__.-'_.-' _.-' 04:24:39 redis_queue.1 | `-._ `-.__.-' _.-' 04:24:39 redis_queue.1 | `-._ _.-' 04:24:39 redis_queue.1 | `-.__.-' 04:24:39 redis_queue.1 | 04:24:39 redis_queue.1 | [1533] 22 Nov 04:24:39.585 # Server started, Redis version 2.8.4 04:24:39 redis_cache.1 | ( ' , .-` | `, ) Running in stand alone mode 04:24:39 redis_cache.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 13000 04:24:39 redis_cache.1 | |-._ ._ / _.-' | PID: 1530 04:24:39 redis_cache.1 |-._ -._-./ .-’ .-’
04:24:39 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 04:24:39 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 04:24:39 redis_cache.1 |-._ -._-..-’_.-’ .-’
04:24:39 redis_socketio.1 | .-`. `_. ''-._ Redis 2.8.4 (00000000/0) 64 bit 04:24:39 redis_socketio.1 | .- .-./ ., ‘’-.
04:24:39 redis_socketio.1 | ( ’ , .-|, ) Running in stand alone mode
04:24:39 redis_socketio.1 | |-._-…-__...-.``-._|' .-’| Port: 12000
04:24:39 redis_socketio.1 | | -._.
/ .-’ | PID: 1520
04:24:39 redis_socketio.1 | -._-.
-./ _.-' _.-' 04:24:39 redis_socketio.1 | |-.
-._-.
.-’ .-’.-’|
04:24:39 redis_socketio.1 | | -._-._ .-’.-’ | http://redis.io
04:24:39 redis_socketio.1 | -._-.-.__.-'_.-' _.-' 04:24:39 redis_socketio.1 | |-.-._-..-’ .-’.-’|
04:24:39 redis_socketio.1 | | -._-._ .-’.-’ |
04:24:39 redis_socketio.1 | -._-.-.__.-'_.-' _.-' 04:24:39 redis_socketio.1 |-. -.__.-' _.-' 04:24:39 redis_socketio.1 |-._ .-’
04:24:39 redis_socketio.1 | -.__.-' 04:24:39 redis_socketio.1 | 04:24:39 redis_socketio.1 | [1520] 22 Nov 04:24:39.585 # Server started, Redis version 2.8.4 04:24:39 redis_socketio.1 | [1520] 22 Nov 04:24:39.585 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect. 04:24:39 redis_cache.1 | |-.
-._-.
.-’ .-’.-’|
04:24:39 redis_cache.1 | | -._-._ .-’.-’ |
04:24:39 redis_cache.1 | -._-.-.__.-'_.-' _.-' 04:24:39 redis_cache.1 |-. -.__.-' _.-' 04:24:39 redis_cache.1 |-._ .-’
04:24:39 redis_cache.1 | `-.__.-’
04:24:39 redis_cache.1 |
04:24:39 redis_cache.1 | [1530] 22 Nov 04:24:39.584 # Server started, Redis version 2.8.4
04:24:39 redis_cache.1 | [1530] 22 Nov 04:24:39.585 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
04:24:39 redis_queue.1 | [1533] 22 Nov 04:24:39.587 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
04:24:39 redis_cache.1 | [1530] 22 Nov 04:24:39.647 * The server is now ready to accept connections on port 13000
04:24:39 redis_socketio.1 | [1520] 22 Nov 04:24:39.647 * The server is now ready to accept connections on port 12000
04:24:39 redis_queue.1 | [1533] 22 Nov 04:24:39.647 * The server is now ready to accept connections on port 11000
04:24:42 worker_default.1 | 04:24:42 RQ worker u’rq:worker:vps.1534.default’ started, version 0.6.0
04:24:42 worker_default.1 | 04:24:42 Cleaning registries for queue: default
04:24:42 worker_default.1 | 04:24:42
04:24:42 worker_long.1 | 04:24:42 RQ worker u’rq:worker:vps.1521.long’ started, version 0.6.0
04:24:42 worker_default.1 | 04:24:42 *** Listening on default…
04:24:42 worker_short.1 | 04:24:42 RQ worker u’rq:worker:vps.1535.short’ started, version 0.6.0
04:24:42 worker_long.1 | 04:24:42 Cleaning registries for queue: long
04:24:42 worker_short.1 | 04:24:42 Cleaning registries for queue: short
04:24:42 worker_short.1 | 04:24:42
04:24:42 worker_short.1 | 04:24:42 *** Listening on short…
04:24:42 worker_long.1 | 04:24:42
04:24:42 worker_long.1 | 04:24:42 *** Listening on long…
04:24:47 watch.1 | Wrote ./assets/js/print_format_v3.min.js - 25k
04:24:49 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
04:24:49 watch.1 | Wrote ./assets/js/frappe-web.min.js - 141k
04:24:52 web.1 | * Restarting with inotify reloader
04:24:53 web.1 | * Debugger is active!
04:24:56 watch.1 | Wrote ./assets/js/form.min.js - 175k
04:24:56 web.1 | * Debugger pin code: 187-159-122
04:24:58 watch.1 | Wrote ./assets/js/report.min.js - 250k
04:25:00 watch.1 | Wrote ./assets/js/erpnext.min.js - 101k
04:25:01 watch.1 | Wrote ./assets/css/list.min.css - 8k
04:25:02 watch.1 | Wrote ./assets/js/item-dashboard.min.js - 7k
04:25:02 watch.1 | Wrote ./assets/js/d3.min.js - 380k
04:25:03 watch.1 | Wrote ./assets/css/report.min.css - 8k
04:25:04 watch.1 | Wrote ./assets/css/frappe-web.css - 54k
04:25:09 watch.1 | Wrote ./assets/js/list.min.js - 146k
04:25:11 watch.1 | Wrote ./assets/js/dialog.min.js - 85k
04:25:15 web.1 | Traceback (most recent call last):
04:25:15 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/website/context.py”, line 47, in update_controller_context
04:25:15 web.1 | ret = module.get_context(context)
04:25:15 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/www/desk.py”, line 18, in get_context
04:25:15 web.1 | frappe.throw(
(“You are not permitted to access this page.”), frappe.PermissionError)
04:25:15 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 300, in throw
04:25:15 web.1 | msgprint(msg, raise_exception=exc, title=title, indicator=‘red’)
04:25:15 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 293, in msgprint
04:25:15 web.1 | _raise_exception()
04:25:15 web.1 | File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 266, in _raise_exception
04:25:15 web.1 | raise raise_exception, encode(msg)
04:25:15 web.1 | PermissionError: You are not permitted to access this page.
04:25:15 web.1 |
04:25:16 web.1 | 127.0.0.1 - - [22/Nov/2016 04:25:16] “GET /desk HTTP/1.0” 200 -
04:25:16 watch.1 | Wrote ./assets/js/desk.min.js - 328k
04:25:16 watch.1 | Wrote ./assets/css/form.min.css - 4k
04:25:17 watch.1 | Wrote ./assets/js/editor.min.js - 45k
04:25:17 watch.1 | Wrote ./assets/css/erpnext.css - 3k
04:25:18 watch.1 | Wrote ./assets/js/libs.min.js - 891k
04:25:18 watch.1 | Wrote ./assets/js/erpnext-web.min.js - 4k
04:25:19 watch.1 | Wrote ./assets/css/desk.min.css - 266k
04:25:20 watch.1 | Wrote ./assets/css/module.min.css - 2k
04:25:56 socketio.1 | listening on *: 9000
04:26:04 web.1 | 127.0.0.1 - - [22/Nov/2016 04:26:04] “GET /api/method/frappe.async.get_user_info?sid=81a14493030f0d7f7e6bd4d3c1bc6d57d3978519f1f9c5cf7d5419cb HTTP/1.0” 200 -
04:26:10 web.1 | Module import failed for Page (frappe.core.doctype.page.page_dashboard)
04:26:25 web.1 | 127.0.0.1 - - [22/Nov/2016 04:26:25] “GET /api/method/frappe.async.get_user_info?sid=81a14493030f0d7f7e6bd4d3c1bc6d57d3978519f1f9c5cf7d5419cb HTTP/1.0” 200 -
04:26:32 web.1 | 127.0.0.1 - - [22/Nov/2016 04:26:32] “POST / HTTP/1.0” 200 -
04:26:33 web.1 | 127.0.0.1 - - [22/Nov/2016 04:26:33] “GET /desk HTTP/1.0” 200 -
04:27:02 web.1 | 127.0.0.1 - - [22/Nov/2016 04:27:02] “GET /api/method/frappe.async.get_user_info?sid=81a14493030f0d7f7e6bd4d3c1bc6d57d3978519f1f9c5cf7d5419cb HTTP/1.0” 200 -
04:27:35 web.1 | 127.0.0.1 - - [22/Nov/2016 04:27:35] “POST / HTTP/1.0” 200 -
04:28:04 web.1 | 127.0.0.1 - - [22/Nov/2016 04:28:04] “POST / HTTP/1.0” 200 -
04:28:33 web.1 | 127.0.0.1 - - [22/Nov/2016 04:28:33] “POST / HTTP/1.0” 200 -
04:28:47 worker_short.1 | 04:28:47 short: frappe.utils.background_jobs.execute_job(async=True, event=u’all’, job_name=u’frappe.email.queue.flush’, kwargs={}, method=u’frappe.email.queue.flush’, site=u’site1.local’, user=u’Administrator’) (96569dd1-cae9-4cdf-8a8b-81d0790ea88b)
04:28:50 worker_short.1 | 04:28:50 short: Job OK (96569dd1-cae9-4cdf-8a8b-81d0790ea88b)
04:28:50 worker_short.1 | 04:28:50 Result is kept for 500 seconds
04:28:50 worker_short.1 | 04:28:50
04:28:50 worker_short.1 | 04:28:50 *** Listening on short…
04:28:50 worker_short.1 | 04:28:50 short: frappe.utils.background_jobs.execute_job(async=True, event=u’all’, job_name=u’frappe.email.doctype.email_account.email_account.pull’, kwargs={}, method=u’frappe.email.doctype.email_account.email_account.pull’, site=u’site1.local’, user=u’Administrator’) (c21c69d9-35fa-4d36-a553-953bc7fe254e)
04:28:52 worker_short.1 | 04:28:52 short: Job OK (c21c69d9-35fa-4d36-a553-953bc7fe254e)
04:28:52 worker_short.1 | 04:28:52 Result is kept for 500 seconds
04:28:52 worker_short.1 | 04:28:52
04:28:52 worker_short.1 | 04:28:52 *** Listening on short…
04:28:52 worker_short.1 | 04:28:52 short: frappe.utils.background_jobs.execute_job(async=True, event=u’all’, job_name=u’frappe.email.doctype.email_account.email_account.notify_unreplied’, kwargs={}, method=u’frappe.email.doctype.email_account.email_account.notify_unreplied’, site=u’site1.local’, user=u’Administrator’) (76e2a5a4-d6b0-4c20-aafc-5fda91080b2f)
04:28:52 worker_short.1 | 04:28:52 short: Job OK (76e2a5a4-d6b0-4c20-aafc-5fda91080b2f)
04:28:52 worker_short.1 | 04:28:52 Result is kept for 500 seconds
04:28:52 worker_short.1 | 04:28:52
04:28:52 worker_short.1 | 04:28:52 *** Listening on short…
04:28:52 worker_short.1 | 04:28:52 short: frappe.utils.background_jobs.execute_job(async=True, event=u’all’, job_name=u’frappe.oauth.delete_oauth2_data’, kwargs={}, method=u’frappe.oauth.delete_oauth2_data’, site=u’site1.local’, user=u’Administrator’) (8de4fd79-cc1f-4640-a657-d212c722bd70)
04:28:53 worker_short.1 | 04:28:53 short: Job OK (8de4fd79-cc1f-4640-a657-d212c722bd70)
04:28:53 worker_short.1 | 04:28:53 Result is kept for 500 seconds
04:28:53 worker_short.1 | 04:28:53
04:28:53 worker_short.1 | 04:28:53 *** Listening on short…
04:29:03 web.1 | 127.0.0.1 - - [22/Nov/2016 04:29:03] “POST / HTTP/1.0” 200 -
04:29:34 web.1 | 127.0.0.1 - - [22/Nov/2016 04:29:34] “POST / HTTP/1.0” 200 -
04:30:06 web.1 | 127.0.0.1 - - [22/Nov/2016 04:30:06] “POST / HTTP/1.0” 200 -
04:30:33 web.1 | 127.0.0.1 - - [22/Nov/2016 04:30:33] “POST / HTTP/1.0” 200 -
04:31:04 web.1 | 127.0.0.1 - - [22/Nov/2016 04:31:04] “POST / HTTP/1.0” 200 -

`

i think its not a locale issue coz i`v another server with the same config and host . even same locale output but without server error !!

any help please !!

Is this occurring for every bench start. You can try clearing the cache by executing bench --site [site_name] clear-cache

Besides, are you able open the link http://site_name:port on your machine.

thanks @shreyasp for reply

actually yes its occurring every bench start and i`v cleared the cache many times before

and this site is hosted on an ubuntu server so i can`t test it from the server but i can access it normaly after the bench start but after a while it starts to show more than error message like

{‘retry’: 0, ‘log’: <function log at 0x7fa371123050>, ‘site’: u’site1.local’, ‘event’: u’daily_long’, ‘method_name’: u’frappe.integrations.doctype.dropbox_settings.dropbox_settings.take_backups_daily’, ‘method’: <function take_backups_daily at 0x7fa36cb4d410>, ‘user’: u’Administrator’, ‘kwargs’: {}, ‘async’: True, ‘job_name’: u’frappe.integrations.doctype.dropbox_settings.dropbox_settings.take_backups_daily’}
Traceback (most recent call last):
File “/home/frappe/frappe-bench/apps/frappe/frappe/utils/background_jobs.py”, line 61, in execute_job
method(**kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/integrations/doctype/dropbox_settings/dropbox_settings.py”, line 158, in take_backups_daily
take_backups_if(“Daily”)
File “/home/frappe/frappe-bench/apps/frappe/frappe/integrations/doctype/dropbox_settings/dropbox_settings.py”, line 165, in take_backups_if
take_backup_to_dropbox()
File “/home/frappe/frappe-bench/apps/frappe/frappe/integrations/doctype/dropbox_settings/dropbox_settings.py”, line 178, in take_backup_to_dropbox
frappe.errprint(error_message)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 230, in errprint
print cstr(msg)
IOError: [Errno 32] Broken pipe

and the above one