Sending emails as a logged-in user email-id

How to send e-mail as coming from logged-in user’s own email address instead of email_id present in Email Account setup?

I am checking this option, always_use_account_email_id_as_sender=1 but still email is being send as email_id present in Email Account Setup not as logged_in user email address.

How can I resolve this issue?

How to send e-mail as coming from logged-in user’s own email address instead of email_id present in Email Account setup?

This will be possible with Email Inbox feature of version 8. It is currently under development and scheduled for release later this week.

I am checking this option, always_use_account_email_id_as_sender=1
but still email is being send as email_id present in Email Account
Setup not as logged_in user email address.

For now, system only does masking. The name of the sender is updated in the From field, but reply-to address is one mentioned in the Email Account. That’s because ERPNext has login credentials for the Account mentioned in the Email Account, and not of user’s email account.

I’m at latest development branch of v9. And it still sends through system mail instead of user’s defined email.

Always use sender as sender mail is selected. Am I doing it wrong or still underdevelopment?

Apparently all “replies” goes through user emails. But when you compose a new mail through Email Inbox (->New) it sends through system mail instead of user mail.

Is there a way to change that?

Hi Umair,

I have version erpnext version 12. I have correct set up for Email Inbox. Still When I log in and Click on New Email button to send email. Emails are still sent from default outgoing email.

please suggest what to do?

Have you checked “Always use accounts email address as sender” in the user settings?

Yes I have checked it.