ERPNext.com Frappe Cloud Documentation Partners Frappe School Public Chat

Save button disappears when I try to edit "Patient" doc type in the Healthcare domain

Hello all,

Gradually working my head around ERPNext (Healthcare Domain) but keep running into little issues.

I want to remove the “full name” display from list view and understand that I need to edit the doc type (View Settings) and change the title field…the problem is that as soon as I make a change to the doc type (Patient) the “Save” button disappears and I am unable to save any changes made. Refreshing/reloading doesn’t work. I get the “Save” button but it disappears again as soon as I edit something.

My list view is displaying name twice and I don’t want it displayed at all… :frowning: I think the above is how to fix the first (far left) display but don’t know how to remove the other one (further to the right) yet. It is the “first_name” field. I wanted to delete it but wasn’t able to and thus made it invisible with a default of “Name”. That works aside from the fact that it shows up in the list…which I don’t want…as it’s a long list of meaningless names (Name, Name1, Name2, Name3 etc.)

Any advice will be most appreciated.

Regards

Jason

Sorry, this seems to be my MO. I needed to edit the setting in the Form not the Doc Type. Changing the View Settings Title Field in the form accomplished what I wanted…for the left most displayed field. I still have to figure out how to remove the other “name” (first name) field from my list view but I’m making progress. :slight_smile:

Jason

Always use Customize Form to make changes.

Thanks :wink:

Any ideas about how to remove the “first_name” displayed as Name from the list view in the Healthcare domain? I don’t see a way via the browser/application interface but it’s certainly possible that I am missing it.

I’ve tried removing it from the list view via List Settings as well as the tick box for the field itself from the Customize form page but it still shows up in the list. :frowning:

I’ve even set it as “Hidden” which removes it from being displayed on each individual record but not from the list view. :grimacing:

Regards

Jason

Just untick In List View for that field.

rtdany10,

Unfortunately that does not work. I have tried unticking “In List View” as well as making the field invisible but it still shows up in the list view. I made it invisible and put “Name” as the default so I’m getting “Name”, “Name - 1”, “Name - 2” etc. which is fine if I can keep it from appearing but…it shows up in the list no matter what I do. :frowning:

06
23

P.S. I tried removing it as a “Mandatory” field but got an error.

You will have to write a client script for list view.

frappe.listview_settings['Patient'] = {
hide_name_column: true, // hide the last column which shows the `name`
}

Check out the documentation

1 Like

mujeerhashmi,

Thank you. I was starting to think that was/is the case. My problem is, being new to ERPNext, I’m not sure where that script needs to go…? In patient.py maybe? Or is there a place where it can be added via the Browser interface?

Regards

Jason

P.S. Oops, sorry, I just saw the link you provided. Thanks, I’ll work my way through that. :wink:

To be more precise you need to refer to this in the documentation.

3 Likes

mujeerhashmi,

Thanks a million! :slight_smile: You made my day. I’ve been obsessed with that little setting for a couple of days now. That did it. I no longer have the “Name” column displaying and learned some valuable information about fine tuning ERPNext. :slight_smile:

Cheers!

Jason

1 Like