ERPNext Conference 2019* ERPNext.com Blog

Sales Taxes and Charges printout in Invoice / Sale order


#1

Are we able to configure the the layout out the “Sales Taxes and Charges” when printing document like sales invoice or sales order?

No matter how I customize the form or doctype “Sales Taxes and Charges” to “Print hide” any item. Or I configure the print format (uncheck every column)

The print out is always the same

And also if the Sales Taxes and Charges table (like in sales invoice) has a line but with 0 amount, the line won’t get printed. We need it to be printed even it is zero value.

How can I configure it?


#2

You would best be served by doing a Jinja based custom print. I have created an example here


#3

How is ERPNEXT currently handling the layout the “Sales Taxes and Charges” section in the print out of Sales Invoice / Sales order, etc?


#4

Thank you @trentmu. Great contribution.

Would you mind taking a step back and explaining which file it is that should be changed in your example?


#5

If you go to… Settings…Print Format…
Once there, create New, give it a name (eg. “MyCompany Sales Invoice”), change it to Custom Format (tickbox) - with doctype=“Sales Invoice” in this particular case. Module is “Accounts”.
Print Format Type = Jinja.
The code gets placed into the HTML box.
You can optionally Make Default if you prefer your version to the “normal” one


#6

Thank you @trentmu

I have already created a new invoice, which I have done by using the “Customize” button on the print options. I then used the visual format builder to make changes to the new invoice, which serves us well,

Now, I want to make further changes to the invoice which cannot be done with the visual format builder. I am comfortable coding HTML, CSS and Javascript. I just don’t know how to go about accessing the code for my new invoice.


#7

I was just wondering. I did the normal print format builder and I just dragged the “Sales Taxes and Charges” to the form. And amazingly the Tax field always goes to the right side and just show the description and value of the lines, no matter how I configure it (like checking other fields, etc) And the line won’t show if it has a value of 0. I am just wondering how did this work as it is very different from the rest of the fields I configured. At the moment I just want to just the print format way and get the Tax line printed out even if it has value 0 (it used to work that way with the previous version).


#8

Try customizing standard print template, remove the Sales Taxes and Charges table and drag and drop total sales taxes and charges into the Grand Totals section:


#9

I need to display the description of the tax.


#10

You can change the label of the Totals Sales Tac in customize by clicking the gear icon.


#11

I found out in the new version, the print setting has a new option “Print taxes with zero amount” and by ticking it, my problem is solved.