Restore failed on VM


I’m trying to restore a database using the restore function, but keep getting errors.

Any advice will be greatly appreciated.

VM can be seen below.

What’s the exact command that you are using?

bench --site SITENAME backup

SITENAME = erpnext.erpnext-vm

bench --site erpnext.erpnext-vm restore FILEPATH

after that failed, I tried

bench --force --site erpnext.erpnext-vm restore FILEPATH

Where you able to recreate the issue?

try this command
bench --site erpnext.erpnext-vm --force restore $PWD/path to sql file

Still getting this:

Do you have any other advice?

@DieTjommie Did you able to restore your database to new-site?
You can create new site and restore database.

I have created a new site and applied the same process and get the same result. Should I remove any data from the new site to restore mine to it?

Can you give more details? Which command you run?

I backup my system using:

bench --site erpnext.erpnext-vm backup

I then move the backed up file to the target server and restore it using this command:

bench --site erpnext.erpnext-vm restore filepath

I have alos tried

bench --force --site erpnext.erpnext-vm restore filepath
bench --site erpnext.erpnext-vm --force restore $PWD/path to sql file

I have used these command successfully before, but for some reason its not working now.

Thank you for your time.

Always restore backup into new site.
You need to create new-site and restore backup.
You can also run bench reinstall command to wipe old data in site

I have created a new site and used the reinstall command, the vm still gives me this output.

ok, if you restore successfully, then run bench migrate and bench build command.
and try to login into ERPNext

At the moment its not restoring successfully. I am restoring into a new site. I even reinstalled the existing site. Still not working. Get the same results.

@DieTjommie looks like temporary issue.
Can you update your virtual box and try to restore again?

I have update to the latest version of virtual box, the error remains the same. Could it be an issue with the file I created during the backup. 20160208_147262_database.sql.gz ?

@DieTjommie may be its possible.

Did you run bench build and bench migrate after restoring backup?

[quote=“kolate_sambhaji, post:19, topic:10298”]
Did you run bench build and bench migrate after restoring backup?
[/quote] Yes, the port gives me an internal server error. Same output on the vm as before.