Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

[Release] ERPNext Version 13

Good catch (and probably correct diagnosis). Didn’t realze fail2ban was installed, but we used the erpnext easy script this time…

sudo systemctl status fail2ban
● fail2ban.service - Fail2Ban Service
     Loaded: loaded (/lib/systemd/system/fail2ban.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2021-04-07 17:56:41 UTC; 23h ago
       Docs: man:fail2ban(1)
    Process: 638 ExecStartPre=/bin/mkdir -p /run/fail2ban (code=exited, status=0/SUCCESS)
   Main PID: 660 (f2b/server)
      Tasks: 7 (limit: 9448)
     Memory: 20.3M
     CGroup: /system.slice/fail2ban.service
             └─660 /usr/bin/python3 /usr/bin/fail2ban-server -xf start

Apr 07 17:56:41 rxderp systemd[1]: Starting Fail2Ban Service...
Apr 07 17:56:41 rxderp systemd[1]: Started Fail2Ban Service.
Apr 07 17:56:41 rxderp fail2ban-server[660]: Server ready

But there you go. It’s definitely installed. I’ll configure fail2ban email notifications (first) and see if that was it, then be sure to whitelist our ips.

For reference:
https://linuxize.com/post/install-configure-fail2ban-on-ubuntu-20-04/
https://www.fail2ban.org/wiki/index.php/Main_Page

1 Like

Naming Series not show in ERPNext: v13.0.1 (version-13)

But V12 Its show

The offer name can be modified, but the sale name cannot. In v12 you can modify both
Offer


Sales

Below is my custom script snippet which helps to select departments based on the company selected.

company:function(frm) {
	    frm.events.filter_cmp_items(frm);
	    frm.set_query('department', () => {
        return {
            filters: {
                company: frm.doc.company
                }
            };
        });

It was working perfectly fine in v12 but after upgrading to v13, I see that like this few more places the filters are not working.

Please help.

Update
If a field is set to default like I had set a default company then in that case this on change a field value(company) doesn’t work. When I removed it as default, everything was fine.
But this is not proper behavior.

Please resolve @nabinhait

frappe@erpnext5512167:~/frappe-bench$ bench switch-to-branch 13
LOG: Fetching upstream unshallow for frappe
$ git remote set-branches upstream ‘*’
$ git fetch --all --unshallow
Fetching upstream
fatal: unable to access ‘https://github.com/frappe/frappe/’: Failed to connect to github.com port 443: No route to host
error: Could not fetch upstream
fatal: unable to access ‘https://github.com/frappe/frappe/’: Failed to connect to github.com port 443: No route to host
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.bench/bench/cli.py”, line 41, in cli
bench_command()
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 764, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 717, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 1137, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 956, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python3.6/dist-packages/click/core.py”, line 555, in invoke
return callback(*args, **kwargs)
File “/home/frappe/.bench/bench/commands/update.py”, line 43, in switch_to_branch
switch_to_branch(branch=branch, apps=list(apps), upgrade=upgrade)
File “/home/frappe/.bench/bench/app.py”, line 417, in switch_to_branch
switch_branch(branch, apps=apps, bench_path=bench_path, upgrade=upgrade)
File “/home/frappe/.bench/bench/app.py”, line 389, in switch_branch
version_upgrade = is_version_upgrade(app=app, bench_path=bench_path, branch=branch)
File “/home/frappe/.bench/bench/app.py”, line 283, in is_version_upgrade
raise InvalidBranchException(“Specified branch of app {0} is not in upstream”.format(app))
bench.app.InvalidBranchException: Specified branch of app frappe is not in upstream

Only switch-to-branch 13 is not enough, it’s incomplete command. See following

bench switch-to-branch version-13 frappe 
erpnext --upgrade
bench setup requirements
bench update --patch
2 Likes

bench --site erpnext.vm console

In [1]: import sys

TypeError Traceback (most recent call last)
/usr/lib/python3.8/codeop.py in call(self, source, filename, symbol)
139
140 def call(self, source, filename, symbol):
–> 141 codeob = compile(source, filename, symbol, self.flags, 1)
142 for feature in _features:
143 if codeob.co_flags & feature.compiler_flag:

TypeError: required field “type_ignores” missing from Module

In [2]:

Any idea what’s going on? I copied my sites folder to another location , reinstall frappe-bench, switched to branch 12, copied the erpnext site back after installing Erpnext app and same error on update. ipython does not have the same error as bench console.

you need to upgrade ipython by executing following code in your bench directory:

env/bin/pip install --upgrade ipython

Thank you @snv , it worked a treat!

My bench update --patch errors out with :

No module named ‘erpnext.hr.doctype.employee_tax_exemption_declaration’

I will proceed to frappe.reload_doc … as those errors continue.

Please find the solution that worked for me here

1 Like

I am an Erpnext user since 3 years. I know better to avoid even the initial stable releases cause they usually contain huge show stopper bugs even in most basic accounting functions. But few weeks back erpnext 12 had broken as some users weren’t able to login. Although the developers were quick to release a patch in 3-4 days, the system was broken for 3-4 days and I was desperate because I am providing support for multiple sites. I stayed up 24 hours behind this thing and ended up taking the plunge and upgrading all sites to v13 beta because that didn’t have the login issue, and I could get some sleep, finally. Boy did I have any idea what I was getting into. Users are unable to submit purchase invoice due to “Stock value and account balance out of sync error”. I must mention that many of my sites are relatively new (less than few months). Even those have issues. Terms and Conditions doesn’t fetch on selection of a preset. Default price list doesn’t fetch on creating new quotation, invoice, etc. Issues are endless. The scariest part is accounting stuff going haywire. According to my accountants, once trial balance goes out of balance, it’s a nightmare to get it back in balance.

Thank you for listening to my rant. Developers, you’re doing an amazing job. The ERP looks good and is blazing fast right now. It’s unbelievable! But you’re gonna lose users if the basic functions keep breaking.

Also could you guys post a patch already? Last patch didn’t seem to help much. I keep refreshing the git releases page most of the time hoping for an update.

2 Likes

Issue 1:


Issue 2: AttributeError: ‘WebsiteTheme’ object has no attribute ‘ignored_apps’ (I have to nano and open some website_theme.py file and remove the line that checks ignored apps in get_scss function so update can work. This happens only for an old site of mine though)
Issue 3: Terms and Conditions dont fetch on preset selection in Quotation, sales invoice. Item prices don’t fetch in Quotation. We have to select the price list. Price list used to be automatically selected before.

UX recommendation: Since we now have immutable ledger and we cannot delete a sales invoice even if it is cancelled unlike before, could you please update the error messages? Now admins can go an manually delete the linked GL entries and then delete the sales invoices. I am afraid that could mess up stock balance etc. Could you provide a feature to “archive” things instead? and remove delete option for cancelled items? archiving would hide the cancelled items out of sight and not be an eye sore.

Check out this

Thanks amit, I saw that already and I think it doesn’t apply in my case. In v12 it was working perfectly. Also it’s happening in many sites where I left the precision settings as default.

v13 still lots of bug agree

1 Like

39%20PM

Dates are not correctly shown

fail2ban was causing me exactly that behavior (ERPNext v12 and 13, both installed via easy script). Once configured to not to ban LAN and VPN, problem is gone.

I try to switch from beta to V 13 got me below

how to resolve this

Backing up sites…
Traceback (most recent call last):
File “/usr/lib/python3.7/runpy.py”, line 183, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File “/usr/lib/python3.7/runpy.py”, line 109, in get_module_details
import(pkg_name)
File “/home/sanath/frappe-bench/apps/frappe/frappe/init.py”, line 1627, in
def log_error(message=None, title=
(“Error”)):
File “/home/sanath/frappe-bench/apps/frappe/frappe/init.py”, line 69, in _
from frappe.translate import get_full_dict
File “/home/sanath/frappe-bench/apps/frappe/frappe/translate.py”, line 18, in
from frappe.model.utils import render_include, InvalidIncludePath
File “/home/sanath/frappe-bench/apps/frappe/frappe/model/utils/init.py”, line 9, in
from frappe.build import html_to_js_template
File “/home/sanath/frappe-bench/apps/frappe/frappe/build.py”, line 18, in
import psutil
ModuleNotFoundError: No module named ‘psutil’

Execute

./env/bin/pip install psutil
2 Likes

Now got me this, but it receiving continually after make bench setup requirements as suggested below.

UNRESOLVED_IMPORT : ‘vue/dist/vue.js’ is imported by …/erpnext/erpnext/public/js/hub/vue-plugins.js, but could not be resolved – treating it as an external dependency
Cannot find some dependencies. You may have to run “bench setup requirements” to install them.

UNRESOLVED_IMPORT : ‘vue/dist/vue.js’ is imported by …/erpnext/erpnext/public/js/hub/marketplace.js, but could not be resolved – treating it as an external dependency
Cannot find some dependencies. You may have to run “bench setup requirements” to install them.

MISSING_GLOBAL_NAME : No name was provided for external module ‘vue/dist/vue.js’ in output.globals – guessing ‘Vue’

1 Like