Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

[Release] ERPNext Version 13

Should step 5 be…

python3 install.py --verbose --production –frappe-branch version-13 --erpnext-branch version-13 --user frappe

If you want to run stable production v13 release and not beta?

1 Like

Hello everyone.

My sequence with the update:

sudo apt update
sudo apt upgrade
curl -fsSL https://deb.nodesource.com/setup_10.x | sudo -E bash -
sudo apt-get install -y nodejs
sudo npm install -g npm
sudo npm install -g yarn
cd / opt / erpnext / erpnext
bench setup requirements
bench update
sudo reboot
bench switch-to-branch version-13 frappe erpnext --upgrade

Error:

File “/opt/erpnext/bench-repo/bench/app.py”, line 417, in switch_to_branch
switch_branch (branch, apps = apps, bench_path = bench_path, upgrade = upgrade)
File “/opt/erpnext/bench-repo/bench/app.py”, line 409, in switch_branch
reload_module (utils)
NameError: global name ‘utils’ is not defined

UPDATE
I have followed these steps, but in the file /opt/erpnext/bench-repo/bench/app.py, prior to the update and the error has not appeared in a new update.

However now this appears:

File “/opt/erpnext/erpnext/apps/frappe/frappe/website/doctype/website_theme/website_theme.py”, line 69, in generate_bootstrap_theme
self.theme_scss = content = get_scss (self)
File “/opt/erpnext/erpnext/apps/frappe/frappe/website/doctype/website_theme/website_theme.py”, line 145, in get_scss
apps_to_ignore = tuple ((d.app + ‘/’) for d in website_theme.ignored_apps)
AttributeError: ‘WebsiteTheme’ object has no attribute ‘ignored_apps’

1 Like

V13 is broken on Android and iOS apps. The app is crucial for us.

1 Like

after issuing command
bench switch-to-branch version-13 frappe erpnext --upgrade
then attempting to run bench update I get the following error

$ bench update

Traceback (most recent call last):
File “/usr/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.local/lib/python2.7/site-packages/pkg_resources/init.py”, line 489, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/home/frappe/.local/lib/python2.7/site-packages/pkg_resources/init.py”, line 2793, in load_entry_point
return ep.load()
File “/home/frappe/.local/lib/python2.7/site-packages/pkg_resources/init.py”, line 2411, in load
return self.resolve()
File “/home/frappe/.local/lib/python2.7/site-packages/pkg_resources/init.py”, line 2417, in resolve
module = import(self.module_name, fromlist=[‘name’], level=0)
File “/home/frappe/.bench/bench/cli.py”, line 3, in
from bench.utils import is_root, PatchError, drop_privileges, get_env_cmd, get_cmd_output, get_frappe, log, find_parent_bench
File “/home/frappe/.bench/bench/utils.py”, line 23, in
import requests
File “/usr/lib/python2.7/site-packages/requests/init.py”, line 43, in
import urllib3
File “/usr/lib/python2.7/site-packages/urllib3/init.py”, line 10, in
from .connectionpool import (
File “/usr/lib/python2.7/site-packages/urllib3/connectionpool.py”, line 31, in
from .connection import (
File “/usr/lib/python2.7/site-packages/urllib3/connection.py”, line 45, in
from .util.ssl_ import (
File “/usr/lib/python2.7/site-packages/urllib3/util/init.py”, line 5, in
from .request import make_headers
File “/usr/lib/python2.7/site-packages/urllib3/util/request.py”, line 5, in
from …exceptions import UnrewindableBodyError
ImportError: cannot import name UnrewindableBodyError

Did you find any solution for this error? I am also stuck with this error.

Hello,

Anyone gets issue with Item variants attribute value not show

And how to fix it?
Thank you.

AttributeError: ‘WebsiteTheme’ object has no attribute ‘background_color’

During upgrade getting the below error

@gsarunk
Try skip failing.
bench --site dev.nectar.lmnas.com migrate --skip-failing

then try again.
bench update --patch

1 Like

Can you try to reload Website Theme manually from Console?

frappe.reload_doc('website', 'doctype', 'website_theme', force=True)
frappe.db.commit()

Please advise for this error:

Try

frappe.reload_doc(“payroll”, “doctype”, “salary_component”)

did you upgrade your bench cli?

I am getting this

In [1]: frappe.reload_doc(‘accounts’, ‘doctype’, ‘pos_invoice_item’)
File “”, line 1
frappe.reload_doc(‘accounts’, ‘doctype’, ‘pos_invoice_item’)
^
SyntaxError: invalid character in identifier

Have you committed after reloading from console?

Use frappe.db.commit() to commit.

Use this frappe.reload_doc('accounts', 'doctype', 'pos_invoice_item')

1 Like

I do face the same issue. Any fix ?

How to upgrade bench CLI?

So, you are using perpetual inventory system and in perpetual inventory system, when you receive an Item, system debits “Stock In Hand” instead of booking expenses (COGS). In version 13, the system corrects it automatically and gives a message.

1 Like

I shared this in last post.

I’m sharing it again.

This topic is a tutorial for installing and upgrading bench [Tutorial] Installing and Upgrading Bench CLI (ver. 5.3)

skip-failing is not recommended, it can lead to other unwanted problems. Always try to dig deep and solve the actual error.