ERPNext Foundation ERPNext Cloud User Manual Blog Discuss Frappé* Donate

[Release] ERPNext Version 12


#106

install erpnext v12

switch to 11, restore, migrate

bench switch-to-branch version-11 frappe erpnext --upgrade
drop site
bench drop-site <site-name>
create new-site
bench new-site <site-name>
turn on developer mode
bench set-config developer_mode 1
drop db
mysql -u root -p
show databases;
drop database<db-name>
exit
restore
wget <backup>
gunzip <backup>
bench --site <site-name> --force restore <backed-up-db.sql>
bench enable-scheduler
get ur custom apps
bench get-app <git-repo.-name>
install erpnext on the site
bench --site <site-name> install-app erpnext
switch to 11
bench switch-to-branch version-11 frappe erpnext --upgrade
migrate
bench --site <site-name> migrate
restart bench
bench restart
reload nginx
service nginx reload
update bench
bench update
change admin pwd
bench --site <site-name> set-admin-password

switch to 12

bench switch-to-branch version-12 frappe erpnext --upgrade
bench run-patch erpnext.patches.v12_0.make_item_manufacturer
bench switch-to-branch version-12 frappe erpnext --upgrade
restart bench
bench restart
reload nginx
service nginx restart
update bench
bench update


#107

trying to migrate a system I got this: frappe.exceptions.CharacterLengthExceededError: DocField, Row 11: ‘Depends On’ (eval:([“Data”, “Select”, “Table”, “Text”, “Text Editor”, “Link”, “Small Text”, “Long Text”, “Read Only”, “Heading”, “Dynamic Link”].indexOf(doc.fieldtype) !== -1)) will get truncated, as max characters allowed is 140
I could not find much about. Any ideas, please!


#108

try limiting the character length of the field


#109

Scenario : updating bench from v11(master)–> v11(version-11) having custom app
Steps that worked:

$ cd / home/frappe/frappe-bench/apps/erpnext
$ git config remote.upstream.fetch "+refs/heads/*:refs/remotes/upstream/*"

$ bench switch-to-branch version-11 frappe erpnext
$ bench update

[Solved] bench.utils.CommandFailedError: yarn install
#110

Thanks @Vinob_chander_Ramasw, I do not have access but only through terminal, sql (?) which i don’t know much…


#111

u should also git fetch upstream and may want to do the same for ur custom apps too


#112

It seems on my other article nobody is answering so perhaps here someone can see it better.

Here is an issue what I am experiencing right now:

After a fresh v11 to v12 upgrade - this is the error I receive when trying to create an Auto Repeat: TypeError: can’t compare datetime.date to unicode

Anybody else getting this error and having a solution ?


#113

any info on this?


#114

I wonder why in the new v12 the Projects don’t show the Tasks related to that project ?

If this is a new thing, it’s a terrible idea …


#115

how to install ERPNEXT 11


#116

Updated to v12 successfully but get an Internal Server Error.

$ service nginx restart
-su: 6: service: not found

apt search nginx gives:
nginx/oldoldstable,now 1.6.2-5+deb8u6 all [installed]
small, powerful, scalable web/proxy server

Any ideas please?


#117

sudo systemctl restart nginx


#118

Closing this thread now as it’s getting very hard to follow.


#119