Try ERPNext Buy Support Partners Foundation

[Release] ERPNext Version 12

Whoa!!! This is awesome… I almost feel like a kid in a candy store :blush:

Did this ship with the DB API as planned? Didn’t see anything about that in the release notes

Cheers!

I’m up and running! Needed to increase my VM on GCloud as my ram was too low. Now it seems to be working smoothly. Thanks

1 Like

As of now.

~/frappe-bench/apps/erpnext$ git branch -a

  • develop
    remotes/upstream/HEAD -> upstream/develop
    remotes/upstream/clarkejj-patch-1
    remotes/upstream/develop
    remotes/upstream/fix_bom_include_exploded_item
    remotes/upstream/hotfix
    remotes/upstream/hr_dashboard
    remotes/upstream/master
    remotes/upstream/revert-16950-fix-issue-credit
    remotes/upstream/staging
    remotes/upstream/v10.x.x
    remotes/upstream/v12
    remotes/upstream/v4.x.x
    remotes/upstream/v5.x.x
    remotes/upstream/v6.x.x
    remotes/upstream/v7.0.x
    remotes/upstream/v7.x.x
    remotes/upstream/v8.x.x
    remotes/upstream/v9.x.x

~/frappe-bench$ bench switch-to-branch v12 erpnext
Switching for erpnext
INFO:bench.utils:git config --unset-all remote.upstream.fetch
INFO:bench.utils:git config --add remote.upstream.fetch ‘+refs/heads/:refs/remotes/upstream/
INFO:bench.utils:git fetch upstream --unshallow
remote: Enumerating objects: 1, done.
remote: Counting objects: 100% (1/1), done.
remote: Total 1 (delta 0), reused 1 (delta 0), pack-reused 0
Unpacking objects: 100% (1/1), done.
INFO:bench.utils:git checkout v12
Branch v12 set up to track remote branch v12 from upstream.
Switched to a new branch ‘v12’
INFO:bench.utils:git merge upstream/v12
Already up-to-date.
Successfully switched branches for:
erpnext
Switched to v12
Please run bench update --patch to be safe from any differences in database schema

Hi
v11 running in VM box
Trying to upgrade to V12
when i run this
frappe@ubuntu:~/frappe-bench$ git config remote.upstream.fetch “+refs/heads/:refs/remotes/upstream/
i get error
fatal : not in a git directory
how to resolve this
regards
Hemanth

Hi Kirishnan,

Check this link out. That should resolve your issue. Hopefully. The software behind this forum replaces some of the characters, that’s the problem.

Thanks

Jay

Sir
Thanks for the reply
this command
git config remote.upstream.fetch “+refs/heads/:refs/remotes/upstream/”
iam running @ frappe@ubuntu:~/frappe-bench$
should i change the directory to git
if so how

how to execute this command
“What do you see if you go to frappe-bench/apps/erpnext and do a git status?”
should i change the directory from frappe@ubuntu:~/frappe-bench$ to ?
Thanks and regards
Hemanth

1 Like

You need to run that from the frappe-bench/apps/erpnext folder and you have to replace in your command line “ with " and ” with ".

plus you need to add a star (the multiplication key *) after heads/ and upstream/

If that doesn’t go through run the same command with git config --replace-all …

Hope this helps.

Thanks

Jay

1 Like

Sir
Thanks for the reply
I tried as mentioned…but no results
this is what i get


tried with git config --replace-all
no results
thanks and regards
Hemanth

1 Like

There won’t be any results in that screen. Now go back to frappe-bench folder and run

bench switch-to-branch version-12 --upgrade
bench update --patch

And if the DocType Item Manufacturer not found shows up:

bench run-patch erpnext.patches.v12_0.make_item_manufacturer

if you have multiple sites you will have to do that for each. The default site will go through when you run it the first time, but for the others you will have to use the command

bench --site sitename run-patch erpnext.patches.v12_0.make_item_manufacturer

Hope that helps

Thanks

Jay

2 Likes

Sir
Thanks a lot for the reply
Actually i tried going back to frappe-bench folder and i couldnt
I Tried cd frappe-bench and it didnt work
i know iam asking a very silly question …but please help me
how do i go back to frappe-bench folder
or should i reboot the system to go to frappe-bench folder
thanks and regards
hemanth

1 Like

Dude.

Type cd …/… from the ERPNext folder.

Or cd ~/frappe-bench from any other folder.

Thanks

Jay

1 Like

would you mind to specify how much RAM was not enough and which amount you have increased that to?

2 Likes

I was using v11 on GCP

  • g1-small Shared-core machine type with 0.5 vCPU, 1.70 GB of memory, backed by a shared physical core.

Now I upgraded it for v12 to:

  • n1-standard-1 Standard machine type with 1 vCPU and 3.75 GB of memory.

https://cloud.google.com/compute/docs/machine-types#general_purpose

2 Likes

I cannot speak to the experience of others but after using it for nearly a day, V12 seems way more stable on release day than V11 was on release day. I know there are a few bugs here and there that need tidying up, but this is by far the most stable release i have experienced. And i love the new interface (I was initially skeptical about the changes when they were first announced). Some of the changes are indeed welcome (although there’s a bit of learning needed in order to understand the changes and additions).

Kudos to the entire Frappe team, developers and contributors for this amazing leap forward. Thank you for the work you do. :clap::clap::clap::clap::clap:

8 Likes

did you implement a K8 or installed/upgraded it?

1 Like

My upgrade attempts failed as I was having mysql permission issues patching Item_Manufacture. I could not figure out why mysql was throwing 1045 permission denied error and all my attempts to fix it directly failed, so I set up a fresh instance and restored backup of my sites and it’s working fine.

1 Like

Just to clear the process:

  • on which version was the backup taken? v11.x or version-11 ?
  • is it guaranteed that a verison-11 backup is restored onto a version-12 setup?
1 Like

No chance for soem people. We are stuck by one of the patches:

pymysql.err.InternalError: (1054, “Unknown column ‘pricing_rules’ in ‘field list’”)

Since the Easy install prepares a version-12 system, we are not able to prepare a version-11 system and thus we are at the hands of developers. Not that we may do a manual install but I don’t think that will solve the version-12 upgrade problem specific to that patch.

1 Like

@Tufan_Kaynak2

My Backup was V11 and it restored to version 12 on most of my sites. I however had an issue with one site as i was getting this error:frappe.exceptions.DoesNotExistError: DocType Item Manufacturer not found. This was eventually fixed with bench --site sitename run-patch erpnext.patches.v12_0.make_item_manufacturer . My instance has been running smoothly since then. I haven’t really faced any issue since the move to V12.

1 Like

Hi
I get this error when i do a v12 upgrade


Any pointers on this
Regards
Hemanth

1 Like