Try ERPNext Buy Support Partners Foundation

[Release] ERPNext Version 12

Should be

bench switch-to-branch version-12

3 Likes

AWESOME!!

I am getting the following:

sudo bench switch-to-branch version-12
Branch version-12 does not exist in Upstream for erpnext
Branch version-12 does not exist in Upstream for frappe
Switched to version-12
Please run bench update --patch to be safe from any differences in database schema

$ sudo bench update --patch
master branch is renamed to version-11 and develop to version-12. Please switch to new branches to get future updates.

To switch to version 11, run the following commands: bench switch-to-branch version-11

1 Like

Did you do bench update once?

1 Like

Yes i did a bench update. Can try again

Edit: made no difference still same issue

1 Like

Looks amazing! For cloud hosted when will the updates be seen?

2 Likes

https://discuss.erpnext.com/t/v12-null-module-names-on-desk/50989?u=hereabdulla

1 Like

Congrats Frappe…
I have question, what is the new develop branch name is it version 13 or develop, thx?

1 Like

@nmami It’s version-12

1 Like

For production - v11 master is the still the recommended choice?

1 Like

@zerodiscount yes still it is…also fixes do come for V11 too…

Hi,

Im getting

“Branch version-12 does not exist in Upstream for erpnext”

when I tried bench switch-to-branch version-12

kind regards
Hemant

1 Like

This should help

2 Likes

GitHub was down for a bit. Please try now.

@nmami develop is now version-13

@zerodiscount master will be version-11 and is deprecated. We won’t be using the term anymore. New benches will now be created in version-12

2 Likes

@rmehta - I updated production container briefly to v12 - but it messed up everything - modules were not visible (as identified in another thread), and webstore / website looked entirely different with product images being resized smaller and text not fitting in current box… Seems migration from V11 to V12 may not be seamless. Had to revert back quickly to v11 using a prior snapshot of container. For non-tech users like me, I would urge clarification on whether v12 is meant for cutting-edge development or is production ready?..Should one expect migration to be seamless for customer facing end? Thanks.

Will also appreciate clarification if V11 deprecated means no more updates or fixes?

V11 is not deprecated (master branch is)!

V12 is ready for production use.

1 Like

Hello. The V12 looks sleek and more into business type ERP, altough I still love the iconic ERP Next icon, as long as the functionality is the same, that’s fine… Add some nice dashboard with graphics will makes it nicer… just my two cents…

keep up the great works coming…

4 Likes

@hpema108 and @DrTrills

Follow instructions for git to fetch all branches in the /apps/erpnext directory. then follow instructions above to bench update and bench switch-to-version11 (or 12)…

1 Like

Hi,

I am trying to update to V12, and when I run bench update, I get following error:
File “/home/frappe/frappe-bench/apps/erpnext/erpnext/regional/india/setup.py”, line 483, in make_custom_fields
create_custom_fields(custom_fields, update=update)
File “/home/frappe/frappe-bench/apps/frappe/frappe/custom/doctype/custom_field/custom_field.py”, line 147, in create_custom_fields
custom_field.save()
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/document.py”, line 271, in save
return self._save(*args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/document.py”, line 324, in save
self.run_post_save_methods()
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/document.py”, line 917, in run_post_save_methods
self.run_method(“on_update”)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/document.py”, line 786, in run_method
out = Document.hook(fn)(self, *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/document.py”, line 1055, in composer
return composed(self, method, *args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/document.py”, line 1038, in runner
add_to_return_value(self, fn(self, *args, **kwargs))
File “/home/frappe/frappe-bench/apps/frappe/frappe/model/document.py”, line 780, in
fn = lambda self, *args, **kwargs: getattr(self, method)(*args, **kwargs)
File “/home/frappe/frappe-bench/apps/frappe/frappe/custom/doctype/custom_field/custom_field.py”, line 61, in on_update
validate_fields_for_doctype(self.dt)
File “/home/frappe/frappe-bench/apps/frappe/frappe/core/doctype/doctype/doctype.py”, line 562, in validate_fields_for_doctype
validate_fields(frappe.get_meta(doctype, cached=False))
File “/home/frappe/frappe-bench/apps/frappe/frappe/core/doctype/doctype/doctype.py”, line 823, in validate_fields
check_link_table_options(meta.get(“name”), d)
File “/home/frappe/frappe-bench/apps/frappe/frappe/core/doctype/doctype/doctype.py”, line 607, in check_link_table_options
frappe.throw(
("{0}: Options must be a valid DocType for field {1} in row {2}").format(docname, d.label, d.idx), WrongOptionsDoctypeLinkError)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 360, in throw
msgprint(msg, raise_exception=exc, title=title, indicator=‘red’)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 346, in msgprint
_raise_exception()
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 315, in _raise_exception
raise raise_exception(msg)
frappe.core.doctype.doctype.doctype.WrongOptionsDoctypeLinkError: Item: Options must be a valid DocType for field Manufacturers in row 130

Please help! Thanks.

i am getting following error
bench.app.MajorVersionUpgradeException: Switching to version-12 will cause upgrade from 11 to 12. Pass --upgrade to confirm

I confirm, there is an error getting Version 12 of ERPNEXT. (seemingly there is no Branch Version-12 for ERPNext)
Frappe does successfully switch-to-branch Version-12 but ERPNext does not.

Ref:
image