Redis server Error when bench starts

bench start
19:05:36 system | worker_long.1 started (pid=4642)
19:05:36 system | schedule.1 started (pid=4657)
19:05:36 system | redis_socketio.1 started (pid=4640)
19:05:36 redis_socketio.1 | 4661:M 13 Nov 19:05:36.587 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:05:36 redis_socketio.1 | .
19:05:36 system | redis_queue.1 started (pid=4651)
19:05:36 redis_queue.1 | 4656:M 13 Nov 19:05:36.578 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:05:36 redis_queue.1 | .
19:05:36 redis_queue.1 | .-__ ''-._ 19:05:36 redis_queue.1 | _.- .. ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
19:05:36 redis_queue.1 | .-.-```. ```\/ _.,_ ''-._ 19:05:36 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 19:05:36 redis_queue.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 11000 19:05:36 redis_queue.1 | |-. ._ / _.-' | PID: 4656 19:05:36 redis_queue.1 |-._ -._-./ .-’ .-’
19:05:36 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 19:05:36 redis_queue.1 | |-.
-._ _.-'_.-' | http://redis.io 19:05:36 redis_queue.1 |-._ -._-..-’.-’ .-’
19:05:36 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 19:05:36 redis_queue.1 | |-.
-._ _.-'_.-' | 19:05:36 redis_queue.1 |-._ -._-.
.-’.-’ .-’
19:05:36 redis_queue.1 | -._-..-’ _.-’
19:05:36 redis_queue.1 | -._ _.-' 19:05:36 redis_queue.1 |-.
.-’
19:05:36 redis_queue.1 |
19:05:36 redis_queue.1 | 4656:M 13 Nov 19:05:36.578 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:05:36 redis_queue.1 | 4656:M 13 Nov 19:05:36.578 # Server started, Redis version 3.0.6
19:05:36 redis_queue.1 | 4656:M 13 Nov 19:05:36.578 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
19:05:36 redis_queue.1 | 4656:M 13 Nov 19:05:36.578 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:05:36 redis_queue.1 | 4656:M 13 Nov 19:05:36.578 * The server is now ready to accept connections on port 11000
19:05:36 system | redis_cache.1 started (pid=4654)
19:05:36 redis_cache.1 | 4676:M 13 Nov 19:05:36.588 * Increased maximum number of open files to 10032 (it was originally set to 1024).
19:05:36 redis_cache.1 | .
19:05:36 redis_cache.1 | .-__ ''-._ 19:05:36 redis_cache.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
19:05:36 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 19:05:36 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 19:05:36 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 19:05:36 redis_cache.1 | |-._ ._ / _.-' | PID: 4676 19:05:36 redis_cache.1 |-._ -._-./ .-’ .-’
19:05:36 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 19:05:36 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 19:05:36 redis_cache.1 |-._ -._-..-’.-’ .-’
19:05:36 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 19:05:36 redis_cache.1 | |-.
-._ _.-'_.-' | 19:05:36 redis_cache.1 |-._ -._-.
.-’.-’ .-’
19:05:36 redis_cache.1 | -._-..-’ _.-’
19:05:36 redis_cache.1 | -._ _.-' 19:05:36 redis_cache.1 |-.
.-’
19:05:36 system | watch.1 started (pid=4648)
19:05:36 system | web.1 started (pid=4652)
19:05:36 redis_cache.1 |
19:05:36 redis_cache.1 | 4676:M 13 Nov 19:05:36.588 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:05:36 redis_cache.1 | 4676:M 13 Nov 19:05:36.588 # Server started, Redis version 3.0.6
19:05:36 redis_cache.1 | 4676:M 13 Nov 19:05:36.588 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
19:05:36 redis_cache.1 | 4676:M 13 Nov 19:05:36.588 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:05:36 redis_cache.1 | 4676:M 13 Nov 19:05:36.588 * The server is now ready to accept connections on port 13000
19:05:36 system | socketio.1 started (pid=4650)
19:05:36 system | worker_short.1 started (pid=4653)
19:05:36 redis_socketio.1 | .-__ ''-._ 19:05:36 redis_socketio.1 | _.- .. ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
19:05:36 redis_socketio.1 | .-.-```. ```\/ _.,_ ''-._ 19:05:36 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 19:05:36 redis_socketio.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 12000 19:05:36 redis_socketio.1 | |-._ ._ / _.-' | PID: 4661 19:05:36 redis_socketio.1 |-._ -._-./ .-’ .-’
19:05:36 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 19:05:36 redis_socketio.1 | |-.
-._ _.-'_.-' | http://redis.io 19:05:36 redis_socketio.1 |-._ -._-..-’.-’ .-’
19:05:36 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 19:05:36 redis_socketio.1 | |-.
-._ _.-'_.-' | 19:05:36 redis_socketio.1 |-._ -._-.
.-’_.-’ _.-’
19:05:36 redis_socketio.1 | -._-..-’ _.-’
19:05:36 redis_socketio.1 | -._ _.-' 19:05:36 redis_socketio.1 |-.
.-’
19:05:36 redis_socketio.1 |
19:05:36 redis_socketio.1 | 4661:M 13 Nov 19:05:36.588 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:05:36 redis_socketio.1 | 4661:M 13 Nov 19:05:36.588 # Server started, Redis version 3.0.6
19:05:36 redis_socketio.1 | 4661:M 13 Nov 19:05:36.588 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
19:05:36 redis_socketio.1 | 4661:M 13 Nov 19:05:36.588 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:05:36 redis_socketio.1 | 4661:M 13 Nov 19:05:36.588 * The server is now ready to accept connections on port 12000
19:05:36 system | worker_default.1 started (pid=4664)
19:05:37 socketio.1 | listening on *: 9000
19:05:39 worker_short.1 | 19:05:39 RQ worker u’rq:worker:suraj-ThinkPad-T420.4658.short’ started, version 0.9.1
19:05:39 worker_short.1 | 19:05:39 Cleaning registries for queue: short
19:05:39 worker_short.1 | 19:05:39
19:05:39 worker_short.1 | 19:05:39 *** Listening on short…
19:05:39 worker_default.1 | 19:05:39 RQ worker u’rq:worker:suraj-ThinkPad-T420.4683.default’ started, version 0.9.1
19:05:39 worker_default.1 | 19:05:39 Cleaning registries for queue: default
19:05:39 worker_default.1 | 19:05:39
19:05:39 worker_default.1 | 19:05:39 *** Listening on default…
19:05:39 worker_long.1 | 19:05:39 RQ worker u’rq:worker:suraj-ThinkPad-T420.4646.long’ started, version 0.9.1
19:05:39 worker_long.1 | 19:05:39 Cleaning registries for queue: long
19:05:39 worker_long.1 | 19:05:39
19:05:39 worker_long.1 | 19:05:39 *** Listening on long…
19:05:39 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
19:05:39 web.1 | * Restarting with inotify reloader
19:05:40 watch.1 | compiling avatar.less
19:05:40 watch.1 | compiling calendar.less
19:05:40 watch.1 | compiling common.less
19:05:40 watch.1 | compiling desk.less
19:05:40 watch.1 | compiling desktop.less
19:05:40 watch.1 | compiling docs.less
19:05:40 watch.1 | compiling email.less
19:05:40 watch.1 | compiling form.less
19:05:40 web.1 | * Debugger is active!
19:05:40 web.1 | * Debugger PIN: 120-907-608
19:05:40 watch.1 | compiling form_grid.less
19:05:40 watch.1 | compiling gantt.less
19:05:40 watch.1 | compiling indicator.less
19:05:40 watch.1 | compiling kanban.less
19:05:40 watch.1 | compiling list.less
19:05:40 watch.1 | compiling mixins.less
19:05:40 watch.1 | compiling mobile.less
19:05:40 watch.1 | compiling module.less
19:05:40 watch.1 | compiling navbar.less
19:05:40 watch.1 | compiling page.less
19:05:40 watch.1 | compiling report.less
19:05:40 watch.1 | compiling role_editor.less
19:05:40 watch.1 | compiling sidebar.less
19:05:40 watch.1 | compiling slickgrid.less
19:05:40 watch.1 | compiling tree.less
19:05:40 watch.1 | compiling website.less
19:05:40 watch.1 | compiling email.less
19:05:40 watch.1 | compiling erpnext.less
19:05:40 watch.1 | compiling hub.less
19:05:40 watch.1 | compiling pos.less
19:05:40 watch.1 | compiling website.less
19:05:40 watch.1 | file watching on *: 6787
19:05:41 watch.1 | Less files compiled
19:05:41 watch.1 | Wrote css/frappe-web.css - 65.43 KB
19:05:41 watch.1 | Wrote js/frappe-web.min.js - 133.32 KB
19:05:42 watch.1 | Wrote js/control.min.js - 75.15 KB
19:05:43 watch.1 | Wrote js/dialog.min.js - 119.65 KB
19:05:43 watch.1 | Wrote css/desk.min.css - 311.03 KB
19:05:43 watch.1 | Wrote css/frappe-rtl.css - 32.73 KB
19:05:43 watch.1 | Wrote js/libs.min.js - 1.14 MB
19:05:45 watch.1 | Wrote js/desk.min.js - 466.55 KB
19:05:45 watch.1 | Wrote css/module.min.css - 2.16 KB
19:05:45 watch.1 | Wrote css/form.min.css - 4.55 KB
19:05:46 watch.1 | Wrote js/form.min.js - 198.94 KB
19:05:46 watch.1 | Wrote css/list.min.css - 15.43 KB
19:05:47 watch.1 | Wrote js/list.min.js - 153.18 KB
19:05:47 watch.1 | Wrote css/report.min.css - 8.31 KB
19:05:47 watch.1 | Wrote js/report.min.js - 261.44 KB
19:05:48 watch.1 | Wrote js/web_form.min.js - 247.91 KB
19:05:48 watch.1 | Wrote css/web_form.css - 24.69 KB
19:05:48 watch.1 | Wrote js/print_format_v3.min.js - 23.64 KB
19:05:48 watch.1 | Wrote css/erpnext.css - 8.08 KB
19:05:48 watch.1 | Wrote js/erpnext-web.min.js - 3.89 KB
19:05:48 watch.1 | Wrote js/erpnext.min.js - 139.6 KB
19:05:48 watch.1 | Wrote js/item-dashboard.min.js - 8.18 KB
19:05:50 watch.1 | events.js:160
19:05:50 watch.1 | throw er; // Unhandled ‘error’ event
19:05:50 watch.1 | ^
19:05:50 watch.1 |
19:05:50 watch.1 | Error: watch /home/suraj/frappe-bench/apps/erpnext/erpnext/schools/doctype/student/student.pyc ENOSPC
19:05:50 watch.1 | at exports._errnoException (util.js:1020:11)
19:05:50 watch.1 | at FSWatcher.start (fs.js:1451:19)
19:05:50 watch.1 | at Object.fs.watch (fs.js:1478:11)
19:05:50 watch.1 | at createFsWatchInstance (/home/suraj/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:37:15)
19:05:50 watch.1 | at setFsWatchListener (/home/suraj/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:80:15)
19:05:50 watch.1 | at FSWatcher.NodeFsHandler._watchWithNodeFs (/home/suraj/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:228:14)
19:05:50 watch.1 | at FSWatcher.NodeFsHandler._handleFile (/home/suraj/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:255:21)
19:05:50 watch.1 | at FSWatcher. (/home/suraj/frappe-bench/node_modules/chokidar/lib/nodefs-handler.js:473:21)
19:05:50 watch.1 | at FSReqWrap.oncomplete (fs.js:123:15)
19:05:50 system | watch.1 stopped (rc=0)
19:05:50 system | sending SIGTERM to redis_socketio.1 (pid 4640)
19:05:50 system | sending SIGTERM to worker_long.1 (pid 4642)
19:05:50 system | sending SIGTERM to redis_queue.1 (pid 4651)
19:05:50 system | sending SIGTERM to web.1 (pid 4652)
19:05:50 system | sending SIGTERM to schedule.1 (pid 4657)
19:05:50 system | sending SIGTERM to worker_default.1 (pid 4664)
19:05:50 system | sending SIGTERM to socketio.1 (pid 4650)
19:05:50 system | sending SIGTERM to redis_cache.1 (pid 4654)
19:05:50 system | sending SIGTERM to worker_short.1 (pid 4653)
19:05:50 redis_socketio.1 | 4661:signal-handler (1510580150) Received SIGTERM scheduling shutdown…
19:05:50 worker_long.1 | 19:05:50 Warm shut down requested
19:05:50 redis_cache.1 | 4676:signal-handler (1510580150) Received SIGTERM scheduling shutdown…
19:05:50 worker_default.1 | 19:05:50 Warm shut down requested
19:05:50 system | socketio.1 stopped (rc=-15)
19:05:50 redis_queue.1 | 4656:signal-handler (1510580150) Received SIGTERM scheduling shutdown…
19:05:50 system | schedule.1 stopped (rc=-15)
19:05:50 worker_short.1 | 19:05:50 Warm shut down requested
19:05:50 redis_queue.1 | 4656:M 13 Nov 19:05:50.213 # User requested shutdown…
19:05:50 redis_queue.1 | 4656:M 13 Nov 19:05:50.213 # Redis is now ready to exit, bye bye…
19:05:50 system | redis_queue.1 stopped (rc=-15)
19:05:50 redis_cache.1 | 4676:M 13 Nov 19:05:50.218 # User requested shutdown…
19:05:50 redis_cache.1 | 4676:M 13 Nov 19:05:50.218 # Redis is now ready to exit, bye bye…
19:05:50 system | redis_cache.1 stopped (rc=-15)
19:05:50 redis_socketio.1 | 4661:M 13 Nov 19:05:50.223 # User requested shutdown…
19:05:50 redis_socketio.1 | 4661:M 13 Nov 19:05:50.223 # Redis is now ready to exit, bye bye…
19:05:50 system | redis_socketio.1 stopped (rc=-15)
19:05:50 system | worker_default.1 stopped (rc=-15)
19:05:50 web.1 | Exception in thread Thread-2 (most likely raised during interpreter shutdown):
19:05:50 web.1 | Traceback (most recent call last):
19:05:50 web.1 | File “/usr/lib/python2.7/threading.py”, line 801, in __bootstrap_inner
19:05:50 web.1 | File “/home/suraj/frappe-bench/env/local/lib/python2.7/site-packages/watchdog/observers/api.py”, line 237, in run
19:05:50 web.1 | <type ‘exceptions.AttributeError’>: ‘NoneType’ object has no attribute ‘Empty’
19:05:50 system | web.1 stopped (rc=-15)
19:05:50 system | worker_short.1 stopped (rc=-15)
19:05:50 system | worker_long.1 stopped (rc=-15)

Your log shows this…

alternatively…