Redis error when starting the bench

Hello,
I successfully installed Frappe on a DigitalOcean Droplet (running Ubuntu 14.04) using the commands:
wget https://raw.githubusercontent.com/frappe/bench/master/install_scripts/setup_frappe.sh
sudo bash setup_frappe.sh

But when I try to start the bench I have the following error message. And I’m unable to access frappe on the port 8000 (0.0.0.0:8000). I guess the problem comes from the redis error message. What should I do to fix that?
Thx in advance!

Command: $ bench start
Message:
10:56:45 system | worker.1 started (pid=2181)
10:56:45 system | redis_cache.1 started (pid=2179)
10:56:45 redis_cache.1 | [2185] 03 Jun 10:56:45.747 # Unable to set the max number of files limit to 10032 (Operation not permitted), setting the max clients configuration to 3984.
10:56:45 redis_cache.1 | .
10:56:45 redis_cache.1 | .-__ ''-._ 10:56:45 redis_cache.1 | _.- .. ‘’-._ Redis 2.8.4 (00000000/0) 64 bit
10:56:45 redis_cache.1 | .-.-```. ```\/ _.,_ ''-._ 10:56:45 redis_cache.1 | ( ' , .-` | `, ) Running in stand alone mode 10:56:45 redis_cache.1 | |`-._`-...-` __...-.-.|’_.-'| Port: 11311 10:56:45 redis_cache.1 | |-. ._ / _.-' | PID: 2185 10:56:45 redis_cache.1 |-._ -._-./ .-’ .-’
10:56:45 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 10:56:45 redis_cache.1 | |-.
-._ _.-'_.-' | http://redis.io 10:56:45 redis_cache.1 |-._ -._-..-’.-’ .-’
10:56:45 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 10:56:45 redis_cache.1 | |-.
-._ _.-'_.-' | 10:56:45 redis_cache.1 |-._ -._-.
.-’_.-’ _.-’
10:56:45 redis_cache.1 | -._-..-’ _.-’
10:56:45 redis_cache.1 | -._ _.-' 10:56:45 redis_cache.1 |-.
.-’
10:56:45 redis_cache.1 |
10:56:45 redis_cache.1 | [2185] 03 Jun 10:56:45.748 # Server started, Redis version 2.8.4
10:56:45 redis_cache.1 | [2185] 03 Jun 10:56:45.748 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
10:56:45 redis_cache.1 | [2185] 03 Jun 10:56:45.748 * The server is now ready to accept connections on port 11311
10:56:45 system | workerbeat.1 started (pid=2182)
10:56:45 system | web.1 started (pid=2180)
10:56:46 workerbeat.1 | celery beat v3.1.18 (Cipater) is starting.
10:56:46 workerbeat.1 | __ - … __ - _
10:56:46 workerbeat.1 | Configuration ->
10:56:46 workerbeat.1 | . broker -> redis://localhost:6379//
10:56:46 workerbeat.1 | . loader -> celery.loaders.app.AppLoader
10:56:46 workerbeat.1 | . scheduler -> celery.beat.PersistentScheduler
10:56:46 workerbeat.1 | . db -> scheduler.schedule
10:56:46 workerbeat.1 | . logfile -> [stderr]@%INFO
10:56:46 workerbeat.1 | . maxinterval -> now (0s)
10:56:46 workerbeat.1 | [2015-06-03 10:56:46,588: INFO/MainProcess] beat: Starting…
10:56:46 worker.1 |
10:56:46 worker.1 | — — — — — — — celery@SandPlay v3.1.18 (Cipater)
10:56:46 worker.1 | — — **** — — -
10:56:46 worker.1 | — - * *** * — Linux-3.13.0-52-generic-x86_64-with-Ubuntu-14.04-trusty
10:56:46 worker.1 | — * - **** — -
10:56:46 worker.1 | - ** — — — — — [config]
10:56:46 worker.1 | - ** — — — — — .> app: frappe:0x7f6809900e50
10:56:46 worker.1 | - ** — — — — — .> transport: redis://localhost:6379//
10:56:46 worker.1 | - ** — — — — — .> results: disabled
10:56:46 worker.1 | - *** — - * — - .> concurrency: 1 (prefork)
10:56:46 worker.1 | — ******* — —
10:56:46 worker.1 | — - ***** — — - [queues]
10:56:46 worker.1 | — — — — — — — .> celery exchange=celery(direct) key=celery
10:56:46 worker.1 |
10:56:46 worker.1 |
10:56:47 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
10:56:47 web.1 | * Restarting with stat
10:56:47 worker.1 | [2015-06-03 10:56:47,768: WARNING/MainProcess] celery@SandPlay ready.
10:57:31 workerbeat.1 | [2015-06-03 10:57:31,706: INFO/MainProcess] Scheduler: Sending due task scheduler (frappe.tasks.enqueue_scheduler_events)
11:00:00 workerbeat.1 | [2015-06-03 11:00:00,064: INFO/MainProcess] Scheduler: Sending due task celery.backend_cleanup (celery.backend_cleanup)

lleleu
have you tried

bench update

Yes I did, but it is no use :pensive (bench already up to date)…

Same problem here (Waiting for answear too)

Hello everyone,
I tried to install everything again from a clean instance. But I sill have the same issue. Is my server’s memory too small (512 MB / 1 CPU, 20 GB SSD, 1000 GB Transfer)?
Or shall I configure Redis manually?
Thx in advance for your help!!

Redis is not the problem. After running bench start, what is the output of curl -I http://localhost:8000 from another term

Hi pdvyas,
I ran bench start. Then in another term curl -I http://localhost:8000. Here is the ouput:
laurent@SandPlay:~$ curl -I http://localhost:8000
HTTP/1.0 200 OK
Content-Type: text/html; charset: utf-8
Content-Length: 12562
X-Page-Name: login
X-From-Cache: False
Set-Cookie: sid=Guest; Expires=Mon, 08-Jun-2015 13:43:00 GMT; Path=/
Server: Werkzeug/0.10.4 Python/2.7.6
Date: Fri, 05 Jun 2015 06:43:00 GMT

That means all is good!

But chrome returns: This page is not available for http://localhost:8000… I don’t understand.

again! same thing happen to me lleleu

May be you’re stopping bench start before trying

I don’t think so (I’m sure in fact) I tried a lot of times and I crul(ed) the localhost while trying to connect from my browser. Curl is Ok but the connection to localhost:8000 always fails (This page is not available).

So I tried nslookup localhost:8080, it returns:

~$ nslookup localhost:8080
Server: XXXXX
Address: XXXXXX

** server can’t find localhost:8080: NXDOMAIN

Perhaps I have a problem with the DNS of my server?

is there any solution ??

nothing ??

No:( no solution. I tried to install the bench on a brand new instance. I’ve got he same result, when I
curl -I http://localhost:8000
get this answer:
HTTP/1.0 200 OK
Content-Type: text/html; charset: utf-8
Content-Length: 12562
X-Page-Name: login
X-From-Cache: False
Set-Cookie: sid=Guest; Expires=Thu, 11-Jun-2015 11:06:32 GMT; Path=/
Server: Werkzeug/0.10.4 Python/2.7.6
Date: Mon, 08 Jun 2015 04:06:33 GMT

So apparently everything is good. But the connection to localhost:8000 always fails.

Anyone has an idea how to fix that?

In fact I think this is a pure connection issue. This ticket should be closed. I’ll open a new one for the connection to localhost:8000 issue.

Hi abszar,
I made it work, see my post:
https://discuss.frappe.io/t/accessing-frappe-bench-from-web-browser/6200

Don’t hesitate to ask for details