Redis cache server not running. Please contact Administrator / Techsupport error

Getting captioned error.

Supervisor status log is:

$ sudo supervisorctl status
[sudo] password for nescode: 
frappe:frappe-web                RUNNING    pid 7169, uptime 20:56:16
frappe:frappe-worker             RUNNING    pid 7168, uptime 20:56:16
frappe:frappe-workerbeat         RUNNING    pid 7178, uptime 20:56:15
node-socketio                    RUNNING    pid 6945, uptime 20:56:51
redis-async-broker               RUNNING    pid 6946, uptime 20:56:51
redis-cache                      FATAL      Exited too quickly (process log may have details)

When I comment out the line "save “” " in redis_cache.conf error goes but then bench update gives error. I tried this https://github.com/frappe/bench/wiki/Regenerate-Production-Config-Files-(ERPNext) but no luck.

OS is debian.

@sunilsrikumar take a look in the error logs in the frappe-bench/logs dir

Hi @max_morais_dmm error log says redis cache error is due to ‘save “”’ whereas redis_cache.conf has - save"" .

redis-cache.error.log:

*** FATAL CONFIG FILE ERROR ***
Reading the configuration file, at line 6
>>> 'save ""'
Bad directive or wrong number of arguments

*** FATAL CONFIG FILE ERROR ***
Reading the configuration file, at line 6
>>> 'save ""'
Bad directive or wrong number of arguments

*** FATAL CONFIG FILE ERROR ***
Reading the configuration file, at line 6
>>> 'save ""'
Bad directive or wrong number of arguments

*** FATAL CONFIG FILE ERROR ***
Reading the configuration file, at line 6
>>> 'save ""'
Bad directive or wrong number of arguments

*** FATAL CONFIG FILE ERROR ***
Reading the configuration file, at line 6

redis_cache.conf details:

dbfilename redis_cache_dump.rdb
pidfile redis_cache.pid
port 11311
maxmemory 50mb
maxmemory-policy allkeys-lru
save""
appendonly no

@sunilsrikumar run bench setup redis and try start again

1 Like

bench setup redis-cache followed by supervisorctl reload not solving the issue. Any idea?

Hello

Change save ‘’ to save 300 10

Details:

SNAPSHOTTING

· Save the DB on disk:
· save ‘seconds’ ‘changes’
· Will save the DB if both the given number of seconds and the given
· number of write operations against the DB occurred.
· In the example below the behaviour will be to save:
· after 900 sec (15 min) if at least 1 key changed
· after 300 sec (5 min) if at least 10 keys changed
· after 60 sec if at least 10000 keys changed

· Note: you can disable saving at all commenting all the “save” lines.

save 900 1
save 300 10
save 60 10000

2 Likes

@wroc77 Thank you so much. Redis cache server popup issue resolved.

Sunil

1 Like