Random sales invoices are in a "to be delivered mode" and does do not record stock movement

I use Xmas break to do my yearly accounts…and found an issue (or bug)…It took me considerable time to point down where the issue is.
A graph of item quantities showed a strong increase of slope starting september 2016… Items in stock were stongly increasing…Well, exporting doscs to excel, comparing, checking etc i could not find where the issue was…Told my wife that probably quite a number of sales were not entered…
Finally identified the issue…
A number of my invoices show under “Make” delivery and under view only the accounts ledger, not the stock. Seemingly at random selection of invoices are first to be delivered…in order to update stock…

Some background:
I use the cloud version and have not updated setup/settings since several years…things work fine…
We have seriously started to use the new POS somewhere in August… We use it from 3 to 4 different computers…I have only one POS profile defined…And the setting is “update stock”. Also sales invoice (the traditional one) is default set to “IS POS”… Also checked the customize sales invoice setting…Update stock has no default…(but that has thus always been like that)

Tried to filter the invoices affected using the fields delivered by supplier and delivered Qty…these fields are empty>>> So i am not capable to filter the invoices that have this “special setting” …and see whther it is for example related to a specific user…LATER EDIT…The affected records, some 10 % the total, can be filtered by update stock… No pattern …All users have these sales without stock movement…The issue has persisted very long…also during 2015…but not so many so I did not notice (we do not keep inventory and consume a lot private of the stiff we sell :slight_smile: ) Tried to change the Update stock status…is not allowed on cancelled field…

Am stuck…Hope it can be easily resolved…

ALSO under github>>> https://github.com/frappe/erpnext/issues/7393

Replied via support