Quantity of Zero

Hi,

in version 10 and before it was possible to have quantities of 0 in quotations for example. This is not possible in version 11 anymore. Is there a possibility to change this behaviour in settings?

When I try to save with quotation items that have a quantity of 0 I get the following error now: “Item quantity can not be zero”

Often I would use quantity of 0 to show optional items on a quotation, so that their price is not reflected in the total amount. This is very important for me.

Thanks for your help,
Andy

2 Likes

Are you able to apply 100% discount to the optional items?

That should zero out the prices on those items. At least this may be a work-around until a better solution can be developed.

BKM

2 Likes

No, this doesn’t work. My clients would get the impression that I give them these positions for free. It’s important that the quantity is actually set to zero!

Does anyone of the developer-team has anything to say about this? Is it intentional or a bug? If it’s intentional, is there a possibility to change it back to how it was before?

To get the behavior changed, your best bet would be to file an issue on github, explaining the use case.

In the meantime, it looks like it’s just a three line check in the accounts controller. If you were to comment them out, it’d prevent the error.

2 Likes

I did this. Works now like before. I think preferable would be a checkbox in the account settings, where I could choose to allow or disallow zero quantities.

I think for many companies it is a common procedure to put optional items onto a quotation just to indicate it’s price, but doesn’t want it’s price to be reflected in the grand total. Basically to not blow up the grand total and scare a potential buyer.

+1 I really need this… will submit a PR

(added) https://github.com/frappe/erpnext/issues/17400