Python Translations on ERPNext

Hello Rusabh,

i have a question regarding the translations of the python code on erpnext.

please see the attached documents 1.png and 2.png

1.png shows the "no record found" message.
2.png shows the place from where the message is coming.

but it is making proper call to the _("no record found") and my current set language is Arabic, so i wanted to know .. why the equivalent arabic is not being displayed, everytime it is returning english ??

please let me know , if i can do anything to update the script

and here is the code that i have written for the getPage():

http://pastebin.com/C2qzBLXk


thanks



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.
Syed, I had already noticed this, I am looking into code wnframework to fix this, but do not worry, I think it is a simple matter.


2013/10/28 Syed Qadeer <sd...@gmail.com>
Hello Rusabh,

i have a question regarding the translations of the python code on erpnext.

please see the attached documents 1.png and 2.png

1.png shows the "no record found" message.
2.png shows the place from where the message is coming.

but it is making proper call to the _("no record found") and my current set language is Arabic, so i wanted to know .. why the equivalent arabic is not being displayed, everytime it is returning english ??

please let me know , if i can do anything to update the script

and here is the code that i have written for the getPage():

http://pastebin.com/C2qzBLXk



thanks



Note:



If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.



    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




--

Maxwell Morais
Tecnologia da Informação
+55 11 3931-1412 Ramal 31

www.realizemodulados.com.br



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.
Please come on the skype, want to talk to u.

On Monday, 28 October 2013 16:16:32 UTC+3, Maxwell wrote:
Syed, I had already noticed this, I am looking into code wnframework to fix this, but do not worry, I think it is a simple matter.


2013/10/28 Syed Qadeer <sd...@gmail.com>
Hello Rusabh,

i have a question regarding the translations of the python code on erpnext.

please see the attached documents 1.png and 2.png

1.png shows the "no record found" message.
2.png shows the place from where the message is coming.

but it is making proper call to the _("no record found") and my current set language is Arabic, so i wanted to know .. why the equivalent arabic is not being displayed, everytime it is returning english ??

please let me know , if i can do anything to update the script

and here is the code that i have written for the getPage():

http://pastebin.com/C2qzBLXk



thanks



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.




--

Maxwell Morais
Tecnologia da Informação
+55 11 3931-1412 Ramal 31

 www.realizemodulados.com.br



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups “ERPNext Developer Forum” group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.