Push-biometric-erpnext

it’s Hikvision and i don’t think it has SDK

In that case you need to check the firmware. If you have purchased the machine from authorised seller you will probably have the firmware from Hikvision. Sometimes, resells change the firmware that best suits the software it is being sold with.

Hikvision state on their website that if a products is purchased online or from an unauthorised distributor it is likely to be a “gray market” product. source https://us.hikvision.com/en/support-resources/downloads/sdk

my interpretation could be wrong.

But it is important to have the machine with firmware which has an API / SKD

if someone disagrees with me please correct me if I am wrong.

thanks.

frappe@ubuntu:~/frappe-bench/push-biometric-erpnext$ sudo python3 push_to_erpnext.py
File “push_to_erpnext.py”, line 52
status.set(f’{device[“device_id”]}_push_timestamp’, str(datetime.datetime.now()))
^
SyntaxError: invalid syntax

hi every one i get this error while try to run script python3 push_to_erpnext.py
current used erpnext v12

here ouput while running python3 -m venv venv && source venv/bin/activate && pip install -r requirements.txt

frappe@ubuntu:~/frappe-bench/push-biometric-erpnext$ cd /home/frappe/frappe-bench/push-biometric-erpnext && python3 -m venv venv && source venv/bin/activate && pip install -r requirements.txt
Requirement already satisfied: requests in ./venv/lib/python3.5/site-packages (from -r requirements.txt (line 1)) (2.23.0)
Requirement already satisfied: pickledb in ./venv/lib/python3.5/site-packages (from -r requirements.txt (line 2)) (0.9.2)
Requirement already satisfied: pyzk in ./venv/lib/python3.5/site-packages/pyzk-0.9-py3.5.egg (from -r requirements.txt (line 3)) (0.9)
Requirement already satisfied: idna<3,>=2.5 in ./venv/lib/python3.5/site-packages (from requests->-r requirements.txt (line 1)) (2.9)
Requirement already satisfied: chardet<4,>=3.0.2 in ./venv/lib/python3.5/site-packages (from requests->-r requirements.txt (line 1)) (3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in ./venv/lib/python3.5/site-packages (from requests->-r requirements.txt (line 1)) (2019.11.28)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in ./venv/lib/python3.5/site-packages (from requests->-r requirements.txt (line 1)) (1.25.8)
Requirement already satisfied: future in ./venv/lib/python3.5/site-packages (from pyzk->-r requirements.txt (line 3)) (0.18.2)

thank you.

1 Like

Hey I am working on same will u help me how to do with SDK

do you have the SDK?

When we click on Set configuration. Windows App

Push Direction in Blank

We need to manually fed into local_config

I have Error code
ee