Purchase Order Item is not showing the UOM

Hello,

The Purchase Order Item is not showing the UOM.

I have a different UOM for the stock item (Meter), and a different UOM for the purchase item (custom UOM Roll, where 1 Roll = 100 Meter). My Purchase Order Item does not show the correct UOM, and the Purchase is done in the stock UOM.

I tried customizing the Purchase Order Form or Purchase Order Item Table to show the UOM field, but this does not do anything. On the Master branch.

Any ideas?

You’ll need to set it up in the Item. Go to the Units of Measure section in that Item:

Add new row, and add Roll and its conversion factor into meter. According to your post then that conversion value will be 100 units of Stock UOM which means 100 meters.

Test this out with a dummy purchase order. For this item in question, expand its row where you can see all details change the UOM (Not Stock UOM) to Roll and it should be done.

This can be verified by looking at the Qty as per Stock UOM which should be just at the end of the dialog box.

1 Like

I’ve done that… with the Stock UOM as meters, and the Purchase UOM as Roll with the conversion factor 100… but it doesn’t work.

Can you share gif/screenshots of what exactly is happening here? It’ll give us a little more context :smiley:

1 Like

Running ERPNext: v10.1.58 (master), Frappe Framework: v11.0.3-beta.9 () (staging)

UOM for the item (please note that the item is a variant, and the master item template has the same UOM):

Second picture shows the UOM for the purchase item:

In the Purchase Order, I can see the Stock UOM, but not the Purchase UOM:

Screenshot%20(3)

I see that I can edit the UOM if I open the item individually, but shouldn’t this be possible directly withing the Purchase Order Item List table?

Also, can I reverse a submitted and received Purchase Order

Thanks, Abid

If you exapnd this row, can you see Roll mentioned in any of the fields ?

The UOM is there but the issue is you are not able to see it in the grid i.e. the view as shown in the picture.

We can replace Stock UOM by the Purchase UOM via this simple Customize Form task.

  1. Go to Customize Form and select Purchase Order Item
  2. Uncheck In Grid View check in field Stock UOM
  3. Check In Grid View to a yes for UOM.

Also it is recommended that your Frappe and ERPnext branches should be on the same branch i.e. master.

Running ERPNext: v10.1.58 (master), Frappe Framework: v11.0.3-beta.9 () (staging)

1 Like

Yes, can see the Roll in the other fields… but shouldn’t the Purchase UOM be the default in the Purchase Order?

Have customized the Purchase Order Item as per your instructions. Thank you, this is resolved now.

Will this customize stay after running updates?

I don’t know why the Frappe Framework is on a different branch. How do I change this to master, or better still to the 11.0 pre-release?

How could we achieve that in the webshop? here also only the first UOM is shown. See also https://github.com/frappe/erpnext/issues/15655

To jump to v11, follow the instructions given here:

This customization should be unaffected.

1 Like

For this check this link. Custom Apps and fixtures will help you for preserving your changes and to recreate them every time you wish to re-install your system.