Try ERPNext Buy Support Partners Foundation

Production server redis not working

My production server is running though it’s slow in performance.

I’m getting following message against sudo supervisorctl status command

frappe                                                    STARTING  
frappe-bench-redis:frappe-bench-redis-cache               FATAL     Exited too quickly (process log may have details)
frappe-bench-redis:frappe-bench-redis-queue               FATAL     Exited too quickly (process log may have details)
frappe-bench-redis:frappe-bench-redis-socketio            FATAL     Exited too quickly (process log may have details)
frappe-bench-web:frappe-bench-frappe-web                  STARTING  
frappe-bench-web:frappe-bench-node-socketio               FATAL     Exited too quickly (process log may have details)
frappe-bench-workers:frappe-bench-frappe-async-worker     RUNNING   pid 16351, uptime 0:41:55
frappe-bench-workers:frappe-bench-frappe-longjob-worker   RUNNING   pid 16352, uptime 0:41:55
frappe-bench-workers:frappe-bench-frappe-worker           RUNNING   pid 16357, uptime 0:41:55
frappe-bench-workers:frappe-bench-frappe-workerbeat       FATAL     Exited too quickly (process log may have details)

How i can overcome this issue?

Check the server logs/ to help you identify the problem?

If you are getting fatal errors on redis, and the server is unusually slow, you probably have insufficient RAM available to the processes, and the server is swapping to disk, which is slow

can you share the server logs ?

Now everything running.