Problem with custom attribute in Customer Doctype: Customer with blank page (after reload page in browser)

Hi there team and community,

I’m working in my first ERP implementation, and I have this problem:

  • I’m in development mode
    - I have created a new attribute in the Customer Doctype, also checked “personalized”.
    - My new attribute is a numeric one, so I used “Int” and named it “numerocliente”.

The problem is:

After that I can create new customers, and import them with this new attribute (I already have imported 4.000 customer) and I can see them. But when I open one of the customers I see a blank page and I can’t see the information of the customer.

Note: Important to say that the first time I open the customer I can see everything. But then I can not see it’s information anymore. Is the same when I create a new one. So the problem appears when you reload the page in the browser.

I have checked the problem with 3 or 4 snapshots of my virtual machine, so the problem is not in the configuration, it seems a problem related to the change I did to the Customer Doctype.


I have the same problem with other attributes, for instance, I have added an attribute in Leads, and I have the same problem, the first time I create one I can see it’s data, but after I reload page in the browser I can’ see anymore the information.

Is it needed any configuration after creating a new attribute in any table / Doctype?
Am I missing sth?

Thanks,

Rubén.

I Add some extra information:

Sometimes happens to me that “I see the data and after one second it dissapears”.

I have tried to change the Doctypes and delete the custom attributes I added, but the problem persists… I deleted them and uncheched the “personalized”.

I algo tried to move to Production mode, but I have the same problem.

On the other hand, I have no problem with other parts of the ERP, my problems appear in the Doctypes that I have customized.

Kind Regards,

Rubén

@rtimagine what do you see in your JS console?

Hi @rmehta,

More info: I have tested in another virtual machine, created from your demo virtualbox image (but with the ubuntu-gnome-desktop installed). And I have exactly the same problem. For instance, if I:

1- I put the erpnext in dev mode
2- I go to doctypes. Select Lead.
3- I add a new attribute, for instance a Select with 3 values. Then click “Personalized” then save.
4- I go to Leads. New lead, put a name, save. Then click and everything Ok. Then Refresh the bowser and I have the “blank page” where I can only see the titles, no info there.

This is what I see in Chrome dev tools:

desk:5 Uncaught ReferenceError: addr_list is not defined
desk.min.js:7342 Warning: Single quotes (’) may not work in templates
VM229:5 Uncaught ReferenceError: addr_list is not defined

This is what I see in the Firefox dev console:

The connection to ws://localhost/socket.io/?EIO=3&transport=websocket&sid=OPXSf3xRN6__3-9fAAAA was interrupted while the page was loading. desk.min.js:5490:15
unreachable code after return statement desk.min.js:70:12432
unreachable code after return statement desk.min.js:8005:187
HTTP “Content-Type” of “audio/mpeg” is not supported. Load of media resource http://localhost/assets/frappe/sounds/email.mp3 failed. desk
All candidate resources failed to load. Media load paused. desk
HTTP “Content-Type” of “audio/mpeg” is not supported. Load of media resource http://localhost/assets/frappe/sounds/submit.mp3 failed. desk
All candidate resources failed to load. Media load paused. desk
HTTP “Content-Type” of “audio/mpeg” is not supported. Load of media resource http://localhost/assets/frappe/sounds/cancel.mp3 failed. desk
All candidate resources failed to load. Media load paused. desk
HTTP “Content-Type” of “audio/mpeg” is not supported. Load of media resource http://localhost/assets/frappe/sounds/delete.mp3 failed. desk
All candidate resources failed to load. Media load paused. desk
HTTP “Content-Type” of “audio/mpeg” is not supported. Load of media resource http://localhost/assets/frappe/sounds/click.mp3 failed. desk
All candidate resources failed to load. Media load paused. desk
HTTP “Content-Type” of “audio/mpeg” is not supported. Load of media resource http://localhost/assets/frappe/sounds/error.mp3 failed. desk
All candidate resources failed to load. Media load paused. desk
unreachable code after return statement desk.min.js:70:12432
ReferenceError: addr_list is not defined

Thanks in advance,

Rubén.

I forgot the to share the js error details:

VM569:5 Uncaught ReferenceError:
addr_list is not defined

(anonymous function) @ VM569:5
frappe.render @ desk.min.js:7346
frappe.render_template @ desk.min.js:7347
$.extend.render_address_and_contact @ erpnext.min.js:9
erpnext.LeadController.frappe.ui.form.Controller.extend.refresh @ VM561:41
(anonymous function) @ form.min.js:212
(anonymous function) @ form.min.js:211
n.extend.map @ jquery.min.js:2
frappe.ui.form.ScriptManager.Class.extend.trigger @ form.min.js:211
_f.Frm.render_form @ form.min.js:55
(anonymous function) @ form.min.js:64
(anonymous function) @ form.min.js:211n.extend.map @ jquery.min.js:2frappe.ui.form.ScriptManager.Class.extend.trigger @ form.min.js:211_f.Frm.setnewdoc @ form.min.js:64_f.Frm.refresh @ form.min.js:48frappe.views.FormFactory.frappe.views.Factory.extend.load @ form.min.js:6(anonymous function) @ form.min.js:6frappe.call.callback @ desk.min.js:7665callback @ desk.min.js:7277statusCode.200 @ desk.min.js:7279(anonymous function) @ desk.min.js:7285j @ jquery.min.js:2k.fireWith @ jquery.min.js:2x @ jquery.min.js:4(anonymous function) @ jquery.min.js:4

Hi team,

Is there any guide to add your own attributes a Standard Doctype? I would like to know if I’m missing something.

Kind regards,

Rubén

Hi there, I would like to share some thought:

When I was new to erpnext it was confusing to me how to add fields to existing documents.

The problem is: if you read in the forum “use custom fields” it can fool you to think that you may have to edit DocTypes and use “your own custom fields”, instead of looking to the Custom Fields Option Menu in Configuration.

I think this is a stupid thing that can be very confusing.

It would be great for new users if is more clear that you may not change original Doctypes and you may use Custom Fields / scripts in the Configuration menu.

It’s just suggestion, I think ERPNext is a great project and it’s not really difficult, but sometimes it’s not clear the way you have to implement it. Anyway, great work team!

Regards,

Rubén.