Problem print to pdf

i had problem to print to pdf all picture not load. please help

but if i load it at the same local network with server its fine

here my site_config.json

   {
 "db_name": "name",
 "db_password": "pass",
 "dropbox_access_key": "access",
 "dropbox_secret_key": "key",
 "encryption_key": "encript key",
 "host_name": "https://domain-site.com",
 "limits": {
  "space_usage": {
   "backup_size": 28.0,
   "database_size": 55.43,
   "files_size": 36.0,
   "total": 119.43
  }
 },
 "ssl_certificate": "/etc/letsencrypt/live/domain-site.com/fullchain.pem",
 "ssl_certificate_key": "/etc/letsencrypt/live/domain-site.com/privkey.pem"

@Mohd_Rizal_sharif

`Try,to set

“developer_mode”: 1,`

why should i change to developer mode… ? are these effects to pdf print?

Solve now, i found out problem cause by server host name. then i change host name and domain name then ok now , pdf now load picture. here link were i follow to modify UBUNTU hostname

https://www.digitalocean.com/community/questions/how-to-set-fqdn-in-ubuntu

Faced a similar problem. Was server host name the only problem you faced? Did you make any other changes?

For Debian Stretch users and others with the QSslSocket: cannot resolve $func issue, you just need to install the package libssl1.0-dev (or similar package in your distro).

1 Like

yes i think so. i use

ubuntu 16.04. with zfs
ERPNext: v8.11.4 (master)
Frappe Framework: v8.10.8 (master)
wkhtmltopdf 0.12.3 (with patched qt)

1.first you have to upload file not in private. as i show in the image. please ensure that you tick Public


2. check your host name server is set as your domain.
https://www.digitalocean.com/community/questions/how-to-set-fqdn-in-ubuntu
3. set your site_config.json

sudo nano /home/frappe/frappe-bench/sites/domain-site.com/site_config.json

then put

“host_name”: “https://domain-site.com”,

1 Like