Try ERPNext Buy Support Partners Foundation

Print Format not showing columns within sections

Hi! So I have a print format that (I cannot post here because new users can only post a single image) but goes like this:
HEADER
Section
Column 1: Column 2:
Tax ID Date
Address
Name
Mobile No.

Section
Table with prices (which actually works well)

Section
Column 1: Column 2:
Total in Words Net total
Discounted total

As you can see, I have a couple sections where I have items on two columns. This is done so that I can fit my entire invoice on a single page (because of national restrictions, but nevermind that.)

The problem, however, is that it prints like this:

Which, among other things, is not separated in columns. Moreover, it’s all aligned to the right. I have checked that I am printing on the correct format, and have tried deleting by cache and all that jazz, but to no avail.

This is the print format in question:

It may help to say what version of ERPNext and the hosting environment.

See if this has anything that can help: https://discuss.erpnext.com/t/pdf-print-is-broken-and-letterhead-in-pdf-not-appearing/53132

Some of the links I posted there aren’t working for me now.

My bad! I’m running:

ERPNext: v12.9.3 (version-12)

Frappe Framework: v12.6.1 (version-12)

On an EC2 Ubuntu instance (20.something)

I did check the links, and went down the hostname rabbit-hole but no luck.

Very similar to the problem I described here

bench restart after changing the hostname to the ip address in site_config.json did not fix it?

What does wkhtmltopdf -V return?

Hi! Yeah, I had to add the hostname because the site_config.json did not have anything there originally. After that bench restart changed nothing. I did add it however as http:… and not IP. I’ll try to change it to the IP address in a while.

As for wkhtmltopdf -V it returns wkhtmltopdf 0.12.5 (with patched qt)

Setting it to the IP did the trick!

Thanks so much! I guess I didn’t properlly read the previous posts 'cause a guy described the same situation (not working with host_name: http://website.com) and the solution was setting the variable to the static IP address.

Thank you all!