Try ERPNext Buy Support Partners Foundation

print(f"Message: {repr(out.message).encode('utf-8')}")

GETTING BELOW ERROR ON FRESH UPGARDE OF VERSION 13- BETA

Installing node dependencies for frappe
$ yarn install
yarn install v1.22.10
[1/4] Resolving packages…
success Already up-to-date.
$ yarn run snyk-protect
yarn run v1.22.10
$ snyk protect
Successfully applied Snyk patches
Done in 23.03s.
Done in 24.12s.
Traceback (most recent call last):
File “/usr/lib/python3.5/runpy.py”, line 174, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File “/usr/lib/python3.5/runpy.py”, line 109, in _get_module_details
import(pkg_name)
File “/home/frappe/frappe-bench/apps/frappe/frappe/init.py”, line 357
print(f"Message: {repr(out.message).encode(‘utf-8’)}")
^
SyntaxError: invalid syntax

Use python 3.6+ to use f-strings f"Message: {repr(out.message).encode(‘utf-8’)}")

2 Likes