POS Receipt does not show Taxes (VAT)

So I got the POS System to work, along with all payment types, products, stock, etc. Now I am updating the Receipt Printing and configuring the design to fit my needs:

	{%- for row in doc.taxes -%}
		<tr>
			<td class="text-right" style="width: 70%">
				{{ row.description}}
			</td>
			<td class="text-right">
				{{ row.get_formatted("tax_amount", doc) }}
			</td>
		<tr>
	{%- endfor -%}

In the Items table I have added Tax (VAT) to the Item. But in the Invoice it doesn’t print. Where exactly in settings or elsewhere I need to go to configure and show the VAT.

It seems it should be the same as Sales Taxes in any other environment. So to sales taxes (you can call it VAT) you need to create a Sales Tax Template and a Tax Rule and then apply the template to the POS profile in the Accounting section. Just select your new tax template in the “Taxes and Charges” field in the profile and save it.

After that the taxes are automatically included in the standard printed invoices and you can modify one of them to get your favorite layout.

Hope this helps.

BKM

thanks @bkm, but I had done that, and just to be sure I went through all the parts that you said and I had it configured correctly. Yet I am unable to get the tax info to print on the receipt.

Just wanted to make sure it’s clear, that I am using POS Receipt. It uses Jinja Syntax, instead of the standard ERP Next GUI for Document Editing.

Is there anything else I am doing wrong?

I don’t “believe” you are doing anything wrong, but to be sure why dont you go to the Print Format List and select the one called “POS Invoice”

It is a standard print format and that makes it uneditable. (In my system it comes up as Disabled - V10)

Once you have it up, verify that is it Print Format Type = Server

Then Click “Menu” and select “Duplicate” and save the new duplicate with a new name and be sure it is not disabled before saving.

Then test this format to see if the taxes show up when you call up a sales invoice and try to print it. (Also verify the Sales Invoice you selected actually has the taxes applied in the Taxes and Charges section)

If this format prints the taxes, then you can modify it to suit your needs as long as you do not disturb the taxes section of the code.

I use this method to make my print formats because the standard ones (even if they are disabled) still work when saved under a new name and all of them have working taxes when printed.

Hope this helps.

BKM

Thanks @bkm for the interest, and as you said check if the sales invoices has taxes. This is what I was doubting too.

I checked it and indeed it’s there, while the rate is 10 and everything seems fine, the “Amount” field is 0. Does this mean the Tax Amount or Taxable Amount. In either case 0 doesn’t sound right.

Also I have configured the Sales Tax to be like this:
Type: On Net Total
Rate: 10.000
Account Head: VAT
Amount: 0
Total: 0

Does I put something down for Amount? It doesn’t make sense, as different items will have different amounts. Or does amount mean percentage of tax to be applied!
This is the screenshot of Sales Invoice

This is a screenshot of Sales Tax Template.

What I find wierd is that Sales Tax is referencing my Chart of Accounts VAT (“VAT-B” instead of “IVA10%”), but that Sales Invoice is also referencing my Chart of Accounts VAt. Which in that case would mean that Sales Tax doesn’t do anything. It should be Invoice -> Sales Tax -> Chart of Accounts.

The tax if mentioned on the item takes precedence. If this particular item in Item Master is set to No Tax then it will override the Tax template. Please check your item master if the item is set to No Tax.

Also check if Rounding off is set to Yes.
We didn’t find such issues in V10 and V11.

1 Like

I think you have it a bit out of order:

  • First create an account head in Chart of Accounts for the Tax (Source of Funds -> Current Liabilities -> Duties and Taxes)

  • Then create a Tax Template pointing to the new VAT tax head account

  • Then create a Tax Rule to determine what triggers the tax

  • Then make sure the Tax Template is specified in the Taxes and Charges section of the POS profile.

Once all of this is in place, you should then see taxes applied to any NEW sales invoices you create. Previously existing sales invoices will not change.

Hope this helps…

BKM

1 Like

Sorry for the late reply. Yes you were right, the Item (had Vat at Rate = 0). This was causing the issue.
Thanks for your help!

Glad to help. Please mark the post as Solution to help others facing similar issue.