ERPNext Conference 2019* ERPNext.com Blog

Please can any one help , i can't open erpnext localhost:8000?


#1

15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:43:43 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:09 web.1 | localhost does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:40 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist
15:44:42 web.1 | 0.0.0.0 does not exist


#2

Have you installed Erpnext successfully ?


#3

what does this show…

head --lines=20 /etc/hosts

If it says
0.0.0.0 localhost
then remove or comment that/those lines and try again


#4

yes…


#5

etc/hosts file:
127.0.0.1 localhost
127.0.1.1 khaled-Latitude-5590

The following lines are desirable for IPv6 capable hosts

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters


#6

full error message:
khaled@khaled-Latitude-5590:~/frappe-bench$ bench start
19:47:17 system | redis_cache.1 started (pid=17221)
19:47:17 system | redis_socketio.1 started (pid=17223)
19:47:17 redis_cache.1 | 17225:C 07 Oct 19:47:17.438 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
19:47:17 redis_cache.1 | 17225:C 07 Oct 19:47:17.438 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=17225, just started
19:47:17 redis_cache.1 | 17225:C 07 Oct 19:47:17.438 # Configuration loaded
19:47:17 redis_socketio.1 | 17227:C 07 Oct 19:47:17.439 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
19:47:17 redis_socketio.1 | 17227:C 07 Oct 19:47:17.439 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=17227, just started
19:47:17 redis_socketio.1 | 17227:C 07 Oct 19:47:17.439 # Configuration loaded
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.439 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.439 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.439 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
19:47:17 system | web.1 started (pid=17231)
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.440 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.440 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.440 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.440 * Running mode=standalone, port=13000.
19:47:17 system | redis_queue.1 started (pid=17230)
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.440 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.440 # Server initialized
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.440 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.440 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:47:17 redis_cache.1 | 17225:M 07 Oct 19:47:17.440 * Ready to accept connections
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.441 * Running mode=standalone, port=12000.
19:47:17 system | socketio.1 started (pid=17233)
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.441 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.441 # Server initialized
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.441 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.441 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:47:17 redis_socketio.1 | 17227:M 07 Oct 19:47:17.441 * Ready to accept connections
19:47:17 redis_queue.1 | 17234:C 07 Oct 19:47:17.442 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
19:47:17 redis_queue.1 | 17234:C 07 Oct 19:47:17.442 # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=17234, just started
19:47:17 redis_queue.1 | 17234:C 07 Oct 19:47:17.442 # Configuration loaded
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.443 # You requested maxclients of 10000 requiring at least 10032 max file descriptors.
19:47:17 system | watch.1 started (pid=17245)
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.443 # Server can’t set maximum open files to 10032 because of OS error: Operation not permitted.
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.443 # Current maximum open files is 4096. maxclients has been reduced to 4064 to compensate for low ulimit. If you need higher maxclients increase ‘ulimit -n’.
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.444 * Running mode=standalone, port=11000.
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.444 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.444 # Server initialized
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.444 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.444 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
19:47:17 redis_queue.1 | 17234:M 07 Oct 19:47:17.444 * Ready to accept connections
19:47:17 system | schedule.1 started (pid=17251)
19:47:17 system | worker_short.1 started (pid=17250)
19:47:17 system | worker_default.1 started (pid=17253)
19:47:17 system | worker_long.1 started (pid=17252)
19:47:18 socketio.1 | listening on *: 9000
19:47:19 web.1 | * Running on http://0.0.0.0:8000/ (Press CTRL+C to quit)
19:47:20 web.1 | * Restarting with inotify reloader
19:47:20 watch.1 | yarn run v1.19.0
19:47:20 watch.1 | $ node rollup/watch.js
19:47:20 web.1 | * Debugger is active!
19:47:20 web.1 | * Debugger PIN: 210-590-842
19:47:21 watch.1 |
19:47:21 watch.1 | Rollup Watcher Started
19:47:21 watch.1 |
19:47:21 watch.1 | Watching…
19:47:21 watch.1 | Rebuilding frappe-web-b4.css
19:47:21 watch.1 | Rebuilding chat.js
19:47:22 watch.1 | Rebuilding frappe-recorder.min.js
19:47:24 watch.1 | Rebuilding frappe-web.min.js
19:47:25 watch.1 | Rebuilding bootstrap-4-web.min.js
19:47:26 watch.1 | Rebuilding control.min.js
19:47:28 watch.1 | Rebuilding dialog.min.js
19:47:28 watch.1 | Rebuilding desk.min.css
19:47:28 watch.1 | Rebuilding frappe-rtl.css
19:47:28 watch.1 | Rebuilding printview.css
19:47:28 watch.1 | Rebuilding desk.min.js
19:47:32 watch.1 | Rebuilding module.min.css
19:47:32 watch.1 | Rebuilding form.min.css
19:47:32 watch.1 | Rebuilding form.min.js
19:47:34 watch.1 | Rebuilding list.min.css
19:47:34 watch.1 | Rebuilding list.min.js
19:47:35 watch.1 | Rebuilding report.min.css
19:47:35 watch.1 | Rebuilding report.min.js
19:47:36 watch.1 | Rebuilding web_form.min.js
19:47:36 watch.1 | Rebuilding web_form.css
19:47:36 watch.1 | Rebuilding email.css
19:47:36 watch.1 | Rebuilding social.min.js
19:47:37 watch.1 | Rebuilding modules.min.js
19:47:37 watch.1 | Rebuilding barcode_scanner.min.js
19:47:39 watch.1 | Rebuilding data_import_tools.min.js
19:47:40 watch.1 | Rebuilding erpnext.css
19:47:40 watch.1 | Rebuilding marketplace.css
19:47:40 watch.1 | Rebuilding erpnext-web.min.js
19:47:40 watch.1 | Rebuilding erpnext-web.css
19:47:40 watch.1 | Rebuilding marketplace.min.js
19:47:42 watch.1 | Rebuilding erpnext.min.js
19:47:43 watch.1 | Rebuilding item-dashboard.min.js
19:47:50 web.1 | localhost does not exist
19:47:50 web.1 | localhost does not exist
19:47:50 web.1 | localhost does not exist
19:47:50 web.1 | localhost does not exist
19:47:55 web.1 | localhost does not exist
19:47:55 web.1 | localhost does not exist
19:47:55 web.1 | localhost does not exist
19:48:25 web.1 | localhost does not exist
19:48:25 web.1 | localhost does not exist
19:48:25 web.1 | localhost does not exist


#7

What does this show?

tail --lines=40 ~/frappe-bench/logs/web.log


#8

I can’t find web.log file in frappe-bench