Permissions - Name not set?

1.I am trying to set User permissions. Idea is to enable view for
2.Projects based on departments. I added Department as a custom link
3.to projects Now I added a user permission with - Department IS
4.“Interior” (Interior being one of the departments) I set apply user
permissions in Project Doctype

The project returns an empty list like this, any idea what is Name not set?

@vivek did you add another permission?

Please let me know how to solve the permission issue

@Hafees_Kazhunkil

Can you give your Permission Issue?
Please see following links for details of setting user permission.
https://frappe.github.io/erpnext/user/manual/en/setting-up/users-and-permissions/

If you want to give permission to Role, you can use Role Permission Manager
If you want to Limit access for a User for particular customer/project/document you can use User Permissions Manager

I added Role based permission for Lead module

Followed the tutorial https://frappe.github.io/erpnext/user/manual/en/setting-up/users-and-permissions/

I want show Lead based on Next Contact By and Lead Owner Field.

After adding Lead only administrator can see the Lead.User can not see his own Lead

Please check the screenshot.I think Name is not set is the issue ?

@Hafees_Kazhunkil
Can you check user permission manager for Lead for that logged in User.
Also which version of Frappe and ERPNext you are using.

please share screen shot of role permision manager

ERPNext: v6.27.17

Frappe Framework: v6.27.18

user permission manager - no restriction

roll permission manager

@Hafees_Kazhunkil on role permission manager please click on Select Doctypes (On role column, below Apply User Permissions) and send screen shot.

@Hafees_Kazhunkil Please remove checkbox onApply user permissions,
If you want to restrict Lead based on Owner, you can click on If Owner checkbox

In this case Lead shows based on owner.but i want to filter lead based on Next Contact By too

@Hafees_Kazhunkil in Role Permission Manger, click on Apply User Permission Manager and select checkbox If User is permitted, check if this works.

Yes.It is working now.Thank you @kolate_sambhaji.Please let me know what was the issue

1 Like

@Hafees_Kazhunkil If you click on Apply user permissions it means you are restricting user based on another dotype(Which is link field in current doctype)

The issue is, you have clicked on Apply user permissions but not selected any doctype in Select Doctypes

I think, developer from community should fix this by adding validations.

1 Like

@rmehta I did something completely different to solve my problem. Used code to change field value to which user based permission was attached.