Try ERPNext Buy Support Partners Foundation

Permission role for Employee

Im trying set a permission role for an user, but when i try save the document is showing an message and i don’t know what i have to do:

Please set User ID field in an Employee record to set Employee Role

In Employee doctype (your_host_name/desk#List/Employee you should choose/create new Employee) and User Id field, save it and then update User document

Thank you! @NMyshuk

After create new employee I cant login by ldap user. Again showing “Please set User ID field in an Employee record to set Employee Role” . My ERP version 11.1.44
Could you help me?

open your Employee document and look for the field User Id and fill it

Is it?

Hello, @masud1

You have to go to the employee document which you have created.

There you can find a section called “ERPNEXT USER”, in that field you have to select the user id of that employee and then save the document.

Please refer the screenshot below.

Hope this helps

Thanks & Regards,
Sujay

Already I did it ,but still now I can’t login by LDAP user. Thanks

have you set LDAP Settings in your system?

This is my latest erpnext LDAP setup and this setup works fine in my v11.1.11

I’m also using ERPNext 11 with LDAP integration and get this error on login, but as @NMyshukm mentioned, creating the employee and linking it to my User makes the message disappear.

Small question though : is it possible to tell ERPNext to automatically create the Employee when a new User with Employee role is created ?