ERPNext Foundation ERPNext Cloud Chat Blog Discuss Frappé* Donate

Permission base on branch wise


#1

i have 20 branch and every branch there is one Manager. So, every end of year Employee are doing Employee Appraisal ratting. when employee save the appraisal form it should be view by their respective Manager. but in my case Manager can’t view.

i have given role like below screen short.

when i uncheck the apply user permission. it display all the appraisal form which are not under their branch.
but when i check apply user permission, its not displaying

i have given branch access also. even then its not working

please help me.


#2
  1. Either you can go with Employee is permitted (Better solution)
    or
  2. You can go with an appraisal is permitted


#3

i have check (if Employee is permitted) then, its not display any thing @bhavikpatel7023

and i have given role name as Approver not HR Manager.

HR manager should see all but Approver should see only his/her employee appraisal only, not other branch


#4

You have to add user permission for that. @kinzang
Add User Permission.
Select manager name is user.
allow = Employee
Value= name of employee.


#5

Thanks @bhavikpatel7023. it work… we need to add one by one…

but what about there is 1000 employee under one branch…


#6

Add new field “Branch” in Appraisals, fetch branch from employee and make branch is permission instead of employee is permitted.


#7

i have already Branch field in Appraisal @bhavikpatel7023


#8

Add user permission.

Select manager name is user.
allow = Branch
Value= name of Branch.


#9

@bhavikpatel7023, i have done what you said but still not working


#10

Could you show it clear. whole page screenshot.


#11

screen shot


#12

is there any appraisal created with this branch???
Remove other user permission as well.


#13

@bhavikpatel7023, Why (if branch is permitted) not showing here.


#14

set branch as link field.


#15

After you will add branch as link field, you’ll get “if branch is permitted” check box here, only check “if branch is permitted” uncheck all other check-boxes.


#16

@bhavikpatel7023 thanks, now it solved.


#17