Try ERPNext Buy Support Partners Foundation

PDF print is broken and Letterhead in PDF not appearing

Hi,

I’ve recently installed v12 in a local server. Everything seems fine [so far], but I’m having trouble generating PDF prints. The PDF format is broken while the preview works just fine.

The preview looks like:

And the PDF looks like this:

All other settings related to printing is okay. What might be causing this? Can anyone enlighten me the solution?

Thanks in advance.

Regards

See if these threads are helpful:

https://discuss.erpnext.com/t/pdf-alignment-problem/34425/13

https://discuss.erpnext.com/t/pdf-email-problems-thread/11614

Thanks. I did tried to find a solution and found a thread regarding the host name. I added the hostname in the config file but still the same error.

I will read the discussions again in the morning.

Thanks for your help.

@smino

Thanks man! I found the issue.

The “libssl1.0-dev” was missing. Version was “libssl-dev”.

Thanks everyone.

1 Like

Hi fnrfarid
Please can you share details how did you fix this?

You have to add the hostname in your siteconfig file. Check this Wkhtmltopdf layout error

already done this but no luck

Its fixed there was small mistake i added
“host_name”: “https://www.yourdomain.com:portnumber