ERPNext Conference 2019* ERPNext.com Blog

PDF output font remains default


#1

I changed the font it applies changes when I print the doc but it does not if I view it as PDF, tried all possible solutions found here in both v11 and v12 still no solution found.


#2

Could you share your current configuration (what type of print format, the css snippet for the font, where is the font file located, …)? Otherwise, we can just guess…


#3

I have not added anything new everything is default, but the default font we see in view and the same default font we get in pdf is different, also if I change font, the builtin ones I still get that weird font in pdf. I have not added anything custom css or my own font.


#4

Could you share a screenshot of the preview and the pdf? Most probably a font is missing on the server, do you have cups installed?


#5

what is cups?


#6

Print view


PDF view


#7

If I change font print view show changes but pdf still shows in this above font


#8

Cups is a package for Linux that provides print drivers and font packages.

$ sudo apt install cups

How do you change the font? Considering that the preview is rendered by your browser and the pdf by wkhtmltopdf, the above changes are normals AFAIK. But if I understand you correctly, the difference is only after the change in font, correct?


#9

I think there is something wrong in the custom print format you’re using.
If you’re using custom print then can you share the script?


#10

How do I make everyone believe me I literally have not done any custom changes, I have not changed the font, I am telling that even if I change the font or not I only get that specific font in pdf. Even default font doesn’t remain same in pdf


#11

Oh Ok So your saying that even with the default standard Print format it is acting like this, where print view is showing different while PDF is showing different.

Maybe need to check the css elements on print view to see what is shows as print view. But I dont think anyone else have reported this issue earlier, Can you try a different browser or a different machine to check if it is behaving the same way ?


#12

This problem is everywhere, I have searched but none had a solution. I have tried on every browser same issue.