Pdf generate template issue

I have problem to work the the pdf feature.

please see the attached photos.
1:click " print" and “pdf” to generate .pdf file ()

  1. “print” is fine, the printed file is same as the preview.

  2. “pdf” feature works, but the printed file is not same as the preview. it seams the pdf file don’t have styled.

1 Like

My problem is very similar to these posts:

I already edit the site_config.json file to include host_name;
and ,replaced the fonts from github.com/frappe/fonts
the frappe cloud don’t have this issue, but my local demo server have problem

What did you put in host_name?

I make a site name is www.domain.com
,i put in the host_name is "host_name": "http://www.domain.com"

I have similar problem while emailing invoice right after it is created:

If you are using development setup, you also need to set the port:

“host_name”: “http://www.domain.com:8000”. However, if you are using nginx, it should’ve worked.

@anand

Even i’m facing similar problem. The alignment has gone for a toss. Specially in item description.

I did add “db_password”: “XXXXXXXXXXXXXXX”,
“host_name”: “http://XX.XX.XX.XX:8000

I’m using AWS.

It was working fine before 6.xx Upgrade. Can you please help me with this.

Thanks in advance.
Mithin

Could be firewall issue in AWS.

Fire wall issue as in? I did a reinstall on a different instance on aws and did a backup restore of the database. Still the same issue. How to solve the issue.

Thanks

I found the problem. My firewall blocked 8080 port.
It works well now.