Try ERPNext Try Frappe Cloud Buy Support Partners Foundation

Payment Entry Showing Outstanding after invoice paid up

hello
When processing a payment entry , i have noticed that the system shows an outstanding amount incorrectly on the print.
e.g invoice amount is $700 , the customer pays $700 , we process the payment against the invoice for $700 and submit.The Print shows outstanding of $700 after making payment.


The wierd thing here and i must say its weird when we first generate the payment it looks correct but then within a minute it shows as attached.

ERPNext: v13.3.1 (version-13)

Frappe Framework: v13.3.0 (version-13)

Note Tested V12 VM :


Installed Apps

ERPNext: v12.21.0 (version-12)

Frappe Framework: v12.18.0 (version-12)

so after a couple minutes :

processing payments as docs :
https://docs.erpnext.com/docs/v12/user/manual/en/accounts/payment-entry

Hi, Everyone,

This is a real problem most of us are having whereby the outstanding amount changes to “0” for about a minute of pressing a submit btn and then changes back to a full amount. It has been tested on V12 and V13 and it is still happening. I wonder how this has not been raised as an issue before, or should we say companies are not sending any Receipts to their clients…, perhaps there is a fix and please if you can share the fix on this platform.

Your help is much appreciated.

I have attached my Payment Entry above and I using ERPNEXT V13.

ERPNext: v13.3.0 (version-13)

Frappe Framework: v13.3.0 (version-13)

Hi all,

I had to come back with feedback about the outstanding balance.
All I can say is, well-done developers, the issue just disappeared after the update to the latest.
Surely this can be closed as resolved.