Page opens/remains greyed out

Hi all, first of all many thanks go to the community from me. This tool is fantastic and I am already in love with it.

I am having one issue though with currency formatting.
I have set my global system setting for currency formatting as # ###,## with decimal points set as 2.
However this has no effect.
A price entry of 1.234,56 is saved as 1.23.

I’ve found in this forum that says it uses the system setting only if the format is left blank in currency. Unfortunately I cannot try this, because when I open a specific currency from the list, say EUR, it opens up as greyed out and I cannot change anything. See the screenshot
More interestingly, the system stays like this until I perform a “reload” action.
Can you please help me out?

PS: btw I am performing all the actions as the Administrator with full permissions and rights.

Appreciated,
BI

Can you try opening the developer console and seeing if any errors come up?

In Chrome, just press Ctrl-Shift-i

This grey out typically happens when the system is thinking (for < a second), or when there is a client side bug that stops the page from loading.

Hi Ben, yes there is indeed an error but I am not the expert in this to understand.
Here is the link to the error
Would you be able to say anything to this?

Thank you,
BI

Maybe this picture gives more information: picture
Thank you.

I’m not sure I know how to help. This doesn’t look directly related to a bug in ERPNext…

Hey sorry you’re facing issues.

Could you make sure you’re updated with the latest changes? Run bench update and let me know if that helps at all. If not, then check console again, and this time click on the filename that shows up on the right side in blue, and send a screenshot of what comes next.

Gentlemen I really appreciate your time for the responses.
Here is what happens when I run “bench update” (this is the output of the second run, it fetched all the updates during the first one but afterwards the last error is the same):
Any ideas?

bicli@ubuntu:~/frappe-bench$ bench update
INFO:bench.utils:updating bench
Already up-to-date.
Requirement already satisfied (use --upgrade to upgrade): Pillow in ./env/lib/python2.7/site-packages
INFO:bench.app:pulling frappe
From https://github.com/frappe/frappe

  • branch develop -> FETCH_HEAD
    Already up-to-date.
    INFO:bench.app:pulling erpnext
    From https://github.com/frappe/erpnext
  • branch develop -> FETCH_HEAD
    Already up-to-date.
    Requirement already up-to-date: pip in ./env/lib/python2.7/site-packages
    Traceback (most recent call last):
    File “/usr/lib/python2.7/runpy.py”, line 162, in _run_module_as_main
    main”, fname, loader, pkg_name)
    File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
    exec code in run_globals
    File “/home/bicli/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 79, in
    main()
    File “/home/bicli/frappe-bench/apps/frappe/frappe/utils/bench_helper.py”, line 16, in main
    click.Group(commands=commands)(prog_name=‘bench’)
    File “/home/bicli/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 716, in call
    return self.main(*args, **kwargs)
    File “/home/bicli/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 696, in main
    rv = self.invoke(ctx)
    File “/home/bicli/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
    File “/home/bicli/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
    File “/home/bicli/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
    File “/home/bicli/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py”, line 534, in invoke
    return callback(*args, **kwargs)
    File “/home/bicli/frappe-bench/env/local/lib/python2.7/site-packages/click/decorators.py”, line 17, in new_func
    return f(get_current_context(), *args, **kwargs)
    File “/home/bicli/frappe-bench/apps/frappe/frappe/commands/init.py”, line 24, in _func
    ret = f(frappe._dict(ctx.obj), *args, **kwargs)
    File “/home/bicli/frappe-bench/apps/frappe/frappe/commands/site.py”, line 222, in backup
    odb = scheduled_backup(ignore_files=not with_files, backup_path_db=backup_path_db, backup_path_files=backup_path_files, backup_path_private_files=backup_path_private_files, force=True)
    File “/home/bicli/frappe-bench/apps/frappe/frappe/utils/backups.py”, line 164, in scheduled_backup
    odb = new_backup(older_than, ignore_files, backup_path_db=backup_path_db, backup_path_files=backup_path_files, force=force)
    File “/home/bicli/frappe-bench/apps/frappe/frappe/utils/backups.py”, line 168, in new_backup
    delete_temp_backups(older_than = frappe.conf.keep_backups_for_hours or 48)
    File “/home/bicli/frappe-bench/apps/frappe/frappe/utils/backups.py”, line 185, in delete_temp_backups
    os.remove(this_file_path)
    OSError: [Errno 21] Is a directory: ‘./site1.local/private/backups/site1.local’
    Traceback (most recent call last):
    File “/usr/local/bin/bench”, line 9, in
    load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
    File “/home/bicli/bench-repo/bench/cli.py”, line 40, in cli
    bench_command()
    File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 716, in call
    return self.main(*args, **kwargs)
    File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 696, in main
    rv = self.invoke(ctx)
    File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
    File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
    File “/usr/local/lib/python2.7/dist-packages/click/core.py”, line 534, in invoke
    return callback(*args, **kwargs)
    File “/home/bicli/bench-repo/bench/commands/update.py”, line 60, in update
    _update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force)
    File “/home/bicli/bench-repo/bench/commands/update.py”, line 89, in _update
    backup_all_sites(bench_path=bench_path)
    File “/home/bicli/bench-repo/bench/utils.py”, line 390, in backup_all_sites
    backup_site(site, bench_path=bench_path)
    File “/home/bicli/bench-repo/bench/utils.py”, line 386, in backup_site
    run_frappe_cmd(’–site’, site, ‘backup’, bench_path=bench_path)
    File “/home/bicli/bench-repo/bench/utils.py”, line 499, in run_frappe_cmd
    raise CommandFailedError(args)
    bench.utils.CommandFailedError: (’–site’, ‘site1.local’, ‘backup’)

@vjFaLk, hi I finally got bench update successfully running. Here is the screenshot: http://i.imgur.com/N6KWUWG.png
It seems like there is a problem with with a member of c.sender for currency but I cannot quite know how to solve this.

Thank you